aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-06-04 19:31:41 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-06-04 19:31:41 +0000
commit48e8d5ce034fa27a2d9e04e1ab195096562ff240 (patch)
tree36ad6b98dd90c867436c48238df8037077977f08 /lang/ghc
parent9093827413d24b8e8899db2e7617412550993938 (diff)
downloadports-48e8d5ce034fa27a2d9e04e1ab195096562ff240.tar.gz
ports-48e8d5ce034fa27a2d9e04e1ab195096562ff240.zip
lang/ghc: Depend on newer LLVM 7.0, for which upstream declares support.
PR: 246988 Submitted by: mikael
Notes
Notes: svn path=/head/; revision=537934
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 9fc89654953f..fc533fbe94d4 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -91,12 +91,16 @@ ONLY_FOR_ARCHS+= aarch64 armv6 armv7 powerpc64
BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
.endif
-.if ${GHC_VERSION_MAJOR} == 8 && ${GHC_VERSION_MINOR} <= 4
+.if ${GHC_VERSION_MAJOR} == 8 && ${GHC_VERSION_MINOR} == 4
LLVM_VERSION= 50
# Turn off for old GHCs, see PR 228727
CONFIGURE_ARGS+= --enable-dtrace=0
-.else
+.elif ${GHC_VERSION_MAJOR} == 8 && ${GHC_VERSION_MINOR} == 6
LLVM_VERSION= 60
+.elif ${GHC_VERSION_MAJOR} == 8 && ${GHC_VERSION_MINOR} == 8
+LLVM_VERSION= 70
+.else # ghc 8.10
+LLVM_VERSION= 90
.endif
.if ${ARCH} == powerpc64