aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-05-28 12:58:56 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-05-28 12:58:56 +0000
commiteeca407697e407f70c8ef5e4840d044a257693d8 (patch)
treef8d5360d1f8a68b9f6f9e5968ac439670e15d09b /lang/ghc
parent54faa52f59c3bb7a71130069cd7c012540c3d4c2 (diff)
downloadports-eeca407697e407f70c8ef5e4840d044a257693d8.tar.gz
ports-eeca407697e407f70c8ef5e4840d044a257693d8.zip
lang/ghc: Print a error message if BOOT option is enabled, but the user has no "ghc" in PATH.
PR: 246800 Submitted by: software@bertram-scharpf.de
Notes
Notes: svn path=/head/; revision=536766
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 36ef1a510ad9..9fc89654953f 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -254,6 +254,11 @@ pre-configure: apply-slist
.if empty(PORT_OPTIONS:MBOOT)
cd ${BOOT_DIR} && ${CONFIGURE_ENV} ${CONFIGURE_CMD} --prefix=${BOOT_DIR}
cd ${BOOT_DIR} && PACKAGES='' ${MAKE_CMD} install
+.else
+# otherwise, make sure we have "ghc" in PATH
+ if ! ${WHICH} -s ghc ; then \
+ echo "No 'ghc' executable is found in your PATH! Turn off BOOT option." ; false ; \
+ fi
.endif
# If DOCS are set, install HsColour in-place
.if ${PORT_OPTIONS:MDOCS}