aboutsummaryrefslogtreecommitdiff
path: root/lang/gjs
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-07-31 11:57:45 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-07-31 11:57:45 +0000
commita5f590e51d3b147b9b5085ac6a2920189b42967a (patch)
treecee27e48f57eafc0ae5948472d8e095072bb5222 /lang/gjs
parenta74217e6d9281b3d195ab0ad6e6b9434f63b6d27 (diff)
downloadports-a5f590e51d3b147b9b5085ac6a2920189b42967a.tar.gz
ports-a5f590e51d3b147b9b5085ac6a2920189b42967a.zip
The FreeBSD GNOME team presents a Glib and Gtk+ 3 update.
This update updates Glib20 to 2.36 and Gtk+ 3.8 * The gio-fam-backend port that used gamin for the GFileMonitor API is gone. It is replaced by a GIO kqueue implementation developed as part of a NetBSD GSoC 2011 project by Dimitry Matveev. * Fix a bug in the glib20 Makefile so it includes -lintl in the glib-2.0 pkgconfig file [1]. This broke static linking and newer binutils. * Add introspection USE_GNOME component which sets GI_SCANNER_DISABLE_CACHE to prevent creation of / root/.cache dir. Defaults to build & run depend, but :build and :run switches available. * New x11-toolkits/pangox-compat port and companion USE_GNOME component for pangox support which was removed from the pango port. Add it to ports still using pangox API. Exp-run by: bapt@ PR: ports/178958 [1] Submitted by: emaste@ [1]
Notes
Notes: svn path=/head/; revision=324037
Diffstat (limited to 'lang/gjs')
-rw-r--r--lang/gjs/Makefile20
-rw-r--r--lang/gjs/distinfo4
-rw-r--r--lang/gjs/pkg-plist15
3 files changed, 19 insertions, 20 deletions
diff --git a/lang/gjs/Makefile b/lang/gjs/Makefile
index 666747c100a9..ab4d0c9e4823 100644
--- a/lang/gjs/Makefile
+++ b/lang/gjs/Makefile
@@ -1,10 +1,9 @@
# Created by: Pawel Worach <pawel.worach@gmail.com>
# $FreeBSD$
-# $MCom: ports/lang/gjs/Makefile,v 1.28 2012/10/18 08:57:51 kwm Exp $
+# $MCom: ports/trunk/lang/gjs/Makefile 18581 2013-06-23 10:50:00Z kwm $
PORTNAME= gjs
-PORTVERSION= 1.32.0
-PORTREVISION= 1
+PORTVERSION= 1.34.0
CATEGORIES= lang gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -12,24 +11,21 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Javascript binding
-BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection \
- spidermonkey185>=1.8.5:${PORTSDIR}/lang/spidermonkey185
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- cairo:${PORTSDIR}/graphics/cairo \
mozjs185:${PORTSDIR}/lang/spidermonkey185
+CONFLICTS_BUILD=spidermonkey17-1.7.*
+
USE_XZ= yes
-USE_GMAKE= yes
+USES= gettext gmake pathfix pkgconfig shebangfix
USE_PYTHON_BUILD=yes
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomeprefix gnomehack intlhack glib20 ltverhack
-USES= pkgconfig gettext
+USE_GNOME= cairo glib20 gnomeprefix introspection:build \
+ intlhack ltverhack
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-post-patch:
- ${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|g' \
- ${WRKSRC}/scripts/make-tests
+SHEBANG_FILES= scripts/make-tests
.include <bsd.port.mk>
diff --git a/lang/gjs/distinfo b/lang/gjs/distinfo
index a392b1e47c27..25d125ca9618 100644
--- a/lang/gjs/distinfo
+++ b/lang/gjs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/gjs-1.32.0.tar.xz) = b9f1dc156c15806824c936bb08ddc5048f52f6921654146c47025a62457108c0
-SIZE (gnome3/gjs-1.32.0.tar.xz) = 464372
+SHA256 (gnome3/gjs-1.34.0.tar.xz) = 3d62c717a0522a36c6faa1eb021872255e3cd285a72786afe23b7cca2e3084cb
+SIZE (gnome3/gjs-1.34.0.tar.xz) = 474004
diff --git a/lang/gjs/pkg-plist b/lang/gjs/pkg-plist
index 45599cf6975c..1a5a0558e8ba 100644
--- a/lang/gjs/pkg-plist
+++ b/lang/gjs/pkg-plist
@@ -6,6 +6,7 @@ include/gjs-1.0/gi/closure.h
include/gjs-1.0/gi/enumeration.h
include/gjs-1.0/gi/foreign.h
include/gjs-1.0/gi/function.h
+include/gjs-1.0/gi/gerror.h
include/gjs-1.0/gi/gtype.h
include/gjs-1.0/gi/interface.h
include/gjs-1.0/gi/keep-alive.h
@@ -26,7 +27,7 @@ include/gjs-1.0/gjs/importer.h
include/gjs-1.0/gjs/jsapi-util.h
include/gjs-1.0/gjs/mem.h
include/gjs-1.0/gjs/native.h
-lib/girepository-1.0/GjsDBus-1.0.typelib
+include/gjs-1.0/gjs/type-module.h
lib/gjs-1.0/cairoNative.a
lib/gjs-1.0/cairoNative.la
lib/gjs-1.0/cairoNative.so
@@ -39,6 +40,9 @@ lib/gjs-1.0/dbusNative.so
lib/gjs-1.0/debugger.a
lib/gjs-1.0/debugger.la
lib/gjs-1.0/debugger.so
+lib/gjs-1.0/formatNative.a
+lib/gjs-1.0/formatNative.la
+lib/gjs-1.0/formatNative.so
lib/gjs-1.0/gettextNative.a
lib/gjs-1.0/gettextNative.la
lib/gjs-1.0/gettextNative.so
@@ -51,14 +55,11 @@ lib/gjs-1.0/mainloop.so
lib/gjs-1.0/system.a
lib/gjs-1.0/system.la
lib/gjs-1.0/system.so
+lib/gjs/girepository-1.0/GjsPrivate-1.0.typelib
lib/libgjs-dbus.a
lib/libgjs-dbus.la
lib/libgjs-dbus.so
lib/libgjs-dbus.so.0
-lib/libgjs-gdbus.a
-lib/libgjs-gdbus.la
-lib/libgjs-gdbus.so
-lib/libgjs-gdbus.so.0
lib/libgjs.a
lib/libgjs.la
lib/libgjs.so
@@ -66,10 +67,10 @@ lib/libgjs.so.0
libdata/pkgconfig/gjs-1.0.pc
libdata/pkgconfig/gjs-dbus-1.0.pc
libdata/pkgconfig/gjs-internals-1.0.pc
-share/gir-1.0/GjsDBus-1.0.gir
share/gjs-1.0/cairo.js
share/gjs-1.0/dbus.js
share/gjs-1.0/gettext.js
+share/gjs-1.0/format.js
share/gjs-1.0/jsUnit.js
share/gjs-1.0/lang.js
share/gjs-1.0/overrides/GLib.js
@@ -83,7 +84,9 @@ share/gjs-1.0/tweener/tweener.js
@dirrm share/gjs-1.0/tweener
@dirrm share/gjs-1.0/overrides
@dirrm share/gjs-1.0
+@dirrm lib/gjs/girepository-1.0
@dirrm lib/gjs-1.0
+@dirrm lib/gjs
@dirrm include/gjs-1.0/gjs
@dirrm include/gjs-1.0/gjs-dbus
@dirrm include/gjs-1.0/gi