aboutsummaryrefslogtreecommitdiff
path: root/lang/gnatdroid-binutils-x86
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-12-01 13:52:31 +0000
committerJohn Marino <marino@FreeBSD.org>2015-12-01 13:52:31 +0000
commitdb357a8aa8f49102a3cbe5deae16577fe8d185c3 (patch)
treeddd2e71f849686d4ab02e113f411bcb38f36cd7d /lang/gnatdroid-binutils-x86
parent0a18690ce9c0b97753cef8fef7d2d755604109ce (diff)
downloadports-db357a8aa8f49102a3cbe5deae16577fe8d185c3.tar.gz
ports-db357a8aa8f49102a3cbe5deae16577fe8d185c3.zip
lang/gnatdroid-binutils-x86: Attempt to fix build on i386
This should fix i386 pkg-plist check failures, but I haven't tested it due to not having access to FreeBSD i386 at this moment.
Notes
Notes: svn path=/head/; revision=402735
Diffstat (limited to 'lang/gnatdroid-binutils-x86')
-rw-r--r--lang/gnatdroid-binutils-x86/Makefile2
-rw-r--r--lang/gnatdroid-binutils-x86/pkg-plist78
2 files changed, 41 insertions, 39 deletions
diff --git a/lang/gnatdroid-binutils-x86/Makefile b/lang/gnatdroid-binutils-x86/Makefile
index 1ebf21f14688..de1d74bb3e58 100644
--- a/lang/gnatdroid-binutils-x86/Makefile
+++ b/lang/gnatdroid-binutils-x86/Makefile
@@ -15,4 +15,6 @@ MASTERDIR= ${.CURDIR}/../../lang/gnatdroid-binutils
PLIST= ${.CURDIR}/pkg-plist
DESCR= ${.CURDIR}/pkg-descr
+PLIST_SUB= AMD64=${ARCH:S/i386/"@comment "/:S/${ARCH}/""/}
+
.include "${MASTERDIR}/Makefile"
diff --git a/lang/gnatdroid-binutils-x86/pkg-plist b/lang/gnatdroid-binutils-x86/pkg-plist
index ab0740ba6754..0c6675a6e780 100644
--- a/lang/gnatdroid-binutils-x86/pkg-plist
+++ b/lang/gnatdroid-binutils-x86/pkg-plist
@@ -49,45 +49,45 @@
%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_i386.xsw
%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_i386.xu
%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_i386.xw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.x
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xbn
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xd
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xdc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xdw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xn
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xr
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xs
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xsc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xsw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xu
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.x
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xbn
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xd
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xdc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xdw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xn
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xr
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xs
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xsc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xsw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xu
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.x
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xbn
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xd
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xdc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xdw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xn
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xr
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xs
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xsc
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xsw
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xu
-%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.x
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xbn
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xd
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xdc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xdw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xn
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xr
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xs
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xsc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xsw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xu
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_k1om.xw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.x
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xbn
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xd
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xdc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xdw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xn
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xr
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xs
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xsc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xsw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xu
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_l1om.xw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.x
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xbn
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xd
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xdc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xdw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xn
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xr
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xs
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xsc
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xsw
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xu
+%%AMD64%%%%BRANCH2%%/%%TARGET%%/lib/ldscripts/elf_x86_64.xw
%%BRANCH2%%/%%TARGET%%/lib/ldscripts/i386linux.x
%%BRANCH2%%/%%TARGET%%/lib/ldscripts/i386linux.xbn
%%BRANCH2%%/%%TARGET%%/lib/ldscripts/i386linux.xn