aboutsummaryrefslogtreecommitdiff
path: root/lang/gnu-cobol
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2017-12-25 10:58:40 +0000
committerJohan van Selst <johans@FreeBSD.org>2017-12-25 10:58:40 +0000
commitfa4464cdb193122a717d6e1a6f135e2980d36dd9 (patch)
tree6bff22eb861b577b4573a65ab7a6e48e83db3140 /lang/gnu-cobol
parent7227864d65ee933830d17cf1c548b90289a950aa (diff)
downloadports-fa4464cdb193122a717d6e1a6f135e2980d36dd9.tar.gz
ports-fa4464cdb193122a717d6e1a6f135e2980d36dd9.zip
- Update to 2.2
- Add LICENSE PR: ports/224494 Submitted by: wen
Notes
Notes: svn path=/head/; revision=457215
Diffstat (limited to 'lang/gnu-cobol')
-rw-r--r--lang/gnu-cobol/Makefile13
-rw-r--r--lang/gnu-cobol/distinfo5
-rw-r--r--lang/gnu-cobol/pkg-plist46
3 files changed, 50 insertions, 14 deletions
diff --git a/lang/gnu-cobol/Makefile b/lang/gnu-cobol/Makefile
index 4f54dd443de1..a20db804a088 100644
--- a/lang/gnu-cobol/Makefile
+++ b/lang/gnu-cobol/Makefile
@@ -2,22 +2,27 @@
# $FreeBSD$
PORTNAME= gnu-cobol
-PORTVERSION= 1.1
-PORTREVISION= 2
+PORTVERSION= 2.2
CATEGORIES= lang
MASTER_SITES= GNU/gnucobol
+DISTNAME= gnucobol-${PORTVERSION}
MAINTAINER= johans@FreeBSD.org
COMMENT= Open-source COBOL compiler
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= multi
+
LIB_DEPENDS= libgmp.so:math/gmp
-USES= bdb gmake libtool ncurses
+USES= bdb gmake libtool ncurses tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-INFO= gnu-cobol
+INFO= gnucobol
+DATADIR= ${PREFIX}/share/gnucobol
+INSTALL_TARGET= install-strip
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/gnu-cobol/distinfo b/lang/gnu-cobol/distinfo
index 0956b57975c7..8aa989bbc03b 100644
--- a/lang/gnu-cobol/distinfo
+++ b/lang/gnu-cobol/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnu-cobol-1.1.tar.gz) = bd319c0d001e85835c8501ad74c9de0052fe82b8a38b4530f41b49b2af028b9d
-SIZE (gnu-cobol-1.1.tar.gz) = 1093343
+TIMESTAMP = 1513844573
+SHA256 (gnucobol-2.2.tar.xz) = dc18fc45c269debfe86a4bbe20a7250983cba6238ea1917e135df5926cd024a0
+SIZE (gnucobol-2.2.tar.xz) = 1604648
diff --git a/lang/gnu-cobol/pkg-plist b/lang/gnu-cobol/pkg-plist
index 05b8cfda15a2..2bd5176928a9 100644
--- a/lang/gnu-cobol/pkg-plist
+++ b/lang/gnu-cobol/pkg-plist
@@ -2,23 +2,53 @@ bin/cob-config
bin/cobc
bin/cobcrun
include/libcob.h
-include/libcob/codegen.h
+include/libcob/cobgetopt.h
include/libcob/common.h
include/libcob/exception.def
-include/libcob/system.def
-lib/gnu-cobol/CBL_OC_DUMP.so
+lib/gnucobol/CBL_OC_DUMP.so
lib/libcob.a
lib/libcob.so
-lib/libcob.so.1
-lib/libcob.so.1.0.0
+lib/libcob.so.4
+lib/libcob.so.4.0.0
+man/man1/cobc.1.gz
+man/man1/cobcrun.1.gz
+%%DATADIR%%/config/acu-strict.conf
+%%DATADIR%%/config/acu.conf
+%%DATADIR%%/config/acu.words
+%%DATADIR%%/config/bs2000-strict.conf
%%DATADIR%%/config/bs2000.conf
+%%DATADIR%%/config/bs2000.words
%%DATADIR%%/config/cobol2002.conf
+%%DATADIR%%/config/cobol2002.words
+%%DATADIR%%/config/cobol2014.conf
+%%DATADIR%%/config/cobol2014.words
%%DATADIR%%/config/cobol85.conf
+%%DATADIR%%/config/cobol85.words
%%DATADIR%%/config/default.conf
+%%DATADIR%%/config/ibm-strict.conf
%%DATADIR%%/config/ibm.conf
+%%DATADIR%%/config/ibm.words
+%%DATADIR%%/config/lax.conf-inc
+%%DATADIR%%/config/mf-strict.conf
%%DATADIR%%/config/mf.conf
+%%DATADIR%%/config/mf.words
+%%DATADIR%%/config/mvs-strict.conf
%%DATADIR%%/config/mvs.conf
+%%DATADIR%%/config/mvs.words
+%%DATADIR%%/config/rm-strict.conf
+%%DATADIR%%/config/rm.conf
+%%DATADIR%%/config/rm.words
+%%DATADIR%%/config/runtime.cfg
+%%DATADIR%%/config/runtime_empty.cfg
+%%DATADIR%%/config/xopen.conf
%%DATADIR%%/copy/screenio.cpy
-%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnu-cobol.mo
-%%NLS%%share/locale/en@quot/LC_MESSAGES/gnu-cobol.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gnu-cobol.mo
+%%DATADIR%%/copy/sqlca.cpy
+%%DATADIR%%/copy/sqlda.cpy
+%%NLS%%share/locale/de/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnucobol.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gnucobol.mo