aboutsummaryrefslogtreecommitdiff
path: root/lang/gnustep-base
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-13 12:37:57 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-13 12:37:57 +0000
commit785db2d60520e2d15f44563708b8fcc59485ea7c (patch)
tree6224d02c930666aef9c444dbffb68b14d2527376 /lang/gnustep-base
parent38e17ebac9eb65e225a13d02e5aa40b03d5d44ff (diff)
downloadports-785db2d60520e2d15f44563708b8fcc59485ea7c.tar.gz
ports-785db2d60520e2d15f44563708b8fcc59485ea7c.zip
- Do not hardcode dependency on GnuTLS (security/gnutls). While preferred,
it is not required, and limited functionality can be achieved by using OpenSSL instead (per the comment in configure script); both providers can be turned off with --disable-{tls,openssl} switches - Similarly, make ICU support optional as well and replace cryptic regex in BASEVERSION assignment with :R while here Approved by: theraven (maintainer)
Notes
Notes: svn path=/head/; revision=406037
Diffstat (limited to 'lang/gnustep-base')
-rw-r--r--lang/gnustep-base/Makefile44
-rw-r--r--lang/gnustep-base/pkg-plist3
2 files changed, 30 insertions, 17 deletions
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 632a749abf3a..9483981c75a5 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -12,27 +12,15 @@ COMMENT= GNUstep Foundation library
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
-OPTIONS_RADIO= ZEROCONF
-OPTIONS_RADIO_ZEROCONF= AVAHI MDNS
-OPTIONS_DEFAULT= AVAHI
-
-NOZEROCONF_DESC= Disable Zeroconf (Bonjour) support
-AVAHI_DESC?= Zeroconf via Avahi (preferred)
-MDNS_DESC?= Zeroconf via mDNSResponder
-
LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
LIB_DEPENDS+= libxml2.so:${PORTSDIR}/textproc/libxml2
LIB_DEPENDS+= libxslt.so:${PORTSDIR}/textproc/libxslt
LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
-LIB_DEPENDS+= libgnutls-openssl.so:${PORTSDIR}/security/gnutls
-LIB_DEPENDS+= libicuuc.so:${PORTSDIR}/devel/icu
LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-procfs --disable-openssl --enable-tls \
- --with-tls-prefix=${LOCALBASE} TLS_CONFIG="pkg-config -gnutls"\
- --disable-mixedabi
-CONFIGURE_ENV+= OBJCFLAGS='-fobjc-runtime=gnustep-1.7 -fblocks'
+CONFIGURE_ARGS= --disable-procfs --disable-mixedabi
+CONFIGURE_ENV= OBJCFLAGS='-fobjc-runtime=gnustep-1.7 -fblocks'
USES= pkgconfig iconv gnustep
USE_GNUSTEP= build
USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
@@ -42,7 +30,29 @@ MAKE_FLAGS= OPTFLAG="${CFLAGS}"
ETCDIR= ${LOCALBASE}/etc
STAGEHEADER= ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Headers
-PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
+PLIST_SUB+= BASEVERSION=${PORTVERSION:R}
+
+OPTIONS_DEFINE= ICU
+OPTIONS_RADIO= SSL ZEROCONF
+OPTIONS_RADIO_SSL= GNUTLS OPENSSL
+OPTIONS_RADIO_ZEROCONF= AVAHI MDNS
+OPTIONS_DEFAULT= ICU GNUTLS AVAHI
+OPTIONS_SUB= yes
+
+ZEROCONF_DESC= Zeroconf (Bonjour) support
+AVAHI_DESC= Zeroconf via Avahi (preferred)
+MDNS_DESC= Zeroconf via mDNSResponder
+
+ICU_LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
+ICU_CONFIGURE_OFF= --disable-icu
+
+GNUTLS_LIB_DEPENDS= libgnutls-openssl.so:${PORTSDIR}/security/gnutls
+GNUTLS_CONFIGURE_ON= --with-tls-prefix=${LOCALBASE} \
+ TLS_CONFIG="pkg-config -gnutls"
+GNUTLS_CONFIGURE_OFF= --disable-tls
+
+OPENSSL_USE= OPENSSL=yes
+OPENSSL_CONFIGURE_OFF= --disable-openssl
.include <bsd.port.options.mk>
@@ -57,8 +67,8 @@ CONFIGURE_ARGS+= --disable-zeroconf
.endif
post-extract:
- @${REINPLACE_CMD} -e "s|/usr/local/|${LOCALBASE}/|" \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|/usr/local/|${LOCALBASE}/| ; \
+ s|HAVE_TLS|HAVE_GNUTLS|" ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${FILESDIR}/gdomap_if ${STAGEDIR}${ETCDIR}
diff --git a/lang/gnustep-base/pkg-plist b/lang/gnustep-base/pkg-plist
index dd41c7afdef1..e49d389383d4 100644
--- a/lang/gnustep-base/pkg-plist
+++ b/lang/gnustep-base/pkg-plist
@@ -823,6 +823,9 @@ GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources
GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/NSTimeZones/zones/W-SU
GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/NSTimeZones/zones/WET
GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/NSTimeZones/zones/Zulu
+%%OPENSSL%%GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/SSL.bundle/Resources/Info-gnustep.plist
+%%OPENSSL%%GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/SSL.bundle/SSL
+%%OPENSSL%%GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/SSL.bundle/stamp.make
GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/Spanish.lproj/Localizable.strings
GNUstep/System/Library/Libraries/gnustep-base/Versions/%%BASEVERSION%%/Resources/TraditionalChinese.lproj/Localizable.strings
GNUstep/System/Library/Libraries/libgnustep-base.so