aboutsummaryrefslogtreecommitdiff
path: root/lang/gnustep-guile/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1999-09-09 10:25:57 +0000
committerThomas Gellekum <tg@FreeBSD.org>1999-09-09 10:25:57 +0000
commit265250ea054105fbc1975a7403d952a1341c9e44 (patch)
tree0d05091c3182603c46f0767053597389ae8d519e /lang/gnustep-guile/Makefile
parentfaf977b05328e3dac1e546250ef4e2ba8012c733 (diff)
downloadports-265250ea054105fbc1975a7403d952a1341c9e44.tar.gz
ports-265250ea054105fbc1975a7403d952a1341c9e44.zip
Notes
Diffstat (limited to 'lang/gnustep-guile/Makefile')
-rw-r--r--lang/gnustep-guile/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/lang/gnustep-guile/Makefile b/lang/gnustep-guile/Makefile
index 65004447de71..4421a6be45da 100644
--- a/lang/gnustep-guile/Makefile
+++ b/lang/gnustep-guile/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: gnustep
-# Version required: 0.5.5
+# Version required: 0.6.0
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= gstep-core-0.5.5
-PKGNAME= gnustep-0.5.5
+DISTNAME= gstep-core-0.6.0
+PKGNAME= gnustep-0.6.0
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/ \
ftp://ftp.peanuts.org/Mirrors/GNUstep/gnustep/core/
@@ -17,27 +17,17 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
-BROKEN= "Sets PREFIX in the Makefile"
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 300000
BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.endif
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
-.endif
-GNU_HOST= freebsd${OSREL}
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} GNU_HOST=${GNU_HOST}
-
-WRKSRC= ${WRKDIR}/gstep-0.5.5
+USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
-CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xraw \
+CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
@@ -47,6 +37,13 @@ USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
-USE_NEWGCC= yes
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+GNU_HOST= freebsd${OSREL}
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} GNU_HOST=${GNU_HOST}
.include <bsd.port.post.mk>