aboutsummaryrefslogtreecommitdiff
path: root/lang/gscheme
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-18 09:55:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-18 09:55:59 +0000
commit935421d20f0298fe6ee095537b94ae0715577648 (patch)
treeae201c6746deb392fa1ad7a5816079cb9e4d9a77 /lang/gscheme
parent577d359b5f27de779ac35847900c58fb2c20703b (diff)
downloadports-935421d20f0298fe6ee095537b94ae0715577648.tar.gz
ports-935421d20f0298fe6ee095537b94ae0715577648.zip
A GNUstep-aware scheme interpreter. You need libflex installed on your system.
Includes many examples, e.g. the sieve of Erathostenes to compute primes, a Koch curve plotter, mandelbrot set, graphs of various functions etc. GScheme is fully tail recursive. The garbage collector bypasses GNUstep's retain/release mechanism in order to deal with circular data structures. GScheme is document-based and you can edit more than one file at the same time. WWW: http://www.gnustep.it/marko/GScheme/index.html
Notes
Notes: svn path=/head/; revision=177497
Diffstat (limited to 'lang/gscheme')
-rw-r--r--lang/gscheme/Makefile31
-rw-r--r--lang/gscheme/distinfo3
-rw-r--r--lang/gscheme/pkg-descr8
-rw-r--r--lang/gscheme/pkg-plist10
4 files changed, 52 insertions, 0 deletions
diff --git a/lang/gscheme/Makefile b/lang/gscheme/Makefile
new file mode 100644
index 000000000000..4d78331b9d2b
--- /dev/null
+++ b/lang/gscheme/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gscheme
+# Date created: 17 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gscheme
+PORTVERSION= 0.5
+CATEGORIES= lang
+MASTER_SITES= http://www.gnustep.it/marko/GScheme/
+DISTNAME= GScheme
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= GNUstep-aware scheme interpreter
+
+#WRKSRC= ${WRKDIR}/X
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE=
+ALL_TARGET=
+
+post-install:
+ ${RM} -f ${GNUSTEP_PREFIX}/Local/Applications/GScheme.app/Resources/library.scm~
+
+.include <bsd.port.mk>
diff --git a/lang/gscheme/distinfo b/lang/gscheme/distinfo
new file mode 100644
index 000000000000..6c6240904945
--- /dev/null
+++ b/lang/gscheme/distinfo
@@ -0,0 +1,3 @@
+MD5 (GScheme.tgz) = efaa0875365127174ad6c6d1a3471388
+SHA256 (GScheme.tgz) = f9bcff716eb4569c19f03958ce9cb6434f314959ee4a2f9f0abd0d54df04c1ea
+SIZE (GScheme.tgz) = 92641
diff --git a/lang/gscheme/pkg-descr b/lang/gscheme/pkg-descr
new file mode 100644
index 000000000000..9e6d670fd2e9
--- /dev/null
+++ b/lang/gscheme/pkg-descr
@@ -0,0 +1,8 @@
+A GNUstep-aware scheme interpreter. You need libflex installed on your system.
+Includes many examples, e.g. the sieve of Erathostenes to compute primes,
+a Koch curve plotter, mandelbrot set, graphs of various functions etc.
+GScheme is fully tail recursive. The garbage collector bypasses GNUstep's
+retain/release mechanism in order to deal with circular data structures.
+GScheme is document-based and you can edit more than one file at the same time.
+
+WWW: http://www.gnustep.it/marko/GScheme/index.html
diff --git a/lang/gscheme/pkg-plist b/lang/gscheme/pkg-plist
new file mode 100644
index 000000000000..b69c8b99535e
--- /dev/null
+++ b/lang/gscheme/pkg-plist
@@ -0,0 +1,10 @@
+Local/Applications/GScheme.app/GScheme
+Local/Applications/GScheme.app/Resources/GScheme.desktop
+Local/Applications/GScheme.app/Resources/GScheme.tiff
+Local/Applications/GScheme.app/Resources/Info-gnustep.plist
+Local/Applications/GScheme.app/Resources/lambda1.tiff
+Local/Applications/GScheme.app/Resources/library.scm
+Local/Applications/GScheme.app/library_paths.openapp
+Local/Applications/GScheme.app/stamp.make
+@dirrm Local/Applications/GScheme.app/Resources
+@dirrm Local/Applications/GScheme.app