aboutsummaryrefslogtreecommitdiff
path: root/lang/guile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-02 12:16:12 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-06-02 12:16:12 +0000
commite0471dcdf8bdbbd18edbc5da972212c25691a520 (patch)
tree89897f7a04a76a419a12aaca1452cc6d1b19a0a4 /lang/guile
parentd0f84703d149734ee7a81898902369e7b17aa113 (diff)
downloadports-e0471dcdf8bdbbd18edbc5da972212c25691a520.tar.gz
ports-e0471dcdf8bdbbd18edbc5da972212c25691a520.zip
lang/guile: Remove USE_AUTOTOOLS
- Add PORTSCOUT variable to limit within 1.X.X - Fix patch files to reflect 'make makepatch'
Notes
Notes: svn path=/head/; revision=388323
Diffstat (limited to 'lang/guile')
-rw-r--r--lang/guile/Makefile5
-rw-r--r--lang/guile/files/patch-configure.in16
-rw-r--r--lang/guile/files/patch-doc__goops__goops.texi6
-rw-r--r--lang/guile/files/patch-doc__r5rs__r5rs.texi4
-rw-r--r--lang/guile/files/patch-doc__ref__fdl.texi6
-rw-r--r--lang/guile/files/patch-doc__ref__gh.texi6
-rw-r--r--lang/guile/files/patch-doc__tutorial__guile-tut.texi10
-rw-r--r--lang/guile/files/patch-libguile_____scm.h (renamed from lang/guile/files/patch-libguile___scm.h)6
-rw-r--r--lang/guile/files/patch-libguile_c-tokenize.c4
-rw-r--r--lang/guile/files/patch-libguile_eval.c6
-rw-r--r--lang/guile/files/patch-libguile_gc.c6
-rw-r--r--lang/guile/files/patch-libguile_gc__os__dep.c (renamed from lang/guile/files/patch-libguile_gc_os_dep.c)32
-rw-r--r--lang/guile/files/patch-libguile_gen-scmconfig.c6
-rw-r--r--lang/guile/files/patch-libguile_guile-snarf.in4
-rw-r--r--lang/guile/files/patch-libguile_numbers.c6
-rw-r--r--lang/guile/files/patch-libguile_pthread-threads.h4
-rw-r--r--lang/guile/files/patch-libguile_read.c4
-rw-r--r--lang/guile/files/patch-libguile_threads.c8
18 files changed, 70 insertions, 69 deletions
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index 59831da0acef..9ecaf9f60383 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -18,14 +18,14 @@ LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
CONFLICTS_INSTALL= guile2-[0-9]*
-USES= gmake libtool makeinfo ncurses pathfix
-USE_AUTOTOOLS= autoheader
+USES= autoreconf gmake libtool makeinfo ncurses pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CFLAGS+= -fwrapv
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+PORTSCOUT= limit:^1\.
PLIST_SUB= GUILE_VER=${PORTVERSION:R}
@@ -49,6 +49,7 @@ post-patch:
@cd ${WRKSRC} ; \
${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g' ${REINPLACE_FILES}
@${REINPLACE_CMD} -e 's|2.68|${AUTOCONF_VERSION}|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|$$(libdir)|$$(libdir)data|g' ${WRKSRC}/Makefile.am
@${TOUCH} ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/lang/guile/files/patch-configure.in b/lang/guile/files/patch-configure.in
index e27f48d3263c..c88f33fab7ea 100644
--- a/lang/guile/files/patch-configure.in
+++ b/lang/guile/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2010-12-13 18:24:39.000000000 +0100
-+++ configure.in 2011-07-31 13:17:56.000000000 +0200
-@@ -659,7 +659,7 @@
+--- configure.in.orig 2010-12-13 17:24:39 UTC
++++ configure.in
+@@ -659,7 +659,7 @@ AC_SUBST([SCM_I_GSC_HAVE_STRUCT_DIRENT64
#
AC_CHECK_HEADERS([complex.h fenv.h io.h libc.h limits.h malloc.h memory.h process.h string.h \
regex.h rxposix.h rx/rxposix.h sys/dir.h sys/ioctl.h sys/select.h \
@@ -9,7 +9,7 @@
sys/utime.h time.h unistd.h utime.h pwd.h grp.h sys/utsname.h \
direct.h strings.h machine/fpu.h])
-@@ -762,6 +762,7 @@
+@@ -762,6 +762,7 @@ AC_CHECK_FUNCS([DINFINITY DQNAN cexp chs
# sys/param.h - not in mingw
# pthread.h - only available with pthreads. ACX_PTHREAD doesn't
# check this specifically, we need it for the timespec test below.
@@ -17,7 +17,7 @@
# sethostname - the function itself check because it's not in mingw,
# the DECL is checked because Solaris 10 doens't have in any header
# strncasecmp - on NetBSD 1.6 the symbol is available in libc but the
-@@ -779,7 +780,7 @@
+@@ -779,7 +780,7 @@ AC_CHECK_FUNCS([DINFINITY DQNAN cexp chs
# vsnprintf - on AIX 5.3, the declaration is only visible with
# `_XOPEN_SOURCE >= 500' or `_ISOC99_SOURCE'.
#
@@ -26,7 +26,7 @@
AC_CHECK_FUNCS(chroot flock getlogin cuserid getpriority setpriority getpass sethostname gethostname)
AC_CHECK_DECLS([sethostname, strncasecmp, unsetenv, hstrerror, cuserid, flock, vsnprintf])
-@@ -1298,9 +1299,11 @@
+@@ -1298,9 +1299,11 @@ case "$with_threads" in
# all; not present on MacOS X or Solaris 10
# pthread_get_stackaddr_np - "np" meaning "non portable" says it
# all; specific to MacOS X
@@ -39,7 +39,7 @@
# On past versions of Solaris, believe 8 through 10 at least, you
# had to write "pthread_once_t foo = { PTHREAD_ONCE_INIT };".
-@@ -1315,7 +1318,7 @@
+@@ -1315,7 +1318,7 @@ case "$with_threads" in
if test "$GCC" = "yes"; then
# Since GCC only issues a warning for missing braces, so we need
# `-Werror' to catch it.
@@ -48,7 +48,7 @@
fi
AC_CACHE_CHECK([whether PTHREAD_ONCE_INIT needs braces],
-@@ -1466,7 +1469,7 @@
+@@ -1466,7 +1469,7 @@ case "$GCC" in
# not be "warning free"
if test "${GUILE_ERROR_ON_WARNING}" = yes
then
diff --git a/lang/guile/files/patch-doc__goops__goops.texi b/lang/guile/files/patch-doc__goops__goops.texi
index b056263c08a1..cb359eb7b12a 100644
--- a/lang/guile/files/patch-doc__goops__goops.texi
+++ b/lang/guile/files/patch-doc__goops__goops.texi
@@ -1,6 +1,6 @@
---- ./doc/goops/goops.texi.orig 2010-12-13 18:24:39.000000000 +0100
-+++ ./doc/goops/goops.texi 2014-06-25 22:51:56.949463365 +0200
-@@ -131,7 +131,7 @@
+--- doc/goops/goops.texi.orig 2010-12-13 17:24:39 UTC
++++ doc/goops/goops.texi
+@@ -131,7 +131,7 @@ info (goops.info) and texinfo format.
@end menu
@node Running GOOPS, Methods, Getting Started, Getting Started
diff --git a/lang/guile/files/patch-doc__r5rs__r5rs.texi b/lang/guile/files/patch-doc__r5rs__r5rs.texi
index 6f02188c460f..be7c4a765759 100644
--- a/lang/guile/files/patch-doc__r5rs__r5rs.texi
+++ b/lang/guile/files/patch-doc__r5rs__r5rs.texi
@@ -1,5 +1,5 @@
---- ./doc/r5rs/r5rs.texi.orig 2010-12-08 10:06:50.000000000 +0100
-+++ ./doc/r5rs/r5rs.texi 2014-06-25 22:52:36.456460772 +0200
+--- doc/r5rs/r5rs.texi.orig 2010-12-08 09:06:50 UTC
++++ doc/r5rs/r5rs.texi
@@ -116,9 +116,6 @@
diff --git a/lang/guile/files/patch-doc__ref__fdl.texi b/lang/guile/files/patch-doc__ref__fdl.texi
index bc3e9e643d97..9df3c18cd4e6 100644
--- a/lang/guile/files/patch-doc__ref__fdl.texi
+++ b/lang/guile/files/patch-doc__ref__fdl.texi
@@ -1,6 +1,6 @@
---- ./doc/ref/fdl.texi.orig 2010-12-13 18:24:39.000000000 +0100
-+++ ./doc/ref/fdl.texi 2014-06-25 22:53:08.813111590 +0200
-@@ -408,7 +408,7 @@
+--- doc/ref/fdl.texi.orig 2010-12-13 17:24:39 UTC
++++ doc/ref/fdl.texi
+@@ -408,7 +408,7 @@ as a draft) by the Free Software Foundat
@end enumerate
@page
diff --git a/lang/guile/files/patch-doc__ref__gh.texi b/lang/guile/files/patch-doc__ref__gh.texi
index fa7c17e9a270..a3fe80cd33bc 100644
--- a/lang/guile/files/patch-doc__ref__gh.texi
+++ b/lang/guile/files/patch-doc__ref__gh.texi
@@ -1,6 +1,6 @@
---- ./doc/ref/gh.texi.orig 2010-12-13 18:24:39.000000000 +0100
-+++ ./doc/ref/gh.texi 2014-06-25 22:53:50.371137099 +0200
-@@ -995,8 +995,6 @@
+--- doc/ref/gh.texi.orig 2010-12-13 17:24:39 UTC
++++ doc/ref/gh.texi
+@@ -995,8 +995,6 @@ These correspond to the Scheme @code{(co
@deftypefun SCM gh_car (SCM @var{obj})
@deftypefunx SCM gh_cdr (SCM @var{obj})
diff --git a/lang/guile/files/patch-doc__tutorial__guile-tut.texi b/lang/guile/files/patch-doc__tutorial__guile-tut.texi
index dfbaada1b3a0..8d475d8e6728 100644
--- a/lang/guile/files/patch-doc__tutorial__guile-tut.texi
+++ b/lang/guile/files/patch-doc__tutorial__guile-tut.texi
@@ -1,6 +1,6 @@
---- ./doc/tutorial/guile-tut.texi.orig 2010-12-13 18:24:39.000000000 +0100
-+++ ./doc/tutorial/guile-tut.texi 2014-06-25 22:55:00.775514198 +0200
-@@ -446,7 +446,7 @@
+--- doc/tutorial/guile-tut.texi.orig 2010-12-13 17:24:39 UTC
++++ doc/tutorial/guile-tut.texi
+@@ -446,7 +446,7 @@ get started, look at the books @cite{Sim
Schemer} from that list.}
@@ -9,7 +9,7 @@
@cindex hello world
Our first program is the typical Scheme "hello world" program. Put the
-@@ -535,12 +535,12 @@
+@@ -535,12 +535,12 @@ guile> @kbd{(memq 4 ls)}
guile> @kbd{(if (memq 4 ls)
(display "hey, it's true!\n")
(display "dude, it's false\n"))}
@@ -24,7 +24,7 @@
@result{}
guile> @kbd{(memq 4 (reverse ls))}
@result{} (4 3 2 1)
-@@ -656,9 +656,9 @@
+@@ -656,9 +656,9 @@ And then invoke it with
(represent-matrix m
(lambda (x) (begin (display x) (display " ")))
(lambda (l) (begin (display "\n"))))
diff --git a/lang/guile/files/patch-libguile___scm.h b/lang/guile/files/patch-libguile_____scm.h
index cb3cdee83e61..63d759844d70 100644
--- a/lang/guile/files/patch-libguile___scm.h
+++ b/lang/guile/files/patch-libguile_____scm.h
@@ -1,6 +1,6 @@
---- libguile/__scm.h 2008-02-23 18:14:28.106264450 -0600
-+++ libguile/__scm.h 2008-02-23 18:15:41.306005478 -0600
-@@ -411,7 +411,8 @@
+--- libguile/__scm.h.orig 2010-12-13 17:25:01 UTC
++++ libguile/__scm.h
+@@ -434,7 +434,8 @@
* that all the state of the process is contained in the stack.
*/
diff --git a/lang/guile/files/patch-libguile_c-tokenize.c b/lang/guile/files/patch-libguile_c-tokenize.c
index 338efe4f7699..2f2ddf2bdeb0 100644
--- a/lang/guile/files/patch-libguile_c-tokenize.c
+++ b/lang/guile/files/patch-libguile_c-tokenize.c
@@ -1,5 +1,5 @@
---- libguile/c-tokenize.c 2010-12-13 20:24:04.000000000 +0100
-+++ libguile/c-tokenize.c 2014-04-13 22:20:33.000000000 +0200
+--- libguile/c-tokenize.c.orig 2010-12-13 19:24:04 UTC
++++ libguile/c-tokenize.c
@@ -898,13 +898,13 @@ case 3:
/* rule 3 can match eol */
YY_RULE_SETUP
diff --git a/lang/guile/files/patch-libguile_eval.c b/lang/guile/files/patch-libguile_eval.c
index 3a7e9a21784e..903dca27da89 100644
--- a/lang/guile/files/patch-libguile_eval.c
+++ b/lang/guile/files/patch-libguile_eval.c
@@ -1,6 +1,6 @@
---- libguile/eval.c 2008-07-09 14:44:29.000000000 +0800
-+++ libguile/eval.c 2008-07-09 14:45:45.000000000 +0800
-@@ -42,6 +42,8 @@
+--- libguile/eval.c.orig 2010-12-13 17:24:39 UTC
++++ libguile/eval.c
+@@ -40,6 +40,8 @@
#ifndef alloca
# if HAVE_ALLOCA_H
# include <alloca.h>
diff --git a/lang/guile/files/patch-libguile_gc.c b/lang/guile/files/patch-libguile_gc.c
index 6701de773a0c..5e8d8b372a3d 100644
--- a/lang/guile/files/patch-libguile_gc.c
+++ b/lang/guile/files/patch-libguile_gc.c
@@ -1,6 +1,6 @@
---- libguile/gc.c.orig 2008-12-08 09:42:54.000000000 -0800
-+++ libguile/gc.c 2009-08-20 22:55:11.000000000 -0700
-@@ -1060,6 +1060,20 @@
+--- libguile/gc.c.orig 2010-12-13 17:24:40 UTC
++++ libguile/gc.c
+@@ -1060,6 +1060,20 @@ scm_ia64_ar_bsp (const void *opaque)
return (void *) ctx->uc_mcontext.sc_ar_bsp;
}
# endif /* linux */
diff --git a/lang/guile/files/patch-libguile_gc_os_dep.c b/lang/guile/files/patch-libguile_gc__os__dep.c
index 508f201fe0a7..95483bc2d98e 100644
--- a/lang/guile/files/patch-libguile_gc_os_dep.c
+++ b/lang/guile/files/patch-libguile_gc__os__dep.c
@@ -1,6 +1,6 @@
---- libguile/gc_os_dep.c.orig 2008-02-16 19:50:24.000000000 +0100
-+++ libguile/gc_os_dep.c 2008-03-06 16:21:40.000000000 +0100
-@@ -115,6 +115,12 @@
+--- libguile/gc_os_dep.c.orig 2010-12-13 17:25:01 UTC
++++ libguile/gc_os_dep.c
+@@ -115,6 +115,12 @@ typedef int GC_bool;
# define NETBSD
# define mach_type_known
# endif
@@ -13,7 +13,7 @@
# if defined(__NetBSD__) && defined(__powerpc__)
# define POWERPC
# define NETBSD
-@@ -249,7 +255,21 @@
+@@ -249,7 +255,21 @@ typedef int GC_bool;
# define ARM32
# define mach_type_known
# endif
@@ -36,7 +36,7 @@
# define ALPHA
# if !defined(LINUX) && !defined (NETBSD)
# define OSF1 /* a.k.a Digital Unix */
-@@ -701,8 +721,6 @@
+@@ -701,8 +721,6 @@ scm_get_stack_base ()
# ifdef SPARC
# define MACH_TYPE "SPARC"
@@ -45,7 +45,7 @@
extern int etext;
# ifdef SUNOS5
# define OS_TYPE "SUNOS5"
-@@ -750,7 +768,6 @@
+@@ -757,7 +775,6 @@ scm_get_stack_base ()
# define DYNAMIC_LOADING
# endif
# ifdef DRSNX
@@ -53,7 +53,7 @@
# define OS_TYPE "DRSNX"
extern char * GC_SysVGetDataStart();
extern int etext;
-@@ -1159,6 +1176,13 @@
+@@ -1172,6 +1189,13 @@ scm_get_stack_base ()
# endif
# endif
@@ -67,7 +67,7 @@
# ifdef IA64
# define MACH_TYPE "IA64"
# define ALIGN_DOUBLE
-@@ -1504,8 +1528,15 @@
+@@ -1517,8 +1541,15 @@ scm_get_stack_base ()
# include <setjmp.h>
#endif
@@ -84,7 +84,7 @@
#endif
#ifdef AMIGA
-@@ -1537,7 +1568,7 @@
+@@ -1550,7 +1581,7 @@ scm_get_stack_base ()
#endif
#ifdef SUNOS5SIGS
@@ -93,7 +93,7 @@
# undef setjmp
# undef longjmp
# define setjmp(env) sigsetjmp(env, 1)
-@@ -1716,11 +1747,13 @@
+@@ -1729,11 +1760,13 @@ void *scm_get_stack_base()
/* static */ jmp_buf GC_jmp_buf;
/*ARGSUSED*/
@@ -107,7 +107,7 @@
# ifdef __STDC__
typedef void (*handler)(int);
-@@ -1728,6 +1761,7 @@
+@@ -1741,6 +1774,7 @@ void *scm_get_stack_base()
typedef void (*handler)();
# endif
@@ -115,7 +115,7 @@
# if defined(SUNOS5SIGS) || defined(IRIX5) || defined(OSF1)
static struct sigaction old_segv_act;
# if defined(_sigargs) || defined(HPUX) /* !Irix6.x */
-@@ -1736,7 +1770,9 @@
+@@ -1749,7 +1783,9 @@ void *scm_get_stack_base()
# else
static handler old_segv_handler, old_bus_handler;
# endif
@@ -125,7 +125,7 @@
static void GC_setup_temporary_fault_handler()
{
# if defined(SUNOS5SIGS) || defined(IRIX5) || defined(OSF1)
-@@ -1773,7 +1809,9 @@
+@@ -1786,7 +1822,9 @@ void *scm_get_stack_base()
# endif
# endif
}
@@ -135,7 +135,7 @@
static void GC_reset_fault_handler()
{
# if defined(SUNOS5SIGS) || defined(IRIX5) || defined(OSF1)
-@@ -1789,8 +1827,10 @@
+@@ -1802,8 +1840,10 @@ void *scm_get_stack_base()
# endif
# endif
}
@@ -146,7 +146,7 @@
static void
GC_noop1(x)
word x;
-@@ -1798,9 +1838,11 @@
+@@ -1811,9 +1851,11 @@ void *scm_get_stack_base()
static VOLATILE word sink;
sink = x;
}
@@ -158,7 +158,7 @@
static ptr_t GC_find_limit(p, up)
ptr_t p;
GC_bool up;
-@@ -1831,6 +1873,7 @@
+@@ -1844,6 +1886,7 @@ void *scm_get_stack_base()
}
return(result);
}
diff --git a/lang/guile/files/patch-libguile_gen-scmconfig.c b/lang/guile/files/patch-libguile_gen-scmconfig.c
index f2b35b8d5934..0560ac8f7075 100644
--- a/lang/guile/files/patch-libguile_gen-scmconfig.c
+++ b/lang/guile/files/patch-libguile_gen-scmconfig.c
@@ -1,8 +1,8 @@
---- libguile/gen-scmconfig.c 2008-02-23 21:38:39.310330888 -0600
-+++ libguile/gen-scmconfig.c 2008-02-23 21:39:32.909873567 -0600
+--- libguile/gen-scmconfig.c.orig 2010-12-13 17:25:01 UTC
++++ libguile/gen-scmconfig.c
@@ -123,6 +123,7 @@
- #include "gen-scmconfig.h"
+ #include <libguile/gen-scmconfig.h>
+#define _ANSI_SOURCE
#include <stdio.h>
diff --git a/lang/guile/files/patch-libguile_guile-snarf.in b/lang/guile/files/patch-libguile_guile-snarf.in
index 047fd8859ec2..1875c456b63c 100644
--- a/lang/guile/files/patch-libguile_guile-snarf.in
+++ b/lang/guile/files/patch-libguile_guile-snarf.in
@@ -1,5 +1,5 @@
---- libguile/guile-snarf.in 2010-12-13 18:24:40.000000000 +0100
-+++ libguile/guile-snarf.in 2014-04-13 21:05:42.000000000 +0200
+--- libguile/guile-snarf.in.orig 2010-12-13 17:24:40 UTC
++++ libguile/guile-snarf.in
@@ -51,7 +51,8 @@ modern_snarf ()
## empty file.
echo "/* cpp arguments: $@ */" ;
diff --git a/lang/guile/files/patch-libguile_numbers.c b/lang/guile/files/patch-libguile_numbers.c
index 0e37e057045a..5c3fe5be09e9 100644
--- a/lang/guile/files/patch-libguile_numbers.c
+++ b/lang/guile/files/patch-libguile_numbers.c
@@ -1,6 +1,6 @@
---- libguile/numbers.c 2008-07-09 14:50:22.000000000 +0800
-+++ libguile/numbers.c 2008-07-09 14:53:05.000000000 +0800
-@@ -163,7 +163,7 @@
+--- libguile/numbers.c.orig 2010-12-13 17:25:01 UTC
++++ libguile/numbers.c
+@@ -160,7 +160,7 @@ xisnan (double x)
}
#if defined (GUILE_I)
diff --git a/lang/guile/files/patch-libguile_pthread-threads.h b/lang/guile/files/patch-libguile_pthread-threads.h
index 42f5934bb506..72689d943159 100644
--- a/lang/guile/files/patch-libguile_pthread-threads.h
+++ b/lang/guile/files/patch-libguile_pthread-threads.h
@@ -1,5 +1,5 @@
---- libguile/pthread-threads.h 2008-02-27 10:31:41.564950412 -0600
-+++ libguile/pthread-threads.h 2008-02-27 10:36:08.383652510 -0600
+--- libguile/pthread-threads.h.orig 2010-12-13 17:24:40 UTC
++++ libguile/pthread-threads.h
@@ -26,6 +26,9 @@
*/
diff --git a/lang/guile/files/patch-libguile_read.c b/lang/guile/files/patch-libguile_read.c
index 57c71d63d21b..c6f21423ad58 100644
--- a/lang/guile/files/patch-libguile_read.c
+++ b/lang/guile/files/patch-libguile_read.c
@@ -1,5 +1,5 @@
---- libguile/read.c 2008-02-23 18:05:20.175715735 -0600
-+++ libguile/read.c 2008-02-23 18:06:27.495397147 -0600
+--- libguile/read.c.orig 2010-12-13 17:24:40 UTC
++++ libguile/read.c
@@ -27,7 +27,7 @@
#include <ctype.h>
#include <string.h>
diff --git a/lang/guile/files/patch-libguile_threads.c b/lang/guile/files/patch-libguile_threads.c
index ad966b88392d..973a82f3cd42 100644
--- a/lang/guile/files/patch-libguile_threads.c
+++ b/lang/guile/files/patch-libguile_threads.c
@@ -1,6 +1,6 @@
---- libguile/threads.c 2008-02-27 10:17:41.531443640 -0600
-+++ libguile/threads.c 2008-02-27 10:25:44.309334685 -0600
-@@ -593,7 +593,7 @@
+--- libguile/threads.c.orig 2010-12-13 17:24:40 UTC
++++ libguile/threads.c
+@@ -631,7 +631,7 @@ scm_i_init_thread_for_guile (SCM_STACKIT
#if SCM_USE_PTHREAD_THREADS
@@ -9,7 +9,7 @@
/* This method for GNU/Linux and perhaps some other systems.
It's not for MacOS X or Solaris 10, since pthread_getattr_np is not
available on them. */
-@@ -606,8 +606,15 @@
+@@ -644,8 +644,15 @@ get_thread_stack_base ()
void *start, *end;
size_t size;