aboutsummaryrefslogtreecommitdiff
path: root/lang/intel-compute-runtime
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-09-18 21:36:53 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-09-18 21:36:53 +0000
commit404f3ed6c6d294029bc90166a63ae99d79bc39ca (patch)
tree2573ec5826b51f3cb02efe56a4a895e4b194482b /lang/intel-compute-runtime
parent24384af1188a9ad418d54bcab6db9a46a8010c3c (diff)
downloadports-404f3ed6c6d294029bc90166a63ae99d79bc39ca.tar.gz
ports-404f3ed6c6d294029bc90166a63ae99d79bc39ca.zip
lang/intel-compute-runtime: update to 20.37.17906
Notes
Notes: svn path=/head/; revision=548918
Diffstat (limited to 'lang/intel-compute-runtime')
-rw-r--r--lang/intel-compute-runtime/Makefile2
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-no-perf70
3 files changed, 74 insertions, 4 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index b29d58d66825..f1c892c7152c 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 20.36.17813
+DISTVERSION= 20.37.17906
CATEGORIES= lang
PKGNAMEPREFIX= intel-
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 7206684316ea..2d92fddbc784 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598879389
-SHA256 (intel-compute-runtime-20.36.17813_GH0.tar.gz) = 584d3be6f6bd60195da77660edd3a857589d50a610a18f1d3098869303bf6752
-SIZE (intel-compute-runtime-20.36.17813_GH0.tar.gz) = 3459305
+TIMESTAMP = 1599810838
+SHA256 (intel-compute-runtime-20.37.17906_GH0.tar.gz) = 803d48568822562398d1e09a992a13234d53040cc07aad64eeefc8ddb1a67060
+SIZE (intel-compute-runtime-20.37.17906_GH0.tar.gz) = 3492080
diff --git a/lang/intel-compute-runtime/files/patch-no-perf b/lang/intel-compute-runtime/files/patch-no-perf
new file mode 100644
index 000000000000..236bfd7f5757
--- /dev/null
+++ b/lang/intel-compute-runtime/files/patch-no-perf
@@ -0,0 +1,70 @@
+Limit PMU counters to Linux
+
+In file included from level_zero/tools/source/sysman/linux/os_sysman_imp.cpp:8:
+In file included from level_zero/tools/source/sysman/linux/os_sysman_imp.h:16:
+level_zero/tools/source/sysman/linux/pmu/pmu_imp.h:12:10: fatal error: 'linux/perf_event.h' file not found
+#include <linux/perf_event.h>
+ ^~~~~~~~~~~~~~~~~~~~
+
+--- level_zero/tools/source/sysman/engine/linux/os_engine_imp.cpp.orig 2020-09-11 07:53:58 UTC
++++ level_zero/tools/source/sysman/engine/linux/os_engine_imp.cpp
+@@ -49,9 +49,11 @@ ze_result_t LinuxEngineImp::getActivity(zes_engine_sta
+ return ZE_RESULT_ERROR_UNSUPPORTED_FEATURE;
+ }
+ uint64_t data[2] = {};
++#ifdef __linux__
+ if (pPmuInterface->pmuReadSingle(static_cast<int>(fd), data, sizeof(data)) < 0) {
+ return ZE_RESULT_ERROR_UNSUPPORTED_FEATURE;
+ }
++#endif
+ // In data[], First u64 is "active time", And second u64 is "timestamp". Both in nanoseconds
+ pStats->activeTime = data[0] / microSecondsToNanoSeconds;
+ pStats->timestamp = data[1] / microSecondsToNanoSeconds;
+@@ -66,9 +68,11 @@ ze_result_t LinuxEngineImp::getProperties(zes_engine_p
+ }
+
+ void LinuxEngineImp::init() {
++#ifdef __linux
+ auto i915EngineClass = engineToI915Map.find(engineGroup);
+ // I915_PMU_ENGINE_BUSY macro provides the perf type config which we want to listen to get the engine busyness.
+ fd = pPmuInterface->pmuInterfaceOpen(I915_PMU_ENGINE_BUSY(i915EngineClass->second, engineInstance), -1, PERF_FORMAT_TOTAL_TIME_ENABLED);
++#endif
+ }
+
+ LinuxEngineImp::LinuxEngineImp(OsSysman *pOsSysman, zes_engine_group_t type, uint32_t engineInstance) : engineGroup(type), engineInstance(engineInstance) {
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.cpp.orig 2020-09-11 07:53:58 UTC
++++ level_zero/tools/source/sysman/linux/os_sysman_imp.cpp
+@@ -37,8 +37,10 @@ ze_result_t LinuxSysmanImp::init() {
+ pPmt = new PlatformMonitoringTech();
+ UNRECOVERABLE_IF(nullptr == pPmt);
+ pPmt->init(myDeviceName, pFsAccess);
++#ifdef __linux__
+ pPmuInterface = PmuInterface::create(this);
+ UNRECOVERABLE_IF(nullptr == pPmuInterface);
++#endif
+
+ return ZE_RESULT_SUCCESS;
+ }
+--- level_zero/tools/source/sysman/linux/os_sysman_imp.h.orig 2020-09-11 07:53:58 UTC
++++ level_zero/tools/source/sysman/linux/os_sysman_imp.h
+@@ -13,7 +13,9 @@
+ #include "level_zero/core/source/device/device.h"
+ #include "level_zero/tools/source/sysman/linux/fs_access.h"
+ #include "level_zero/tools/source/sysman/linux/pmt.h"
++#ifdef __linux__
+ #include "level_zero/tools/source/sysman/linux/pmu/pmu_imp.h"
++#endif
+ #include "level_zero/tools/source/sysman/linux/xml_parser/xml_parser.h"
+ #include "level_zero/tools/source/sysman/sysman_imp.h"
+
+--- level_zero/tools/source/sysman/linux/pmu/CMakeLists.txt.orig 2020-09-11 07:53:58 UTC
++++ level_zero/tools/source/sysman/linux/pmu/CMakeLists.txt
+@@ -9,7 +9,7 @@ set(L0_SRCS_TOOLS_SYSMAN_LINUX_PMU
+ ${CMAKE_CURRENT_SOURCE_DIR}/pmu_imp.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/pmu.h
+ )
+-if(UNIX)
++if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ target_sources(${L0_STATIC_LIB_NAME}
+ PRIVATE
+ ${L0_SRCS_TOOLS_SYSMAN_LINUX_PMU}