aboutsummaryrefslogtreecommitdiff
path: root/lang/intel-compute-runtime
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-05 14:57:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-05 14:57:43 +0000
commitebda41dd3c5b409073a82fd12eb1b18e3c98a7b3 (patch)
treea02f53f8fe51d4d184c38b1e526a2cf5e340cabf /lang/intel-compute-runtime
parent6e0768b9156102b89980816e376fd5fe6468f10f (diff)
downloadports-ebda41dd3c5b409073a82fd12eb1b18e3c98a7b3.tar.gz
ports-ebda41dd3c5b409073a82fd12eb1b18e3c98a7b3.zip
lang/intel-compute-runtime: update to 21.09.19150
Notes
Notes: svn path=/head/; revision=567390
Diffstat (limited to 'lang/intel-compute-runtime')
-rw-r--r--lang/intel-compute-runtime/Makefile3
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-device_path37
3 files changed, 41 insertions, 5 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 1814e0102f43..c7eedf7afbfd 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= compute-runtime
-DISTVERSION= 21.08.19096
-PORTREVISION= 1
+DISTVERSION= 21.09.19150
CATEGORIES= lang
PKGNAMEPREFIX= intel-
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 0bb6803d9cde..73cb280e74c1 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1613411392
-SHA256 (intel-compute-runtime-21.08.19096_GH0.tar.gz) = 2114918e6990c5be8e0ac5cdfae74cbc7747b73c4cb93adf0210c35edc33f644
-SIZE (intel-compute-runtime-21.08.19096_GH0.tar.gz) = 3765142
+TIMESTAMP = 1614027337
+SHA256 (intel-compute-runtime-21.09.19150_GH0.tar.gz) = c38172bc7460cc3ec104ef29a655788cdd8329a62e894ee1ec116e78ebc451a5
+SIZE (intel-compute-runtime-21.09.19150_GH0.tar.gz) = 3780882
SHA256 (2a423820aaa4.patch) = dd034e856e75d70bc6b63204aa2c67530a3212d111b67a703e4cbeb84e61685b
SIZE (2a423820aaa4.patch) = 947
diff --git a/lang/intel-compute-runtime/files/patch-device_path b/lang/intel-compute-runtime/files/patch-device_path
new file mode 100644
index 000000000000..15a11b0b6b7c
--- /dev/null
+++ b/lang/intel-compute-runtime/files/patch-device_path
@@ -0,0 +1,37 @@
+/sys is Linux-specific. FreeBSD has linsysfs(5) but not mounted by default.
+
+--- shared/source/os_interface/linux/sys_calls_linux.cpp.orig 2021-02-22 20:55:37 UTC
++++ shared/source/os_interface/linux/sys_calls_linux.cpp
+@@ -12,7 +12,11 @@
+ #include <stdio.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#if defined(__linux__)
+ #include <sys/sysmacros.h>
++#elif defined(__DragonFly__) || defined(__FreeBSD__)
++#include <cstdlib>
++#endif
+ #include <unistd.h>
+
+ namespace NEO {
+@@ -36,6 +40,7 @@ int readlink(const char *path, char *buf, size_t bufsi
+ }
+
+ int getDevicePath(int deviceFd, char *buf, size_t &bufSize) {
++#if defined(__linux__)
+ struct stat st;
+ if (fstat(deviceFd, &st)) {
+ return -1;
+@@ -45,6 +50,12 @@ int getDevicePath(int deviceFd, char *buf, size_t &buf
+ major(st.st_rdev), minor(st.st_rdev));
+
+ return 0;
++#elif defined(__DragonFly__) || defined(__FreeBSD__)
++ return fdevname_r(deviceFd, buf, (int)bufSize) ? 0 : -1;
++#else
++ // Extract drmGetDeviceNameFromFd2 from libdrm
++ return -1;
++#endif
+ }
+ } // namespace SysCalls
+ } // namespace NEO