aboutsummaryrefslogtreecommitdiff
path: root/lang/io-devel
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-06 18:41:08 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-06 18:41:08 +0000
commitaeb723dd90b2399df0cf02e07704a7d887af011c (patch)
tree4d8e2f1a5076dedc9b755bdbb9ddcde98b5370d4 /lang/io-devel
parentf1637728b0ae89e7942ca797470266601c84ba07 (diff)
downloadports-aeb723dd90b2399df0cf02e07704a7d887af011c.tar.gz
ports-aeb723dd90b2399df0cf02e07704a7d887af011c.zip
Disable sse on non-x86 architectures to fix build.
Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=494830
Diffstat (limited to 'lang/io-devel')
-rw-r--r--lang/io-devel/Makefile9
-rw-r--r--lang/io-devel/files/extra-patch-CMakeLists.txt10
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/io-devel/Makefile b/lang/io-devel/Makefile
index d412862d580d..9a581f174d29 100644
--- a/lang/io-devel/Makefile
+++ b/lang/io-devel/Makefile
@@ -29,4 +29,11 @@ MAKE_JOBS_UNSAFE= yes
CMAKE_ARGS= -DWITHOUT_EERIE:BOOL=ON
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# disable sse on non-x86 archs
+.if ${ARCH} != amd64 && ${ARCH} != i386
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/io-devel/files/extra-patch-CMakeLists.txt b/lang/io-devel/files/extra-patch-CMakeLists.txt
new file mode 100644
index 000000000000..8590f9b905e5
--- /dev/null
+++ b/lang/io-devel/files/extra-patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2018-08-07 11:40:49 UTC
++++ CMakeLists.txt
+@@ -41,7 +41,6 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
+ SET(CMAKE_BUILD_TYPE_DebugFast)
+ SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
+ SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
+- SET(CMAKE_C_FLAGS "-msse2")
+ if(NOT CMAKE_BUILD_TYPE)
+ SET(CMAKE_BUILD_TYPE "DebugFast")
+ endif(NOT CMAKE_BUILD_TYPE)