aboutsummaryrefslogtreecommitdiff
path: root/lang/io
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-06 19:40:42 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-06 19:40:42 +0000
commit6d9a99d78de1e8f008bc4377a4b8bd5eb272b354 (patch)
treec7b28fd6aa561581215da11ba048bb8951ccd465 /lang/io
parent897b8b7c3aed484b18b5d5f05e36aa06dbfe598c (diff)
downloadports-6d9a99d78de1e8f008bc4377a4b8bd5eb272b354.tar.gz
ports-6d9a99d78de1e8f008bc4377a4b8bd5eb272b354.zip
Disable sse on non-x86 archs to fix build.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=498176
Diffstat (limited to 'lang/io')
-rw-r--r--lang/io/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index d975cc4199ed..3b19a526f047 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -11,11 +11,10 @@ COMMENT= Small prototype-based programming language
LICENSE= BSD3CLAUSE
-CONFLICTS= io-devel-[0-9]*
-
BROKEN_armv6= fails to compile: ucontext.h: expected parameter declarator
BROKEN_armv7= fails to compile: Coro.c:392:2: no member named 'arm_r0' in 'mcontext_t'
-BROKEN_powerpc64= fails to build: unrecognized command line option -msse2
+
+CONFLICTS= io-devel-[0-9]*
USES= cmake:noninja compiler:c11 ssl
@@ -34,6 +33,13 @@ OPTIONS_SUB= yes
.include "${.CURDIR}/Makefile.addons"
+.include <bsd.port.pre.mk>
+
+# disable sse on non-x86 archs
+.if ${ARCH} != amd64 && ${ARCH} != i386
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's/^[ ]*add_subdirectory/#&/' \
${WRKSRC}/addons/CMakeLists.txt
@@ -61,4 +67,4 @@ do-test:
cd ${BUILD_WRKSRC} && \
./_build/binaries/io ${WRKSRC}/libs/iovm/tests/correctness/run.io
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>