aboutsummaryrefslogtreecommitdiff
path: root/lang/io
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-11-11 10:24:01 +0000
committerJohn Marino <marino@FreeBSD.org>2015-11-11 10:24:01 +0000
commit7b56a62b83d9a94e2dd3fc43ed1ab952783ad3a1 (patch)
tree5ca5a1a575aeac618b414b98bcfa346ca6cb31cc /lang/io
parentbc38a6cff27d9ab56453b6e9e776d491ceec3788 (diff)
downloadports-7b56a62b83d9a94e2dd3fc43ed1ab952783ad3a1.tar.gz
ports-7b56a62b83d9a94e2dd3fc43ed1ab952783ad3a1.zip
lang/io: uses optios framework, fix couple of bugs
During the conversion to use option handlers, I found a couple of typos and obsolete code which caused errors. I also switched to USES+= readline libedit when their options were selected.
Notes
Notes: svn path=/head/; revision=401234
Diffstat (limited to 'lang/io')
-rw-r--r--lang/io/Makefile5
-rw-r--r--lang/io/Makefile.addons258
2 files changed, 40 insertions, 223 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index f3e6c8345d2e..9b3d948f9568 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -3,7 +3,7 @@
PORTNAME= io
PORTVERSION= 2013.12.04
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang
MAINTAINER= ports@FreeBSD.org
@@ -25,6 +25,7 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_GROUP= ADDONS
+OPTIONS_SUB= yes
.include "${.CURDIR}/Makefile.addons"
@@ -37,7 +38,7 @@ post-patch:
${FIND} ${WRKSRC}/addons -name "*.bak" -o -name "*.orig" -delete
post-install:
- ${FIND} -d ${STAGEDIR}${PREFIX}/lib/io/addons -type d -empty -exec rmdir {} \;
+ ${FIND} -d ${STAGEDIR}${PREFIX}/lib/io/addons -type d -empty -delete
${FIND} ${STAGEDIR}${PREFIX}/lib/io/addons -type f -name "*.so" -exec \
${STRIP_CMD} {} \;
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index 73c6d62bcc3b..46038a7dd4c1 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -70,224 +70,43 @@ OPTIONAL_ADDONS=BigNum \
OPTIONS_GROUP_ADDONS=${OPTIONAL_ADDONS}
-.include <bsd.port.options.mk>
-
-#
-# BigNum
-#
-.if ${PORT_OPTIONS:MBigNum}
-LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
-.endif
-
-#
-# CFFI
-#
-.if ${PORT_OPTIONS:MCFFI}
-LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
-.endif
-
-#
-# Clutter
-#
-.if ${PORT_OPTIONS:MClutter}
-LIB_DEPENDS+= libclutter-glx-1.0.so:${PORTSDIR}/graphics/clutter
-.endif
-
-#
-# DBI
-#
-.if ${PORT_OPTIONS:MDBI}
-LIB_DEPENDS+= libdbi.so:${PORTSDIR}/databases/libdbi
-.endif
-
-#
-# EditLine
-#
-.if ${PORT_OPTIONS:MEditLine}
-LIB_DEPENDS+= libedit.so:${PORTSDIR}/devel/libedit
-.endif
-
-#
-# Font
-#
-.if ${PORT_OPTIONS:MFont}
-USE_GL+= glut
-USE_XORG+= xmu
-LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
-.endif
-
-#
-# GLFW
-#
-.if ${PORT_OPTIONS:MGLFW}
-LIB_DEPENDS+= libglfw.so.0:${PORTSDIR}/graphics/glfw2
-.endif
-
-#
-# Image
-#
-.if ${PORT_OPTIONS:MImage}
-LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
- libtiff.so:${PORTSDIR}/graphics/tiff
-USES+= jpeg
-.endif
-
-#
-# LZO
-#
-.if ${PORT_OPTIONS:MLZO}
-LIB_DEPENDS+= liblzo2.so:${PORTSDIR}/archivers/lzo2
-.endif
-
-#
-# LibSndFile
-#
-.if ${PORT_OPTIONS:MLibSndFile}
-LIB_DEPENDS+= libsndfile.so:${PORTSDIR}/audio/libsndfile
-.endif
-
-#
-# Libxml2
-#
-.if ${PORT_OPTIONS:MLibxml2}
-USE_GNOME+= libxml2
-.endif
-
-#
-# Loudmouth
-#
-.if ${PORT_OPTIONS:MLoudmouth}
-LIB_DEPENDS+= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
-.endif
-
-#
-# Memcached
-#
-.if ${PORT_OPTIONS:MMemcached}
-LIB_DEPENDS+= libmemcached.so:${PORTSDIR}/databases/libmemcached
-.endif
-
-#
-# MySQL
-#
-.if ${PORT_OPTIONS:MMySQL}
-USE_MYSQL+= client
-.endif
-
-#
-# Ogg
-#
-.if ${PORT_OPTIONS:MOgg}
-LIB_DEPENDS+= libogg.so:${PORTSDIR}/audio/libogg
-.endif
-
-#
-# OpenGL
-#
-.if ${PORT_OPTIONS:MOpenGL}
-USE_GL+= glut
-USE_XORG+= xmu
-
-.endif
-
-#
-# PostgreSQL
-#
-.if ${PORT_OPTIONS:MPostgreSQL}
-USES+= pgsql
-.endif
-
-#
-# Python
-#
-.if ${PORT_OPTIONS:MPython}
-USES+= python
-.endif
-
-#
-# QDBM
-#
-.if ${PORT_OPTIONS:MQDBM}
-LIB_DEPENDS+= libqdbm.so:${PORTSDIR}/databases/qdbm
-.endif
-
-#
-# ReadLine
-#
-.if ${PORT_OPTIONS:MReadLine}
-LIB_DEPENDS+= libhistory.so:${PORTSDIR}/devel/readline
-.endif
-
-#
-# Regex
-#
-.if ${PORT_OPTIONS:MRegex}
-LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
-.endif
-
-#
-# SQLite3
-#
-.if ${PORT_OPTIONS:MSQLite3}
-USE_SQLITE= 3
-SQLITE_LIB= ${LOCALBASE}/lib/libsqlite${SQLITE_VER}.so
-.endif
-
-# SampleRateConverter
-#
-.if ${PORT_OPTIONS:MSampleRateConverter}
-LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
-.endif
-
-#
-# Socket
-#
-.if ${PORT_OPTIONS:MSocket}
-LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
-.endif
-
-#
-# TagLib
-#
-.if ${PORT_OPTIONS:MTagLib}
-LIB_DEPENDS+= libtag.so:${PORTSDIR}/audio/taglib
-.endif
-
-#
-# Theora
-#
-.if ${PORT_OPTIONS:MTheora}
-LIB_DEPENDS+= libtheora.so:${PORTSDIR}/multimedia/libtheora
-.endif
-
-#
-# TokyoCabinet
-#
-.if ${PORT_OPTIONS:MTokyoCabinet}
-LIB_DEPENDS+= libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
-.endif
-
-#
-# UUID
-#
-.if ${PORT_OPTIONS:MUUID}
-LIB_DEPENDS+= libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
-.endif
-
-#
-# Vorbis
-#
-.if ${PORT_OPTIONS:MBVorbis}
-LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
-.endif
-
-#
-# Yajl
-#
-.if ${PORT_OPTIONS:MYajl}
-LIB_DEPENDS+= libyajl.so:${PORTSDIR}/devel/yajl
-.endif
+BigNum_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+CFFI_LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+Clutter_LIB_DEPENDS= libclutter-glx-1.0.so:${PORTSDIR}/graphics/clutter
+DBI_LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
+EditLine_USES= libedit
+Font_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+Font_USE= GL=glut XORG=xmu
+GLFW_LIB_DEPENDS= libglfw.so.0:${PORTSDIR}/graphics/glfw2
+Image_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
+Image_USES= jpeg
+LZO_LIB_DEPENDS= liblzo2.so:${PORTSDIR}/archivers/lzo2
+LibSndFile_LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
+Libxml2_USE= GNOME=libxml2
+Loudmouth_LIB_DEPENDS= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
+Memcached_LIB_DEPENDS= libmemcached.so:${PORTSDIR}/databases/libmemcached
+MySQL_USE= MYSQL=client
+Ogg_LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
+OpenGL_USE= GL=glut XORG=xmu
+PostgreSQL_USES= pgsql
+Python_USES= python
+QDBM_LIB_DEPENDS= libqdbm.so:${PORTSDIR}/databases/qdbm
+ReadLine_USES= readline:port
+Regex_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+SQLite3_USE= SQLITE=3
+SampleRateConverter_LIB_DEPENDS=\
+ libsamplerate.so:${PORTSDIR}/audio/libsamplerate
+Socket_LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
+TagLib_LIB_DEPENDS= libtag.so:${PORTSDIR}/audio/taglib
+Theora_LIB_DEPENDS= libtheora.so:${PORTSDIR}/multimedia/libtheora
+TokyoCabinet_LIB_DEPENDS= \
+ libtokyocabinet.so:${PORTSDIR}/databases/tokyocabinet
+UUID_LIB_DEPENDS= libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
+Vorbis_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+Yajl_LIB_DEPENDS= libyajl.so:${PORTSDIR}/devel/yajl
+.include <bsd.port.options.mk>
########################################
# WE NOW DEFINE THE FULL LIST OF ADDONS
@@ -297,10 +116,7 @@ PLIST_SUB+= ${def}=""
.endfor
ADDONS= ${DEFAULT_ADDONS}
.for opt in ${OPTIONS_GROUP_ADDONS}
-. if defined (WITH_${opt})
+. if ${PORT_OPTIONS:M${opt}}
ADDONS+= ${opt}
-PLIST_SUB+= ${opt}=""
-. else
-PLIST_SUB+= ${opt}="@comment "
. endif
.endfor