aboutsummaryrefslogtreecommitdiff
path: root/lang/lafontaine
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-03 13:35:48 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-03 13:35:48 +0000
commit8d2d848a19dbcdf5666c988a52b8fda4508217f6 (patch)
tree1c58d8ec064579b8367bc7529a99ab012d98a75d /lang/lafontaine
parentdc494c17e32d0921a4f863f395d6345ce42543a7 (diff)
downloadports-8d2d848a19dbcdf5666c988a52b8fda4508217f6.tar.gz
ports-8d2d848a19dbcdf5666c988a52b8fda4508217f6.zip
- Fix build with gcc 4.1
- Change my email Approved by: sem (mentor)
Notes
Notes: svn path=/head/; revision=174372
Diffstat (limited to 'lang/lafontaine')
-rw-r--r--lang/lafontaine/Makefile2
-rw-r--r--lang/lafontaine/files/patch-exec.c51
2 files changed, 49 insertions, 4 deletions
diff --git a/lang/lafontaine/Makefile b/lang/lafontaine/Makefile
index fda322482ff0..38e2bf26ee13 100644
--- a/lang/lafontaine/Makefile
+++ b/lang/lafontaine/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= lang
MASTER_SITES= http://www.nongnu.org/lafontaine/archives/
DISTNAME= ${PORTNAME}_0.4-1
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Graphical logo interpreter
WRKSRC= ${WRKDIR}/${PORTNAME}-0.4
diff --git a/lang/lafontaine/files/patch-exec.c b/lang/lafontaine/files/patch-exec.c
index 58b34ed07257..72234355af64 100644
--- a/lang/lafontaine/files/patch-exec.c
+++ b/lang/lafontaine/files/patch-exec.c
@@ -1,6 +1,6 @@
---- src/exec.c.orig Sun Aug 15 19:57:08 2004
-+++ src/exec.c Sun Aug 15 19:57:55 2004
-@@ -108,6 +108,7 @@
+--- src/exec.c.orig Fri Oct 25 11:28:43 2002
++++ src/exec.c Mon Oct 2 20:50:35 2006
+@@ -109,6 +109,7 @@
{ 47031, 47031, 47031} //15 or
};
@@ -8,3 +8,48 @@
/**
main execution function.<br>
+@@ -265,7 +266,7 @@
+ */
+ struct s_instr *exec_moveforward(struct s_instr *instr)
+ {
+- register int steps;
++ int steps;
+ #ifdef DEBUG
+ debug_append(" # executing exec_moveforward()\n");
+ #endif
+@@ -745,7 +746,7 @@
+ */
+ struct s_instr *exec_hazard(struct s_instr *instr)
+ {
+- register guint maxvalue, hazvalue;
++ guint maxvalue, hazvalue;
+
+ #ifdef DEBUG
+ debug_append(" # executing exec_hazard()\n");
+@@ -804,7 +805,7 @@
+ */
+ struct s_instr *exec_loopcnt(struct s_instr *instr)
+ {
+- register gint loopcnt, startval;
++ gint loopcnt, startval;
+
+ #ifdef DEBUG
+ debug_append(" # executing exec_loopcnt()\n");
+@@ -830,7 +831,7 @@
+ */
+ struct s_instr *exec_if(struct s_instr *instr)
+ {
+- register gboolean condition;
++ gboolean condition;
+
+ #ifdef DEBUG
+ debug_append(" # executing exec_if()\n");
+@@ -875,7 +876,7 @@
+ */
+ struct s_instr *exec_while(struct s_instr *instr)
+ {
+- register gboolean condition;
++ gboolean condition;
+
+ #ifdef DEBUG
+ debug_append(" # executing exec_while()\n");