aboutsummaryrefslogtreecommitdiff
path: root/lang/libobjc2
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-12 02:25:07 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-12 02:25:07 +0000
commit7bfae932f73e6929fd4fc0afd04e81199c58df00 (patch)
treeae010486371dd984317b78c829a6c1566d322249 /lang/libobjc2
parent43c9b0c5bc539452cc0f4da23f4ff1e08646554f (diff)
downloadports-7bfae932f73e6929fd4fc0afd04e81199c58df00.tar.gz
ports-7bfae932f73e6929fd4fc0afd04e81199c58df00.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". For people already testing powerpc on clang, it is possible that they already have both compilers in base. Thus, the assumption that "gcc is in base" (e.g. libstdc++.so exists) always means "force use of GCC" is already broken. It will be for everyone on -CURRENT once the switch is made. While here, standardize on compiler:c++11-lang instead of -lib (they are equivalent these days), pet portlint, and do some other cleanup. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=506432
Diffstat (limited to 'lang/libobjc2')
-rw-r--r--lang/libobjc2/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index 498f5042bbcd..0bdf95fedaf0 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -5,14 +5,15 @@ PORTNAME= libobjc2
PORTVERSION= 2.0
PORTREVISION= 1
CATEGORIES= lang devel gnustep
-LICENSE= MIT
MAINTAINER= theraven@FreeBSD.org
COMMENT= Replacement Objective-C runtime supporting modern Objective-C features
+LICENSE= MIT
+
BROKEN_powerpc= Does not compile on powerpc: Unsupported relocation type 10
BROKEN_sparc64= Does not compile on sparc64: Cannot configure clang properly
-USES= cmake objc:compiler
+USES= cmake compiler objc:compiler
USE_GITHUB= yes
GH_ACCOUNT= gnustep
@@ -27,11 +28,14 @@ PLIST_SUB+= SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR}
CMAKE_ARGS+= -DLIB_INSTALL_PATH=lib
CMAKE_ARGS+= -DTESTS=OFF
-.if exists(/usr/lib/libstdc++.so)
+
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
CXXFLAGS+= -stdlib=libstdc++
.endif
post-install:
${LN} -sf libobjc.so.${SHLIB_MAJOR}.${SHLIB_MINOR} ${STAGEDIR}${PREFIX}/lib/libobjc.so.${SHLIB_MAJOR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>