aboutsummaryrefslogtreecommitdiff
path: root/lang/librep/Makefile
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2009-05-24 19:52:23 +0000
committerAndrey Slusar <anray@FreeBSD.org>2009-05-24 19:52:23 +0000
commit5fdce584a47858517b401b36058c2ba0ba384a67 (patch)
tree89be277637ef78560aedec0468351b054693a245 /lang/librep/Makefile
parentd05ee21190ad653e039a4b8b3c8242dbb1612c8b (diff)
downloadports-5fdce584a47858517b401b36058c2ba0ba384a67.tar.gz
ports-5fdce584a47858517b401b36058c2ba0ba384a67.zip
Notes
Diffstat (limited to 'lang/librep/Makefile')
-rw-r--r--lang/librep/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 0b3a771cde87..efbf0468289e 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -6,10 +6,9 @@
# $MCom: ports/lang/librep/Makefile,v 1.2 2006/09/10 00:51:12 mezz Exp $
PORTNAME= librep
-PORTVERSION= 0.17
-PORTREVISION= 2
+PORTVERSION= 0.17.4
CATEGORIES= lang elisp gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= librep
MAINTAINER= anray@FreeBSD.org
@@ -17,12 +16,14 @@ COMMENT= An Emacs Lisp like runtime library
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
gmp.8:${PORTSDIR}/math/libgmp4
+RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
PLIST_SUB= GNUHOST=${ARCH}-pc-freebsd${OSREL:C/\..*//} VERSION=${PORTVERSION}
USE_GETTEXT= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}"
@@ -37,11 +38,4 @@ INFO= librep
BROKEN= Does not build on ia64
.endif
-post-extract:
- @${RM} ${WRKSRC}/test
-
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
- ${WRKSRC}/configure
-
.include <bsd.port.post.mk>