aboutsummaryrefslogtreecommitdiff
path: root/lang/libstdc++_stldoc_4.2.2
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2008-01-18 20:49:55 +0000
committerBruce M Simpson <bms@FreeBSD.org>2008-01-18 20:49:55 +0000
commit1bca129ace4a08b152eb5a1afb189489b7aeedd4 (patch)
treee15ba7e0b0645e695b3fd130dc72049cbef6b085 /lang/libstdc++_stldoc_4.2.2
parent4aa21add373a4da2596cefaacaa79ffa2cfc9ea2 (diff)
downloadports-1bca129ace4a08b152eb5a1afb189489b7aeedd4.tar.gz
ports-1bca129ace4a08b152eb5a1afb189489b7aeedd4.zip
Add a port for the g++ 4.2.2 C++ library documentation.
Notes
Notes: svn path=/head/; revision=205799
Diffstat (limited to 'lang/libstdc++_stldoc_4.2.2')
-rw-r--r--lang/libstdc++_stldoc_4.2.2/Makefile38
-rw-r--r--lang/libstdc++_stldoc_4.2.2/distinfo3
-rw-r--r--lang/libstdc++_stldoc_4.2.2/pkg-descr6
3 files changed, 47 insertions, 0 deletions
diff --git a/lang/libstdc++_stldoc_4.2.2/Makefile b/lang/libstdc++_stldoc_4.2.2/Makefile
new file mode 100644
index 000000000000..c67935553d40
--- /dev/null
+++ b/lang/libstdc++_stldoc_4.2.2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: libstdc++_stldoc
+# Date created: 18th January 2008
+# Whom: Bruce M. Simpson
+#
+# $FreeBSD$
+#
+# Note: Specific versions of this documentation exist for each version
+# of the libstdc++ library, note versioning convention below.
+#
+
+PORTNAME= libstdc++_stldoc_4.2.2
+PORTVERSION= 20071101
+CATEGORIES= lang devel
+MASTER_SITES= ${MASTER_SITE_GCC}
+MASTER_SITE_SUBDIR= \
+ libstdc++/doxygen
+DISTNAME= libstdc++-html-USERS-4.2.2
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= GNU libstdc++ API documentation
+
+USE_BZIP2= yes
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+# This port contains too many pathnames to use for globs.
+# PORTDOCS does not do the right thing when a single directory '.'
+# is specified, so use a directory name.
+
+PORTDOCS= stldoc
+
+do-install:
+ @${MKDIR} ${DOCSDIR}/stldoc
+ @cd ${WRKSRC}/html_user-4.2.20071101 && ${FIND} . -type f | \
+ ${XARGS} -J % ${INSTALL_DATA} % ${DOCSDIR}/stldoc
+
+.include <bsd.port.mk>
diff --git a/lang/libstdc++_stldoc_4.2.2/distinfo b/lang/libstdc++_stldoc_4.2.2/distinfo
new file mode 100644
index 000000000000..54f6cc51eb92
--- /dev/null
+++ b/lang/libstdc++_stldoc_4.2.2/distinfo
@@ -0,0 +1,3 @@
+MD5 (libstdc++-html-USERS-4.2.2.tar.bz2) = 2b49a808d2b3eb82136822a71afa36b0
+SHA256 (libstdc++-html-USERS-4.2.2.tar.bz2) = 993270983aef22bf73a88f41090fd32923b3c8041be157db081bff7ff20828de
+SIZE (libstdc++-html-USERS-4.2.2.tar.bz2) = 14416519
diff --git a/lang/libstdc++_stldoc_4.2.2/pkg-descr b/lang/libstdc++_stldoc_4.2.2/pkg-descr
new file mode 100644
index 000000000000..f01446aa4b5c
--- /dev/null
+++ b/lang/libstdc++_stldoc_4.2.2/pkg-descr
@@ -0,0 +1,6 @@
+This is the source / API documentation for the GNU C++ Library.
+
+It includes documentation of the implementation of the C++ Standard
+Template Library as shipped with GNU C++.
+
+WWW: http://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/index.html