aboutsummaryrefslogtreecommitdiff
path: root/lang/linux-dotnet-cli
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2018-06-30 07:40:20 +0000
committerDavid Naylor <dbn@FreeBSD.org>2018-06-30 07:40:20 +0000
commitc444ec3ffea4ad964ce555695f7c8c4555129e6a (patch)
treea0c56e52348225a9d3f6b80fdd8bb476f991e5b7 /lang/linux-dotnet-cli
parent7622ad2de81bae4e4078e3f68dfbefcd31dd75f9 (diff)
downloadports-c444ec3ffea4ad964ce555695f7c8c4555129e6a.tar.gz
ports-c444ec3ffea4ad964ce555695f7c8c4555129e6a.zip
Notes
Diffstat (limited to 'lang/linux-dotnet-cli')
-rw-r--r--lang/linux-dotnet-cli/Makefile19
-rw-r--r--lang/linux-dotnet-cli/pkg-message48
2 files changed, 67 insertions, 0 deletions
diff --git a/lang/linux-dotnet-cli/Makefile b/lang/linux-dotnet-cli/Makefile
new file mode 100644
index 000000000000..e1e7a0a3dd4e
--- /dev/null
+++ b/lang/linux-dotnet-cli/Makefile
@@ -0,0 +1,19 @@
+# Created by: David Naylor <dbn@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dotnet-cli
+DISTNAME= dotnet-runtime-${DISTVERSION}-linux-x64
+
+USE_LINUX=
+
+DISTINFO_FILE= ${MASTERDIR}/distinfo
+PLIST_FILES= bin/dotnet ${DATADIR}/dotnet
+PKGMESSAGE= ${.CURDIR}/pkg-message
+MASTERDIR= ${.CURDIR}/../linux-dotnet-runtime
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/dotnet ${STAGEDIR}${DATADIR}/dotnet
+ ${RLN} ${STAGEDIR}${DATADIR}/dotnet ${STAGEDIR}${PREFIX}/bin/dotnet
+
+.include "${MASTERDIR}/Makefile"
diff --git a/lang/linux-dotnet-cli/pkg-message b/lang/linux-dotnet-cli/pkg-message
new file mode 100644
index 000000000000..d2ee2527a006
--- /dev/null
+++ b/lang/linux-dotnet-cli/pkg-message
@@ -0,0 +1,48 @@
+Telemetry
+---------
+The .NET Core tools collect usage data in order to improve your experience.
+The data is anonymous and does not include command-line arguments. The data is
+collected by Microsoft and shared with the community. You can opt out of
+telemetry by setting a DOTNET_CLI_TELEMETRY_OPTOUT environment variable to 1
+using your favorite shell. You can read more about .NET Core tools telemetry @
+https://aka.ms/dotnet-cli-telemetry.
+
+CA Root Certificates for NSS
+----------------------------
+.NET Core requires NSS CA certificates installed. The recommended way to
+install the certificates is to:
+
+# pkg install ca_root_nss
+# ln -s /usr/local/share/certs/ca-root-nss.crt \
+ /compat/linux/etc/pki/tls/certs/ca-bundle.crt
+
+Failed to initialize CoreCLR, HRESULT: 0x8007001F
+-------------------------------------------------
+.NET core may produce the above error message if the system has exceeded
+capacity for wired memory, or is unprivilaged allocations of wired memory is
+not permitted.
+
+To ensure unprivilaged allocation of wired memory is allowed, as root:
+
+# sysctl security.bsd.unprivilaged_mlock=1
+
+To preserve this setting across reboots, append the following to
+/etc/sysctl.conf:
+
+security.bsd.unprivilaged_mlock=1
+
+To check the usage and limit of wired memory see the 'vm.stats.vm.v_wire_count'
+and 'vm.max_wired' sysctl(8) respectively. To increase the wired memory
+capacity set 'vm.max_wired' to a value greater than 'vm.stats.vm.v_wire_count'.
+.NET Core only requires ~128k wired memory per running application.
+
+For example, if one has:
+
+# sysctl vm.stats.vm.v_wire_count
+vm.stats.vm.v_wire_count: 1332146
+# sysctl vm.max_wired
+vm.max_wired: 1331964
+
+then increasing 'vm.max_wired' will enable .NET Core to run:
+
+# sysctl vm.max_wired=1333000