aboutsummaryrefslogtreecommitdiff
path: root/lang/lua52
diff options
context:
space:
mode:
authorIan Lepore <ian@FreeBSD.org>2016-02-20 19:19:50 +0000
committerIan Lepore <ian@FreeBSD.org>2016-02-20 19:19:50 +0000
commit53625bac52bb8604215639523b1893cebc9a58d3 (patch)
tree5010fade097bac5325d7bd4e7964e6ee479a7172 /lang/lua52
parentcae6f97d44592bf44cd69ecef7ef4b026bbc6588 (diff)
downloadports-53625bac52bb8604215639523b1893cebc9a58d3.tar.gz
ports-53625bac52bb8604215639523b1893cebc9a58d3.zip
Use -fPIC on all arches; lua builds the object files into a shared lib.
Since the object files get built into a shared lib, using -fPIC on all arches is the right thing to do, instead of adding it to each new arch that comes along which doesn't accidentally allow non-PIC modules in shared libs. PR: 207324 Approved by: mat(mentor) Differential Revision: https://reviews.freebsd.org/D5362
Notes
Notes: svn path=/head/; revision=409263
Diffstat (limited to 'lang/lua52')
-rw-r--r--lang/lua52/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/lang/lua52/Makefile b/lang/lua52/Makefile
index 02beccac1b2a..b7877b2ef47e 100644
--- a/lang/lua52/Makefile
+++ b/lang/lua52/Makefile
@@ -57,9 +57,7 @@ SUB_LIST= version=${PORTVERSION} \
libdir=${LUA_LIBDIR} \
soname=lua-${LUA_VER}
-CFLAGS_aarch64= -fPIC
-CFLAGS_amd64= -fPIC
-CFLAGS_powerpc= -fPIC
+CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e 's,rand *(,random(,g' \