aboutsummaryrefslogtreecommitdiff
path: root/lang/lua53
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-16 18:35:33 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-07-16 18:35:33 +0000
commit1d0c6d6f85076ce6cb03a0ed62bf706f00b1b109 (patch)
tree1bd8a2efe9455d86117346ba60d09752e16b19e3 /lang/lua53
parentd4c8d330928aaafaf9f5c4791524d9baf5d31eba (diff)
downloadports-1d0c6d6f85076ce6cb03a0ed62bf706f00b1b109.tar.gz
ports-1d0c6d6f85076ce6cb03a0ed62bf706f00b1b109.zip
lang/lua53: 5.3.0 -> 5.3.1
PR: 201469 Submitted by: milios@ccsys.com
Notes
Notes: svn path=/head/; revision=392310
Diffstat (limited to 'lang/lua53')
-rw-r--r--lang/lua53/Makefile4
-rw-r--r--lang/lua53/distinfo4
-rw-r--r--lang/lua53/files/patch-src__liolib.c10
3 files changed, 9 insertions, 9 deletions
diff --git a/lang/lua53/Makefile b/lang/lua53/Makefile
index a07f7fe89304..48198d2c31be 100644
--- a/lang/lua53/Makefile
+++ b/lang/lua53/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lua
-PORTVERSION= 5.3.0
+PORTVERSION= 5.3.1
CATEGORIES= lang
MASTER_SITES= http://www.lua.org/ftp/
PKGNAMESUFFIX= 53
@@ -13,7 +13,7 @@ COMMENT= Small, compilable scripting language providing easy access to C code
LICENSE= MIT
LUA_VER= 5.3
-LIB_DEPENDS= libedit.so.0:${PORTSDIR}/devel/libedit
+LIB_DEPENDS= libedit.so:${PORTSDIR}/devel/libedit
USE_LDCONFIG= yes
# Overriding __MAKE_CONF makes sure that we don't re-parse
diff --git a/lang/lua53/distinfo b/lang/lua53/distinfo
index cd30b9ec6ee6..4fe56ac1bffe 100644
--- a/lang/lua53/distinfo
+++ b/lang/lua53/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lua-5.3.0.tar.gz) = ae4a5eb2d660515eb191bfe3e061f2b8ffe94dce73d32cfd0de090ddcc0ddb01
-SIZE (lua-5.3.0.tar.gz) = 278045
+SHA256 (lua-5.3.1.tar.gz) = 072767aad6cc2e62044a66e8562f51770d941e972dc1e4068ba719cd8bffac17
+SIZE (lua-5.3.1.tar.gz) = 282401
diff --git a/lang/lua53/files/patch-src__liolib.c b/lang/lua53/files/patch-src__liolib.c
index 35a3db195d14..24fb69460fe0 100644
--- a/lang/lua53/files/patch-src__liolib.c
+++ b/lang/lua53/files/patch-src__liolib.c
@@ -1,10 +1,10 @@
---- ./src/liolib.c.orig 2013-01-05 22:46:54.000000000 +0100
-+++ ./src/liolib.c 2013-01-05 22:47:32.000000000 +0100
-@@ -19,6 +19,7 @@
+--- src/liolib.c.orig 2015-04-03 18:41:57 UTC
++++ src/liolib.c
+@@ -16,6 +16,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <unistd.h>
- #define liolib_c
- #define LUA_LIB
+ #include "lua.h"
+