aboutsummaryrefslogtreecommitdiff
path: root/lang/lua53
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /lang/lua53
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.tar.gz
ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
USES=lua gained flavors.
Ports using USES=lua:module or lua:flavors will be flavored. A range of supported lua versions can be set using XX-YY (or XX-, or -YY, or simply ZZ) for ports not supporting all lua versions. USES=lua sets LUA_FLAVOR that needs to be used on all dependencies of flavored lua ports, in a similar way as PHP or Python flavors. PR: 245038 Submitted by: andrew tao11 riddles org uk Reviewed by: mat, kevans, russ haley gmail com Approved by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D16494
Notes
Notes: svn path=/head/; revision=531700
Diffstat (limited to 'lang/lua53')
-rw-r--r--lang/lua53/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/lang/lua53/Makefile b/lang/lua53/Makefile
index c9761f157d06..059f03f3e5cf 100644
--- a/lang/lua53/Makefile
+++ b/lang/lua53/Makefile
@@ -13,7 +13,7 @@ COMMENT= Powerful, efficient, lightweight, embeddable scripting language
LICENSE= MIT
-LUA_VER= 5.3
+USES= lua:core,53
USE_LDCONFIG= yes
# Overriding __MAKE_CONF makes sure that we don't re-parse
@@ -32,18 +32,10 @@ BUILD_WRKSRC= ${WRKSRC}/src
# We put the docs for Lua proper in a lua/ subdir of the version subdir
# so that ports for Lua modules can use the version subdir too without
# making a mess.
-DOCSDIR= ${PREFIX}/share/doc/lua${PKGNAMESUFFIX}/lua
+DOCSDIR= ${LUA_DOCSDIR}
PORTDOCS= *
BUILD_WRKDOC= ${WRKSRC}/doc
-LUA_PREFIX= ${PREFIX}
-
-# 2018-03-17: AG - These should match lua.mk, but we can't include that here
-LUA_CMD= lua${PKGNAMESUFFIX}
-LUAC_CMD= luac${PKGNAMESUFFIX}
-LUA_INCDIR= ${LUA_PREFIX}/include/lua${PKGNAMESUFFIX}
-LUA_LIBDIR= ${LUA_PREFIX}/lib
-
LUA_LIB_STATIC= liblua-${LUA_VER}.a
LUA_LIB_SHARED= liblua-${LUA_VER}.so
LUA_PC_FILE= lua-${LUA_VER}.pc