aboutsummaryrefslogtreecommitdiff
path: root/lang/maude
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-12-17 17:31:26 +0000
committerJohn Marino <marino@FreeBSD.org>2016-12-17 17:31:26 +0000
commitca1beac70793f1075ebffd083532d684469cdd0a (patch)
tree33fba9393ecc78afd85760eb73a70376ac047256 /lang/maude
parenta31295340e877dd8ed161c8d0b948fd246802066 (diff)
downloadports-ca1beac70793f1075ebffd083532d684469cdd0a.tar.gz
ports-ca1beac70793f1075ebffd083532d684469cdd0a.zip
lang/maude: document ncurses requirement
- Set to link directly against ncurses (not curses) - Explicitly set extra patches to apply to DF as well. They were already but it wasn't clear if that was wanted or not. - set USES=alias to fix building on DF
Notes
Notes: svn path=/head/; revision=428787
Diffstat (limited to 'lang/maude')
-rw-r--r--lang/maude/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/lang/maude/Makefile b/lang/maude/Makefile
index ec26ac0f4bd3..4707f5a0edd4 100644
--- a/lang/maude/Makefile
+++ b/lang/maude/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= libbdd.so:science/buddy \
libgmp.so:math/gmp \
libsigsegv.so:devel/libsigsegv
-USES= autoreconf bison
+USES= alias autoreconf bison ncurses
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${NCURSESINC} -I${LOCALBASE}/include
+LDFLAGS+= -L${NCURSESLIB} -L${LOCALBASE}/lib
CONFIGURE_ARGS= --datadir=${DATADIR}
MAKE_JOBS_UNSAFE= yes
@@ -39,7 +39,7 @@ BROKEN_aarch64= Fails to link: missing sbrk
.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 1000000
+.if ${OPSYS} == "DragonFly" || ${OSVERSION} >= 1000000
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Mixfix-lexerAux
.endif
@@ -64,6 +64,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/src/Mixfix/global.hh
+ @${REINPLACE_CMD} -e 's|-lcurses|-lncurses|g' \
+ ${WRKSRC}/configure.ac
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}