aboutsummaryrefslogtreecommitdiff
path: root/lang/mdk/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-06-10 14:02:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-06-10 14:02:25 +0000
commit8d361cc8831b05c868ba08d1c4ec2e71137f874f (patch)
tree772e315b94fe67bfd3314315a95df002963c79c2 /lang/mdk/Makefile
parent4ec2f91a2bab05326c61686230b5a3c924923f7b (diff)
downloadports-8d361cc8831b05c868ba08d1c4ec2e71137f874f.tar.gz
ports-8d361cc8831b05c868ba08d1c4ec2e71137f874f.zip
Notes
Diffstat (limited to 'lang/mdk/Makefile')
-rw-r--r--lang/mdk/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
index 0664b57453f8..c0a91748aa6c 100644
--- a/lang/mdk/Makefile
+++ b/lang/mdk/Makefile
@@ -7,24 +7,28 @@
#
PORTNAME= mdk
-PORTVERSION= 1.0
+PORTVERSION= 1.0.1
CATEGORIES= lang gnome
MASTER_SITES= ${MASTER_SITE_GNU} \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= MIX Development Kit offers an emulation of MIX and MIXAL
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
+ intl.4:${PORTSDIR}/devel/gettext \
+ guile.15:${PORTSDIR}/lang/guile
+
+USE_GETOPT_LONG= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-USE_GMAKE= yes
+USE_GNOME= glib12 gtk12 libglade gnomehack gnomehier gnomeprefix
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
post-extract:
- @${RM} -f ${WRKSRC}/doc/*.info
+ @${RM} -f ${WRKSRC}/doc/*.info*
.include <bsd.port.mk>