aboutsummaryrefslogtreecommitdiff
path: root/lang/modula-3
diff options
context:
space:
mode:
authorJohn Polstra <jdp@FreeBSD.org>1999-01-28 05:39:19 +0000
committerJohn Polstra <jdp@FreeBSD.org>1999-01-28 05:39:19 +0000
commit28eacf3dc2aeb4cadfcc6ecacd2426c4f3658626 (patch)
tree24dd3da0522a97cb28f4cafc37decb30b138170a /lang/modula-3
parentdc691c41bd8eeeef851595f336e37864228cbe16 (diff)
downloadports-28eacf3dc2aeb4cadfcc6ecacd2426c4f3658626.tar.gz
ports-28eacf3dc2aeb4cadfcc6ecacd2426c4f3658626.zip
Notes
Diffstat (limited to 'lang/modula-3')
-rw-r--r--lang/modula-3/Makefile27
-rw-r--r--lang/modula-3/scripts/fix_pathnames12
-rw-r--r--lang/modula-3/scripts/maybe-strip7
3 files changed, 28 insertions, 18 deletions
diff --git a/lang/modula-3/Makefile b/lang/modula-3/Makefile
index 2afa5181ce00..a0ee3a395e2a 100644
--- a/lang/modula-3/Makefile
+++ b/lang/modula-3/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Mar 1996
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id: Makefile,v 1.26 1998/10/13 01:17:27 jseger Exp $
+# $Id: Makefile,v 1.27 1998/12/04 07:23:01 asami Exp $
#
DISTNAME= modula-3-3.6
@@ -22,17 +22,6 @@ MAN1= analyze_coverage.1 m3browser.1 m3build.1 \
m3totex.1 m3where.1 quake.1 recordheap.1
SCRIPTS_ENV+= MAJOR=${major} PKGDIR=${PKGDIR} PLIST=${PLIST}
-# Support building on systems with or without X11 installed. The port
-# only supports X11R6 in the standard location, so we don't bother using
-# the X11BASE macro. It's not defined yet at this point in the Makefile
-# anyway.
-.if exists(/usr/X11R6/lib/libX11.a)
-PLIST= ${WRKDIR}/PLIST
-MAN1+= formsedit.1 replayheap.1 showheap.1 shownew.1 showthread.1
-.else
-PLIST= ${WRKDIR}/PLIST.noX11
-.endif
-
# Shared library major version number. Keep this in sync with the
# modula-3-lib port.
major= 6
@@ -43,6 +32,17 @@ major= 6
# be "installed" into the following directory, which we own.
temp_prefix= ${WRKSRC}/installed
+# Support building on systems with or without X11 installed.
+.ifdef NO_X11
+PLIST= ${WRKDIR}/PLIST.noX11
+.else
+pre-fetch:
+ @echo "To build this port without X11, define \"NO_X11\"."
+
+PLIST= ${WRKDIR}/PLIST
+MAN1+= formsedit.1 replayheap.1 showheap.1 shownew.1 showthread.1
+.endif
+
do-install:
@echo "Deleting extraneous cruft"
@cd ${temp_prefix}/lib/m3/pkg; \
@@ -93,7 +93,8 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/m3/src/COPYRIGHT ${PREFIX}/share/modula-3
@echo "Stripping executables"
@cd ${temp_prefix}; \
- find bin -type f ! -name recordheap | (cd ${PREFIX}; xargs strip)
+ find bin -type f ! -name recordheap |\
+ (cd ${PREFIX}; xargs ${SH} ${SCRIPTDIR}/maybe-strip)
@cd ${PREFIX}/lib/m3/FreeBSD2; strip m3 m3cgc1 m3mkdir
@cd ${PREFIX}/bin; \
ln -f m3build m3build-${major}
diff --git a/lang/modula-3/scripts/fix_pathnames b/lang/modula-3/scripts/fix_pathnames
index c04fca5f9868..2eca36b5b708 100644
--- a/lang/modula-3/scripts/fix_pathnames
+++ b/lang/modula-3/scripts/fix_pathnames
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# $Id: fix_pathnames,v 1.2 1996/09/10 05:25:10 jdp Exp $
+# $Id: fix_pathnames,v 1.3 1996/10/29 23:17:19 jdp Exp $
umask 022
@@ -20,8 +20,10 @@ pkgdir=lib/m3/pkg
cd ${newpath}/${pkgdir}
for i in `cd ${oldpath}/${pkgdir}; \
find . -type f \( -name .M3IMPTAB -o -name FreeBSD2 \)`; do
- test -f ${i}.bak || cp -p ${i} ${i}.bak
- rm -f ${i}
- sed -e "s|/[^ ]*/work/installed/|${newpath}/|g" ${i}.bak >${i} && \
- rm -f ${i}.bak
+ if [ -f ${i} ]; then
+ test -f ${i}.bak || cp -p ${i} ${i}.bak
+ rm -f ${i}
+ sed -e "s|/[^ ]*/work/installed/|${newpath}/|g" ${i}.bak >${i} && \
+ rm -f ${i}.bak
+ fi
done
diff --git a/lang/modula-3/scripts/maybe-strip b/lang/modula-3/scripts/maybe-strip
new file mode 100644
index 000000000000..ef0b03f05592
--- /dev/null
+++ b/lang/modula-3/scripts/maybe-strip
@@ -0,0 +1,7 @@
+#! /bin/sh
+
+for i; do
+ if [ -f $i ]; then
+ strip $i
+ fi
+done