aboutsummaryrefslogtreecommitdiff
path: root/lang/mono
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2016-11-14 16:33:15 +0000
committerTom Judge <tj@FreeBSD.org>2016-11-14 16:33:15 +0000
commitd80cc28447ab4ecc59b307d80b436642216935e9 (patch)
tree91286a7b40054bb45ae307e07c4e529cc27c3210 /lang/mono
parentfa079162d7b2aa28e0383e751b9def15239260c8 (diff)
downloadports-d80cc28447ab4ecc59b307d80b436642216935e9.tar.gz
ports-d80cc28447ab4ecc59b307d80b436642216935e9.zip
Fix the patch to actually patch the file, not just create a patch file.
Notes
Notes: svn path=/head/; revision=426124
Diffstat (limited to 'lang/mono')
-rw-r--r--lang/mono/Makefile1
-rw-r--r--lang/mono/files/patch-mono_utils_mono-proclib.c16
-rw-r--r--lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c19
3 files changed, 17 insertions, 19 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index aff85b6f364d..f2f3ddd957c1 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mono
PORTVERSION= 4.6.1.5
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
diff --git a/lang/mono/files/patch-mono_utils_mono-proclib.c b/lang/mono/files/patch-mono_utils_mono-proclib.c
new file mode 100644
index 000000000000..2edf8e10d6eb
--- /dev/null
+++ b/lang/mono/files/patch-mono_utils_mono-proclib.c
@@ -0,0 +1,16 @@
+--- mono/utils/mono-proclib.c.orig 2016-07-29 09:10:33 UTC
++++ mono/utils/mono-proclib.c
+@@ -107,11 +107,11 @@ mono_process_list (int *size)
+ mib [2] = KERN_PROC_ALL;
+ mib [3] = 0;
+
+- res = sysctl (mib, 4, NULL, &data_len, NULL, 0);
++ res = sysctl (mib, 3, NULL, &data_len, NULL, 0);
+ if (res)
+ return NULL;
+ processes = (struct kinfo_proc *) malloc (data_len);
+- res = sysctl (mib, 4, processes, &data_len, NULL, 0);
++ res = sysctl (mib, 3, processes, &data_len, NULL, 0);
+ if (res < 0) {
+ free (processes);
+ if (errno != ENOMEM)
diff --git a/lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c b/lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c
deleted file mode 100644
index 906199b6a1fc..000000000000
--- a/lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- mono/utils/patch-mono_utils_mono-proclib.c.orig 2016-10-05 17:28:38 UTC
-+++ mono/utils/patch-mono_utils_mono-proclib.c
-@@ -0,0 +1,16 @@
-+--- mono/utils/mono-proclib.c.orig 2016-07-29 09:10:33 UTC
-++++ mono/utils/mono-proclib.c
-+@@ -107,11 +107,11 @@ mono_process_list (int *size)
-+ mib [2] = KERN_PROC_ALL;
-+ mib [3] = 0;
-+
-+- res = sysctl (mib, 4, NULL, &data_len, NULL, 0);
-++ res = sysctl (mib, 3, NULL, &data_len, NULL, 0);
-+ if (res)
-+ return NULL;
-+ processes = (struct kinfo_proc *) malloc (data_len);
-+- res = sysctl (mib, 4, processes, &data_len, NULL, 0);
-++ res = sysctl (mib, 3, processes, &data_len, NULL, 0);
-+ if (res < 0) {
-+ free (processes);
-+ if (errno != ENOMEM)