aboutsummaryrefslogtreecommitdiff
path: root/lang/mujs
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-17 16:07:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-17 16:07:29 +0000
commit76a2f1729986ddf4f2cb472cfa2807ef82d38280 (patch)
tree39dcd6521a36a0963c1b34b7d5393e815d420b55 /lang/mujs
parente2b1aaa548d8644ee7888c10a1e1bbac393a2ab9 (diff)
downloadports-76a2f1729986ddf4f2cb472cfa2807ef82d38280.tar.gz
ports-76a2f1729986ddf4f2cb472cfa2807ef82d38280.zip
New port: lang/mujs: Embeddable Javascript interpreter in C
Notes
Notes: svn path=/head/; revision=464830
Diffstat (limited to 'lang/mujs')
-rw-r--r--lang/mujs/Makefile27
-rw-r--r--lang/mujs/distinfo3
-rw-r--r--lang/mujs/files/patch-Makefile23
-rw-r--r--lang/mujs/pkg-descr11
4 files changed, 64 insertions, 0 deletions
diff --git a/lang/mujs/Makefile b/lang/mujs/Makefile
new file mode 100644
index 000000000000..ff7f203d8a8a
--- /dev/null
+++ b/lang/mujs/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= mujs
+DISTVERSION= 1.0.3
+CATEGORIES= lang devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Embeddable Javascript interpreter in C
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= ccxvii
+USE_LDCONFIG= yes
+ALL_TARGET= default
+
+PLIST_FILES= bin/mujs \
+ include/mujs.h \
+ lib/libmujs.so \
+ libdata/pkgconfig/mujs.pc
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmujs.so
+
+.include <bsd.port.mk>
diff --git a/lang/mujs/distinfo b/lang/mujs/distinfo
new file mode 100644
index 000000000000..6e68e3132492
--- /dev/null
+++ b/lang/mujs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521301055
+SHA256 (ccxvii-mujs-1.0.3_GH0.tar.gz) = 5aabafe512d7a7c6d2c8d67483a5331e55440eeca2db2dc4602ca643c62b5ef6
+SIZE (ccxvii-mujs-1.0.3_GH0.tar.gz) = 117180
diff --git a/lang/mujs/files/patch-Makefile b/lang/mujs/files/patch-Makefile
new file mode 100644
index 000000000000..c4e2ea6b836c
--- /dev/null
+++ b/lang/mujs/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2018-03-17 15:44:40 UTC
++++ Makefile
+@@ -45,9 +45,9 @@ OUT := build/$(build)
+ SRCS := $(wildcard js*.c utf*.c regexp.c)
+ HDRS := $(wildcard js*.h mujs.h utf.h regexp.h)
+
+-default: static
++default: shared
+ static: $(OUT) $(OUT)/mujs $(OUT)/libmujs.a $(OUT)/mujs.pc
+-shared: static $(OUT)/libmujs.so
++shared: $(OUT) $(OUT)/mujs $(OUT)/libmujs.so $(OUT)/mujs.pc
+
+ astnames.h: jsparse.h
+ grep -E '(AST|EXP|STM)_' jsparse.h | sed 's/^[^A-Z]*\(AST_\)*/"/;s/,.*/",/' | tr A-Z a-z > $@
+@@ -105,7 +105,7 @@ install-static: install-common
+ install-shared: install-common
+ install -m 755 build/release/libmujs.so $(DESTDIR)$(libdir)
+
+-install: install-static
++install: install-shared
+
+ tarball:
+ git archive --format=zip --prefix=mujs-$(VERSION)/ HEAD > mujs-$(VERSION).zip
diff --git a/lang/mujs/pkg-descr b/lang/mujs/pkg-descr
new file mode 100644
index 000000000000..7aa5b9c1aa20
--- /dev/null
+++ b/lang/mujs/pkg-descr
@@ -0,0 +1,11 @@
+MuJS is a lightweight Javascript interpreter designed for embedding in
+other software to extend them with scripting capabilities.
+
+MuJS was designed with a focus on small size, correctness, and simplicity.
+It is written in portable C and implements ECMAScript as specified by ECMA-262.
+The interface for binding with native code is designed to be as simple as
+possible to use, and is very similar to Lua. There is no need to interact with
+byzantine C++ template mechanisms, or worry about marking and unmarking garbage
+collection roots, or wrestle with obscure build systems.
+
+WWW: https://mujs.com/