aboutsummaryrefslogtreecommitdiff
path: root/lang/mujs
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-12-19 07:36:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-12-19 07:36:57 +0000
commit847b4fbe67e1a7a58673da7605aa2e0a132d5a19 (patch)
tree519e7843e354ac60ce522a7d0e33d1bf92bb01cd /lang/mujs
parent694847e2bf55422b8346dd4cdb1f318714000624 (diff)
downloadports-847b4fbe67e1a7a58673da7605aa2e0a132d5a19.tar.gz
ports-847b4fbe67e1a7a58673da7605aa2e0a132d5a19.zip
lang/mujs: Add the 32BIT option allowing to execute much larger programs
Notes
Notes: svn path=/head/; revision=520423
Diffstat (limited to 'lang/mujs')
-rw-r--r--lang/mujs/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/mujs/Makefile b/lang/mujs/Makefile
index f2c98ebc281f..da03339e76a5 100644
--- a/lang/mujs/Makefile
+++ b/lang/mujs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mujs
DISTVERSION= 1.0.6-6
DISTVERSIONSUFFIX= -g8c86834
+PORTREVISION= 1
CATEGORIES= lang devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
@@ -31,6 +32,14 @@ PLIST_FILES= bin/mujs \
lib/libmujs.a \
libdata/pkgconfig/mujs.pc
+OPTIONS_DEFINE= 32BIT
+OPTIONS_DEFAULT= 32BIT
+
+32BIT_DESC= 32-bit address space to allow for larger programs
+
+post-patch-32BIT-on:
+ @${REINPLACE_CMD} 's|typedef unsigned short js_Instruction|typedef int js_Instruction|' ${WRKSRC}/jsi.h
+
post-install: # https://github.com/ccxvii/mujs/issues/99
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmujs.so