aboutsummaryrefslogtreecommitdiff
path: root/lang/neko
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-09-09 23:15:30 +0000
committerJohn Marino <marino@FreeBSD.org>2014-09-09 23:15:30 +0000
commita32b2f6852819dbd0495e0e6f0be6c5dcaf707f7 (patch)
tree4dd7627f010e9a9e6976ca03aece86a3b1fada32 /lang/neko
parenta7fd113bfdbad60719fceee68b2fa23b13033607 (diff)
downloadports-a32b2f6852819dbd0495e0e6f0be6c5dcaf707f7.tar.gz
ports-a32b2f6852819dbd0495e0e6f0be6c5dcaf707f7.zip
Remove four unrelated staged ports
Notes
Notes: svn path=/head/; revision=367791
Diffstat (limited to 'lang/neko')
-rw-r--r--lang/neko/Makefile155
-rw-r--r--lang/neko/distinfo2
-rw-r--r--lang/neko/files/patch-libs_std_md5.c11
-rw-r--r--lang/neko/files/patch-libs_std_process.c11
-rw-r--r--lang/neko/files/patch-libs_std_sys.c14
-rw-r--r--lang/neko/pkg-descr12
-rw-r--r--lang/neko/pkg-plist20
7 files changed, 0 insertions, 225 deletions
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
deleted file mode 100644
index d742c94c52ee..000000000000
--- a/lang/neko/Makefile
+++ /dev/null
@@ -1,155 +0,0 @@
-# Created by: Masanori OZAWA (ozawa@ongs.co.jp)
-# $FreeBSD$
-
-PORTNAME= neko
-PORTVERSION= 2.0.0
-PORTREVISION= 2
-CATEGORIES= lang
-MASTER_SITES= http://nekovm.org/_media/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The Neko Programming Language
-
-LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
-
-ONLY_FOR_ARCHS= i386 amd64
-
-USES= dos2unix gmake pkgconfig
-USE_AUTOTOOLS= libtool:env
-MAKE_JOBS_UNSAFE= yes
-DOS2UNIX_REGEX= .*(Makefile|\.(c|h|neko|nml))$$
-
-OPTIONS_DEFINE= APACHE MYSQL SQLITE PCRE GTK2
-OPTIONS_DEFAULT= PCRE GTK2
-
-OPTIONS_SINGLE= MYSQL
-OPTIONS_SINGLE_MYSQL= MYSQL4 MYSQL5
-
-MYSQL4_DESC= Build against MySQL 4.1
-MYSQL5_DESC= Build against MySQL 5.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-LIBKEYNAME+= mod_neko mod_tora
-
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE= 22
-CFLAGS+= -I${LOCALBASE}/include/apache22
-PLIST_SUB+= APACHE22=""
-.else
-LIBKEYNAME+= mod_neko2 mod_tora2
-PLIST_SUB+= APACHE22="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL4}
-USE_MYSQL= 41
-CFLAGS+= -I${LOCALBASE}/include/mysql
-PLIST_SUB+= MYSQL4=""
-.else
-LIBKEYNAME+= mysql
-PLIST_SUB+= MYSQL4="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL5}
-USE_MYSQL= 51
-CFLAGS+= -I${LOCALBASE}/include/mysql
-PLIST_SUB+= MYSQL5=""
-.else
-LIBKEYNAME+= mysql5
-PLIST_SUB+= MYSQL5="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
-PLIST_SUB+= SQLITE3=""
-.else
-LIBKEYNAME+= sqlite
-PLIST_SUB+= SQLITE3="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
-PLIST_SUB+= PCRE=""
-.else
-LIBKEYNAME+= regexp
-PLIST_SUB+= PCRE="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME= gtk20
-PLIST_SUB+= GTK2=""
-.else
-LIBKEYNAME+= ui
-PLIST_SUB+= GTK2="@comment "
-.endif
-
-.if ${ARCH} == "amd64"
-CFLAGS+= -D_64BITS -fPIC
-.endif
-
-post-patch:
- @${REINPLACE_CMD} \
- -e '/INSTALL_PREFIX/s,/usr/local,${PREFIX},' \
- -e '/^CFLAGS =/s,.$$, ${CFLAGS},' \
- -e '/LIBNEKO_LIBS =/s,[-]ldl,${LDFLAGS},' \
- -e '/LIBNEKO_LIBS =/s,[-]lgc,-lgc-threaded,' \
- -e '/NEKOVM_FLAGS =/s,[-]lneko,-L${LOCALBASE}/lib -lneko -lgc-threaded,' \
- -e '/mkdir/s,\(INSTALL_PREFIX[}]/include\),\1/neko,' \
- -e '/cp vm[/]neko[*][.]h/s,\(INSTALL_PREFIX[}]/include\),\1/neko,' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} \
- -e '/^[#] include/s,wait.h,sys/wait.h,' \
- ${WRKSRC}/libs/std/process.c
- @${REINPLACE_CMD} \
- -e '/^linkcmd =/s,"ld",cc,' \
- -e 's/= readline[(][)];/= "s";/' \
- -e 's,/usr/local/include,${PREFIX}/include,' \
- -e 's,/usr/local/lib,${PREFIX}/lib,' \
- ${WRKSRC}/src/tools/install.neko
-.if !empty(LIBKEYNAME)
-.for LKN in ${LIBKEYNAME}
- @${REINPLACE_CMD} \
- -e '/^ ${LKN} =[>]/,/^ [}][,]\{0,1\}.$$/d' \
- ${WRKSRC}/src/tools/install.neko
-.endfor
-.endif
-.if ${PORT_OPTIONS:MAPACHE}
- @${REINPLACE_CMD} \
- -e 's,"/usr/include/apache2","${PREFIX}/include/apache22",' \
- ${WRKSRC}/src/tools/install.neko
-.endif
-.if ${PORT_OPTIONS:MGTK2}
- @${REINPLACE_CMD} \
- -e 's,"/usr/include/gtk-2.0","${PREFIX}/include/gtk-2.0",' \
- ${WRKSRC}/src/tools/install.neko
- @${REINPLACE_CMD} \
- -e 's,NEKO_LINUX,NEKO_BSD,' ${WRKSRC}/libs/ui/ui.c
-.endif
-.if ${ARCH} == "amd64" && ${PORT_OPTIONS:MMYSQL4}
- @${ECHO_CMD}
- @${ECHO_CMD} "======================================================="
- @${ECHO_CMD}
- @${ECHO_CMD} " Notice: When not building MYSQL with 'CFLAGS+=-fPIC'"
- @${ECHO_CMD} " first, It fails in building of a MYSQL module."
- @${ECHO_CMD}
- @${ECHO_CMD} "======================================================="
- @${ECHO_CMD}
-.endif
-
-post-install:
-.if ${PORT_OPTIONS:MAPACHE}
- @${ECHO_CMD}
- @${ECHO_CMD} "======================================================="
- @${ECHO_CMD}
- @${ECHO_CMD} " If you want to use Apache with mod_neko, you need "
- @${ECHO_CMD} " edit the Apache configuration files."
- @${ECHO_CMD} " Please see 'http://nekovm.org/doc/mod_neko' for details."
- @${ECHO_CMD}
- @${ECHO_CMD} "======================================================="
- @${ECHO_CMD}
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/neko/distinfo b/lang/neko/distinfo
deleted file mode 100644
index 89f1d04bf953..000000000000
--- a/lang/neko/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (neko-2.0.0.tar.gz) = 47a4714df7a603fc64995fc353f09205e52da4df954b6c6969d7d1b9a00a95d1
-SIZE (neko-2.0.0.tar.gz) = 425539
diff --git a/lang/neko/files/patch-libs_std_md5.c b/lang/neko/files/patch-libs_std_md5.c
deleted file mode 100644
index ebc3613a92f1..000000000000
--- a/lang/neko/files/patch-libs_std_md5.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/std/md5.c.orig 2012-12-05 14:07:07.000000000 +0900
-+++ libs/std/md5.c 2012-12-05 14:07:20.000000000 +0900
-@@ -16,7 +16,7 @@
- /* ************************************************************************ */
- #include <neko.h>
- #include <string.h>
--#include "sha1.h"
-+#include "../common/sha1.h"
-
- /**
- <doc>
diff --git a/lang/neko/files/patch-libs_std_process.c b/lang/neko/files/patch-libs_std_process.c
deleted file mode 100644
index 3c5fad76475b..000000000000
--- a/lang/neko/files/patch-libs_std_process.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/std/process.c.orig 2009-06-19 00:08:00.000000000 +0900
-+++ libs/std/process.c 2009-06-19 00:08:06.000000000 +0900
-@@ -23,7 +23,7 @@
- # include <unistd.h>
- # include <errno.h>
- # ifndef NEKO_MAC
--# include <wait.h>
-+# include <sys/wait.h>
- # endif
- #endif
-
diff --git a/lang/neko/files/patch-libs_std_sys.c b/lang/neko/files/patch-libs_std_sys.c
deleted file mode 100644
index 250550943fc1..000000000000
--- a/lang/neko/files/patch-libs_std_sys.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- libs/std/sys.c.orig 2013-10-03 01:47:05.000000000 +0900
-+++ libs/std/sys.c 2013-10-03 01:45:35.000000000 +0900
-@@ -41,7 +41,11 @@
- # include <sys/time.h>
- # include <sys/times.h>
- # include <sys/wait.h>
-+# if __FreeBSD_version >= 900044
- # include <xlocale.h>
-+# else
-+# undef NEKO_POSIX
-+# endif
- #endif
-
- #ifdef NEKO_MAC
diff --git a/lang/neko/pkg-descr b/lang/neko/pkg-descr
deleted file mode 100644
index d28330e19b53..000000000000
--- a/lang/neko/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-The Neko Programming Language
-
-Neko is a high-level dynamically typed programming language which can
-also be used as an embedded scripting language. It has been designed to
-provide a common runtime for several different languages.
-
-Neko is not only very easy to learn and use, but also has the flexibility
-of being able to extend the language with C libraries. You can even write
-generators from your own language to Neko and then use the Neko Runtime to
-compile, run, and access existing libraries.
-
-WWW: http://nekovm.org/
diff --git a/lang/neko/pkg-plist b/lang/neko/pkg-plist
deleted file mode 100644
index 8d3af373c17d..000000000000
--- a/lang/neko/pkg-plist
+++ /dev/null
@@ -1,20 +0,0 @@
-bin/neko
-bin/nekoc
-bin/nekoml.std
-bin/nekoml
-bin/nekotools
-lib/libneko.so
-lib/neko/std.ndll
-lib/neko/zlib.ndll
-%%APACHE22%%lib/neko/mod_neko2.ndll
-%%APACHE22%%lib/neko/mod_tora2.ndll
-%%MYSQL4%%lib/neko/mysql.ndll
-%%MYSQL5%%lib/neko/mysql5.ndll
-%%SQLITE3%%lib/neko/sqlite.ndll
-%%PCRE%%lib/neko/regexp.ndll
-%%GTK2%%lib/neko/ui.ndll
-include/neko/neko.h
-include/neko/neko_mod.h
-include/neko/neko_vm.h
-@dirrm lib/neko
-@dirrm include/neko