aboutsummaryrefslogtreecommitdiff
path: root/lang/nesasm
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-06 05:56:58 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-06 05:56:58 +0000
commit3e3e6b92e9630440dd9ddce1479c839920ae74f0 (patch)
treebf4cabc44168cd5a7be36ea7556ac0e95a274544 /lang/nesasm
parente65deabb136738d816cca67a116c3db30f429294 (diff)
downloadports-3e3e6b92e9630440dd9ddce1479c839920ae74f0.tar.gz
ports-3e3e6b92e9630440dd9ddce1479c839920ae74f0.zip
New port: lang devel/nesasm: 6502 assembler with specific NES support
nesasm is a 6502 assembler with specific NES support. NES support in this case refers to FamiCOM and Nintendo Entertainment System support. lang/fasm has been used as a reference on how an assembler should be ported. Feedback is as always welcome, hopefully it will lead to me producing better ports and less work for you committer ;) WWW: http://bobrost.com/nes/resources.php PR: ports/115254 Submitted by: Pontus Stenetorp <ninjin@kth.se>
Notes
Notes: svn path=/head/; revision=198903
Diffstat (limited to 'lang/nesasm')
-rw-r--r--lang/nesasm/Makefile29
-rw-r--r--lang/nesasm/distinfo3
-rw-r--r--lang/nesasm/files/patch-Makefile8
-rw-r--r--lang/nesasm/pkg-descr3
-rw-r--r--lang/nesasm/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/lang/nesasm/Makefile b/lang/nesasm/Makefile
new file mode 100644
index 000000000000..e13a386a7b41
--- /dev/null
+++ b/lang/nesasm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: nesasm
+# Date created: 6 August 2007
+# Whom: Pontus Stenetorp <ninjin@kth.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nesasm
+PORTVERSION= 20040314
+CATEGORIES= lang devel
+MASTER_SITES= http://bobrost.com/nes/files/
+DISTNAME= nbasic_2004_03_14
+
+MAINTAINER= ninjin@kth.se
+COMMENT= The nesasm assembler is a 6502 assembler with specific NES support
+
+WRKSRC= ${WRKDIR}/nbasic_2004_03_14/source/${PORTNAME}/source/
+USE_ZIP= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/nesasm ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}../documentation/*.txt ${DOCSDIR}
+ # The next install will overwrite readme.txt with a newer readme.txt
+ ${INSTALL_DATA} ${WRKSRC}../readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/nesasm/distinfo b/lang/nesasm/distinfo
new file mode 100644
index 000000000000..7fc2f66c0e60
--- /dev/null
+++ b/lang/nesasm/distinfo
@@ -0,0 +1,3 @@
+MD5 (nbasic_2004_03_14.zip) = ea6e00be9c4f4ec06d1d51947ab6f7d3
+SHA256 (nbasic_2004_03_14.zip) = 23c0106c397aec03ab8401c0dc0072eaeb420401f3c40d69ee1d3bd3e398a7b9
+SIZE (nbasic_2004_03_14.zip) = 585041
diff --git a/lang/nesasm/files/patch-Makefile b/lang/nesasm/files/patch-Makefile
new file mode 100644
index 000000000000..80ade1b2f04a
--- /dev/null
+++ b/lang/nesasm/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig Tue Aug 7 00:04:20 2007
++++ Makefile Tue Aug 7 00:04:47 2007
+@@ -1,4 +1,4 @@
+-default:
++all:
+ make -f Makefile.unix
+
+ clean:
diff --git a/lang/nesasm/pkg-descr b/lang/nesasm/pkg-descr
new file mode 100644
index 000000000000..db4b7e666e18
--- /dev/null
+++ b/lang/nesasm/pkg-descr
@@ -0,0 +1,3 @@
+The nesasm assembler is a 6502 assembler with specific NES support.
+
+WWW: http://bobrost.com/nes/resources.php
diff --git a/lang/nesasm/pkg-plist b/lang/nesasm/pkg-plist
new file mode 100644
index 000000000000..d3ec463f26b8
--- /dev/null
+++ b/lang/nesasm/pkg-plist
@@ -0,0 +1,8 @@
+bin/nesasm
+%%DOCSDIR%%/cpu_inst.txt
+%%DOCSDIR%%/history.txt
+%%DOCSDIR%%/index.txt
+%%DOCSDIR%%/neshdr20.txt
+%%DOCSDIR%%/readme.txt
+%%DOCSDIR%%/usage.txt
+@dirrm %%DOCSDIR%%