aboutsummaryrefslogtreecommitdiff
path: root/lang/nickle
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-11-18 13:51:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-11-18 13:51:51 +0000
commit096910598200334a7a523321dde44db04eb9aac8 (patch)
tree29d0bbb07992e512e3779cd873b5d0396c1143b5 /lang/nickle
parent51c60ddf7f7c0942f2a332498ef7e104a0c11dc0 (diff)
downloadports-096910598200334a7a523321dde44db04eb9aac8.tar.gz
ports-096910598200334a7a523321dde44db04eb9aac8.zip
- Drop the article from COMMENT line, sort the knobs
- Convert USE_GMAKE to USES, expand ${PTHREAD_LIBS} - Stagify and unmute copying of examples while here
Notes
Notes: svn path=/head/; revision=334195
Diffstat (limited to 'lang/nickle')
-rw-r--r--lang/nickle/Makefile32
-rw-r--r--lang/nickle/pkg-plist1
2 files changed, 13 insertions, 20 deletions
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index 0279f5a1072e..e28cee43acb7 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -7,38 +7,30 @@ CATEGORIES= lang
MASTER_SITES= http://www.nickle.org/release/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A numeric oriented programming language
+COMMENT= Numeric-oriented programming language
LICENSE= MIT
-OPTIONS_DEFINE= EXAMPLES
-
-USES= ncurses
-USE_GMAKE= yes
+USES= gmake ncurses
GNU_CONFIGURE= yes
# Nickle now has bindings which are likely to pull in libraries that need
# libpthread. Link to it now explicitly, or it wouldn't work at runtime.
-LDFLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= -pthread
-MAN1= nickle.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= EXAMPLES
post-patch:
- @${REINPLACE_CMD} -e \
- '/^SUBDIRS/s|examples|| ; \
- s| -O2||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|examples|| ; s| -O2||' \
+ ${WRKSRC}/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
-name "*.sgml" \) | ${CPIO} -pdm -L \
- -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR})
- @${FIND} ${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
- @${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
-.endif
+ -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${EXAMPLESDIR})
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} \
+ ${SHAREMODE}
.include <bsd.port.mk>
diff --git a/lang/nickle/pkg-plist b/lang/nickle/pkg-plist
index 7d0a33e6f799..53dcc21b0b06 100644
--- a/lang/nickle/pkg-plist
+++ b/lang/nickle/pkg-plist
@@ -10,6 +10,7 @@ include/nickle/opcode.h
include/nickle/ref.h
include/nickle/stack.h
include/nickle/value.h
+man/man1/nickle.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/COPYING
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb.5c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cribbage.5c