aboutsummaryrefslogtreecommitdiff
path: root/lang/nickle
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:44:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:44:31 +0000
commit7d5a8531c3bb758f0ca62c8045645f215f573985 (patch)
tree4952392645d14fc85aea87b6c23f8bcd628c7e77 /lang/nickle
parent196758f91873fa9073b2b929d7f586bd5b8fbee9 (diff)
downloadports-7d5a8531c3bb758f0ca62c8045645f215f573985.tar.gz
ports-7d5a8531c3bb758f0ca62c8045645f215f573985.zip
- Update to version 2.73
PR: 166040 Submitted by: Ports FUry Feature safe: yes
Notes
Notes: svn path=/head/; revision=293762
Diffstat (limited to 'lang/nickle')
-rw-r--r--lang/nickle/Makefile18
-rw-r--r--lang/nickle/distinfo4
-rw-r--r--lang/nickle/pkg-plist74
3 files changed, 57 insertions, 39 deletions
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index 86a858dad7dc..58e7fded24e3 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nickle
-PORTVERSION= 2.72
+PORTVERSION= 2.73
CATEGORIES= lang
MASTER_SITES= http://www.nickle.org/release/
@@ -17,6 +17,7 @@ LICENSE= MIT
USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
# Nickle now has bindings which are likely to pull in libraries that need
# libpthread. Link to it now explicitly, or it wouldn't work at runtime.
@@ -24,4 +25,19 @@ LDFLAGS+= ${PTHREAD_LIBS}
MAN1= nickle.1
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s|examples|| ; \
+ s| -O2||' ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NIPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
+ -name "*.sgml" \) | ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} \
+ ${EXAMPLESDIR})
+ @${FIND} ${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
+ @${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endif
+
.include <bsd.port.mk>
diff --git a/lang/nickle/distinfo b/lang/nickle/distinfo
index fb3f40f694cf..cbb87ed772a9 100644
--- a/lang/nickle/distinfo
+++ b/lang/nickle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nickle-2.72.tar.gz) = 23e94ac20743006e3d11319e0a3f239a4a868274455010b217854b28f523e98a
-SIZE (nickle-2.72.tar.gz) = 485042
+SHA256 (nickle-2.73.tar.gz) = 0844d563edd27c7a461c2966cbaeacc56e12c4b2a0c3077a78a2a3c907672e37
+SIZE (nickle-2.73.tar.gz) = 511708
diff --git a/lang/nickle/pkg-plist b/lang/nickle/pkg-plist
index 706bff4bb162..7d0a33e6f799 100644
--- a/lang/nickle/pkg-plist
+++ b/lang/nickle/pkg-plist
@@ -10,6 +10,36 @@ include/nickle/opcode.h
include/nickle/ref.h
include/nickle/stack.h
include/nickle/value.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/COPYING
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cribbage.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/erat.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fourfours.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/initializer.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/is-prime.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kaiser.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/menace2.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/miller-rabin.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mutextest.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/numbers.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/polynomial.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/prime.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/qbrating.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/randtest.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/restart.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/roman.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-demo.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/skiplisttest.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smlng/COPYING
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smlng/context.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smlng/generate.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smlng/parse.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smlng/test.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/turtle/COPYING
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/turtle/snowflake.5c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/turtle/snowflake.tex
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/turtle/turtle.5c
%%DATADIR%%/COPYING
%%DATADIR%%/abort.5c
%%DATADIR%%/arc4.5c
@@ -17,53 +47,25 @@ include/nickle/value.h
%%DATADIR%%/command.5c
%%DATADIR%%/ctype.5c
%%DATADIR%%/factorial.5c
-%%DATADIR%%/prime_sieve.5c
-%%DATADIR%%/examples/COPYING
-%%DATADIR%%/examples/comb.5c
-%%DATADIR%%/examples/cribbage.5c
-%%DATADIR%%/examples/erat.5c
-%%DATADIR%%/examples/initializer.5c
-%%DATADIR%%/examples/is-prime.5c
-%%DATADIR%%/examples/kaiser.5c
-%%DATADIR%%/examples/menace2.5c
-%%DATADIR%%/examples/miller-rabin.5c
-%%DATADIR%%/examples/mutextest.5c
-%%DATADIR%%/examples/numbers.5c
-%%DATADIR%%/examples/polynomial.5c
-%%DATADIR%%/examples/prime.5c
-%%DATADIR%%/examples/qbrating.5c
-%%DATADIR%%/examples/randtest.5c
-%%DATADIR%%/examples/restart.5c
-%%DATADIR%%/examples/roman.5c
-%%DATADIR%%/examples/rsa-demo.5c
-%%DATADIR%%/examples/rsa.5c
-%%DATADIR%%/examples/skiplist.5c
-%%DATADIR%%/examples/skiplisttest.5c
-%%DATADIR%%/examples/smlng/COPYING
-%%DATADIR%%/examples/smlng/context.5c
-%%DATADIR%%/examples/smlng/generate.5c
-%%DATADIR%%/examples/smlng/parse.5c
-%%DATADIR%%/examples/smlng/test.5c
-%%DATADIR%%/examples/sort.5c
-%%DATADIR%%/examples/turtle/COPYING
-%%DATADIR%%/examples/turtle/snowflake.5c
-%%DATADIR%%/examples/turtle/snowflake.tex
-%%DATADIR%%/examples/turtle/turtle.5c
-%%DATADIR%%/examples/fourfours.5c
%%DATADIR%%/file.5c
+%%DATADIR%%/gamma.5c
%%DATADIR%%/history.5c
+%%DATADIR%%/list.5c
%%DATADIR%%/math.5c
%%DATADIR%%/mutex.5c
%%DATADIR%%/parse-args.5c
+%%DATADIR%%/prime_sieve.5c
%%DATADIR%%/printf.5c
%%DATADIR%%/prng.5c
%%DATADIR%%/process.5c
%%DATADIR%%/scanf.5c
+%%DATADIR%%/skiplist.5c
%%DATADIR%%/socket.5c
+%%DATADIR%%/sort.5c
%%DATADIR%%/string.5c
%%DATADIR%%/svg.5c
-@dirrm %%DATADIR%%/examples/turtle
-@dirrm %%DATADIR%%/examples/smlng
-@dirrm %%DATADIR%%/examples
@dirrm %%DATADIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/turtle
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/smlng
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm include/nickle