aboutsummaryrefslogtreecommitdiff
path: root/lang/nim
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-06 06:56:38 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-06 06:56:38 +0000
commit6b430afb93da2647114b54739819e21fdbe2a9a2 (patch)
tree63da7ab9f5c6e2d876c168e5751d1fd0bec8cca0 /lang/nim
parent8f7c268d78b8142dc6ddb07235cd09e02ce1c422 (diff)
downloadports-6b430afb93da2647114b54739819e21fdbe2a9a2.tar.gz
ports-6b430afb93da2647114b54739819e21fdbe2a9a2.zip
Notes
Diffstat (limited to 'lang/nim')
-rw-r--r--lang/nim/Makefile11
-rw-r--r--lang/nim/distinfo6
-rw-r--r--lang/nim/pkg-plist12
3 files changed, 21 insertions, 8 deletions
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 41e6ff4e16e0..4a006a87b96b 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nim
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= https://nim-lang.org/download/
@@ -15,13 +16,14 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
BROKEN_sparc64= fails to build: build.sh: clang: not found
LIB_DEPENDS= libpcre.so:devel/pcre
-
TEST_DEPENDS= node>=0:www/node
USES= compiler:c11 tar:xz
USE_LDCONFIG= yes
-TOOLS_DESC= Build and install nim tools
+CONFLICTS_INSTALL= nimble
+
+TOOLS_DESC= Build and install nim tools, including nimble
OPTIONS_DEFINE= DOCS TOOLS
OPTIONS_DEFAULT= DOCS TOOLS
@@ -34,7 +36,7 @@ MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
-TLIST= nimfind nimgrep nimpretty nimsuggest testament
+TLIST= nimble nimfind nimgrep nimpretty nimsuggest testament
.if ${CHOSEN_COMPILER_TYPE} == "gcc"
EXTRA_PATCHES= ${PATCHDIR}/elfv1-patch-build.sh
@@ -66,10 +68,9 @@ do-build-DOCS-on:
-d:release --nimcache=${WRKDIR}/nimcache --docCmd=skip
do-build-TOOLS-on:
- cd ${WRKSRC} && ./koch toolsNoNimble --parallelBuild=${MAKE_JOBS_NUMBER} \
+ cd ${WRKSRC} && ./koch tools --parallelBuild=${MAKE_JOBS_NUMBER} \
-d:release --nimcache=${WRKSRC}/nimcache
-
do-install:
# Revert hack to build docs
@${REINPLACE_CMD} -e '/%%NIMCACHE%%/d' \
diff --git a/lang/nim/distinfo b/lang/nim/distinfo
index 8981b6f17d15..9bb44cd36d32 100644
--- a/lang/nim/distinfo
+++ b/lang/nim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603099030
-SHA256 (nim-1.4.0.tar.xz) = be3120ab6b737f6ce0dd63fabf9e7c2c7625992b1145e5ebccf0573f3b09905d
-SIZE (nim-1.4.0.tar.xz) = 4626604
+TIMESTAMP = 1604564068
+SHA256 (nim-1.4.0.tar.xz) = 9dfba2bed31a21a5a34231016dd556b1b5e0db23c01357cfab26aa8f27a6c23d
+SIZE (nim-1.4.0.tar.xz) = 4706936
diff --git a/lang/nim/pkg-plist b/lang/nim/pkg-plist
index aa2205c6b401..4c20dd0aab04 100644
--- a/lang/nim/pkg-plist
+++ b/lang/nim/pkg-plist
@@ -1,4 +1,5 @@
bin/nim
+%%TOOLS%%bin/nimble
%%TOOLS%%bin/nimfind
%%TOOLS%%bin/nimgrep
%%TOOLS%%bin/nimpretty
@@ -176,6 +177,13 @@ lib/nim/deprecated/pure/parseopt2.nim
lib/nim/deprecated/pure/securehash.nim
lib/nim/deprecated/pure/sharedstrings.nim
lib/nim/experimental/diff.nim
+lib/nim/fusion/btreetables.nim
+lib/nim/fusion/compat.nim
+lib/nim/fusion/filepermissions.nim
+lib/nim/fusion/htmlparser.nim
+lib/nim/fusion/htmlparser/parsexml.nim
+lib/nim/fusion/htmlparser/xmltree.nim
+lib/nim/fusion/pools.nim
lib/nim/genode/alloc.nim
lib/nim/genode/env.nim
lib/nim/genode_cpp/syslocks.h
@@ -497,11 +505,13 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/base64.html
%%PORTDOCS%%%%DOCSDIR%%/html/bitops.html
%%PORTDOCS%%%%DOCSDIR%%/html/browsers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/btreetables.html
%%PORTDOCS%%%%DOCSDIR%%/html/cgi.html
%%PORTDOCS%%%%DOCSDIR%%/html/chains.html
%%PORTDOCS%%%%DOCSDIR%%/html/channels.html
%%PORTDOCS%%%%DOCSDIR%%/html/codeowners.html
%%PORTDOCS%%%%DOCSDIR%%/html/colors.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compat.html
%%PORTDOCS%%%%DOCSDIR%%/html/compiler/aliases.html
%%PORTDOCS%%%%DOCSDIR%%/html/compiler/asciitables.html
%%PORTDOCS%%%%DOCSDIR%%/html/compiler/ast.html
@@ -655,6 +665,7 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/estp.html
%%PORTDOCS%%%%DOCSDIR%%/html/exitprocs.html
%%PORTDOCS%%%%DOCSDIR%%/html/fenv.html
+%%PORTDOCS%%%%DOCSDIR%%/html/filepermissions.html
%%PORTDOCS%%%%DOCSDIR%%/html/filters.html
%%PORTDOCS%%%%DOCSDIR%%/html/gc.html
%%PORTDOCS%%%%DOCSDIR%%/html/globs.html
@@ -740,6 +751,7 @@ lib/nim/wrappers/tinyc.nim
%%PORTDOCS%%%%DOCSDIR%%/html/pathnorm.html
%%PORTDOCS%%%%DOCSDIR%%/html/pcre.html
%%PORTDOCS%%%%DOCSDIR%%/html/pegs.html
+%%PORTDOCS%%%%DOCSDIR%%/html/pools.html
%%PORTDOCS%%%%DOCSDIR%%/html/posix.html
%%PORTDOCS%%%%DOCSDIR%%/html/posix_utils.html
%%PORTDOCS%%%%DOCSDIR%%/html/postgres.html