aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml-doc
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-02-27 07:51:03 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-02-27 07:51:03 +0000
commit53d77859466cb86812e41166b584a77aeebb906f (patch)
treec0b4958297b3973d33ad367fedacce3fb5dc7c51 /lang/ocaml-doc
parente248e25ea13de8edd61023146ac7c42cb9e97694 (diff)
downloadports-53d77859466cb86812e41166b584a77aeebb906f.tar.gz
ports-53d77859466cb86812e41166b584a77aeebb906f.zip
Notes
Diffstat (limited to 'lang/ocaml-doc')
-rw-r--r--lang/ocaml-doc/Makefile31
-rw-r--r--lang/ocaml-doc/distinfo4
-rw-r--r--lang/ocaml-doc/pkg-descr4
3 files changed, 39 insertions, 0 deletions
diff --git a/lang/ocaml-doc/Makefile b/lang/ocaml-doc/Makefile
new file mode 100644
index 000000000000..172c3d7cab16
--- /dev/null
+++ b/lang/ocaml-doc/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ocaml-doc
+# Date created: 2004-02-03
+# Whom: Eugene Ossintsev
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocaml
+PORTVERSION= 3.07
+CATEGORIES= lang
+MASTER_SITES= http://caml.inria.fr/distrib/${DISTNAME}/ \
+ ftp://ftp.inria.fr/INRIA/caml-light/${DISTNAME}/ \
+ ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/caml-light/${DISTNAME}/
+PKGNAMESUFFIX= -doc
+DISTFILES= ${DISTNAME}-refman.html.tar.gz ${DISTNAME}-refman.ps.gz
+EXTRACT_ONLY= ${DISTNAME}-refman.html.tar.gz
+
+MAINTAINER= eugos@gmx.net
+COMMENT= Documentation (HTML, PS) for the Objective Caml
+
+NO_BUILD= yes
+
+PORTDOCS= *
+
+do-install:
+ @${MKDIR} ${DOCSDIR}/html/libref
+ cd ${WRKDIR}/htmlman/libref && ${INSTALL_DATA} * ${DOCSDIR}/html/libref
+ cd ${WRKDIR}/htmlman && ${INSTALL_DATA} [a-km-z]* libg* ${DOCSDIR}/html
+ ${INSTALL_DATA} ${DISTDIR}/${DISTNAME}-refman.ps.gz ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/ocaml-doc/distinfo b/lang/ocaml-doc/distinfo
new file mode 100644
index 000000000000..b955ff17f654
--- /dev/null
+++ b/lang/ocaml-doc/distinfo
@@ -0,0 +1,4 @@
+MD5 (ocaml-3.07-refman.html.tar.gz) = 9ac1f7e9e381b95504f0e7868d9fbf52
+SIZE (ocaml-3.07-refman.html.tar.gz) = 475879
+MD5 (ocaml-3.07-refman.ps.gz) = 09a9ac4bc1ec90ca4d16743ffbe76c78
+SIZE (ocaml-3.07-refman.ps.gz) = 580036
diff --git a/lang/ocaml-doc/pkg-descr b/lang/ocaml-doc/pkg-descr
new file mode 100644
index 000000000000..2ab9b881fafc
--- /dev/null
+++ b/lang/ocaml-doc/pkg-descr
@@ -0,0 +1,4 @@
+Documentation for the Objective Caml compiler and programming environment
+in HTML and PostScript formats.
+
+WWW: http://caml.inria.fr/ocaml/