aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-03 14:34:33 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-03 14:34:33 +0000
commit3aaf31100bcac63f8123647f778eb04a81bf95a6 (patch)
tree9093f0df962b0bbfa2396ed459a4601ff645a911 /lang/ocaml
parent17e94cf14231e12581eba431e40afbdd7cea16ae (diff)
downloadports-3aaf31100bcac63f8123647f778eb04a81bf95a6.tar.gz
ports-3aaf31100bcac63f8123647f778eb04a81bf95a6.zip
lang/ocaml: fix build on powerpc64le
Use GCC, like on powerpc64 and add powerpc64le entry to configure script. Approved by: tier 2 blanket
Notes
Notes: svn path=/head/; revision=560007
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile4
-rw-r--r--lang/ocaml/files/patch-configure11
2 files changed, 10 insertions, 5 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index c2328c69c240..28f9c368b7c5 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -110,6 +110,10 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-asmcomp_power_arch.ml
USE_GCC= yes
.endif
+.if ${ARCH} == powerpc64le
+USE_GCC= yes
+.endif
+
post-extract:
.if ${PORT_OPTIONS:MDOCS}
@if ! (cd ${WRKDIR} && \
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 547042cbff71..7daf041f41a4 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -25,17 +25,18 @@
esac
fi
-@@ -921,6 +923,9 @@ case "$target" in
+@@ -921,6 +923,10 @@ case "$target" in
powerpc*-*-linux*) arch=power;
if $arch64; then model=ppc64; else model=ppc; fi
system=elf;;
++ powerpc64le*-*-freebsd*) arch=power; model=ppc64le; system=bsd_elf;;
+ powerpc*-*-freebsd*) arch=power;
+ if $arch64; then model=ppc64; else model=ppc; fi
+ system=bsd_elf;;
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
s390x*-*-linux*) arch=s390x; model=z10; system=elf;;
-@@ -930,6 +935,7 @@ case "$target" in
+@@ -930,6 +936,7 @@ case "$target" in
armv6t2*-*-linux-gnueabi) arch=arm; model=armv6t2; system=linux_eabi;;
armv6*-*-linux-gnueabi) arch=arm; model=armv6; system=linux_eabi;;
armv6*-*-freebsd*) arch=arm; model=armv6; system=freebsd;;
@@ -43,7 +44,7 @@
earmv6*-*-netbsd*) arch=arm; model=armv6; system=netbsd;;
earmv7*-*-netbsd*) arch=arm; model=armv7; system=netbsd;;
armv5te*-*-linux-gnueabi) arch=arm; model=armv5te; system=linux_eabi;;
-@@ -946,6 +952,7 @@ case "$target" in
+@@ -946,6 +953,7 @@ case "$target" in
x86_64-*-darwin*) arch=amd64; system=macosx;;
x86_64-*-mingw*) arch=amd64; system=mingw;;
aarch64-*-linux*) arch=arm64; system=linux;;
@@ -51,7 +52,7 @@
x86_64-*-cygwin*) arch=amd64; system=cygwin;;
esac
-@@ -1051,10 +1058,12 @@ case "$arch,$system" in
+@@ -1051,10 +1059,12 @@ case "$arch,$system" in
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
amd64,linux) profiling='true';;
amd64,openbsd) profiling='true';;
@@ -64,7 +65,7 @@
arm,linux*) profiling='true';;
power,elf) profiling='true';;
power,bsd*) profiling='true';;
-@@ -1168,7 +1177,7 @@ fi
+@@ -1168,7 +1178,7 @@ fi
if test "$with_curses" = "yes"; then
for libs in "" "-lcurses" "-ltermcap" "-lcurses -ltermcap" "-lncurses"; do