aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-05-31 17:48:59 +0000
committerJohn Marino <marino@FreeBSD.org>2015-05-31 17:48:59 +0000
commit808304b3ad9615653c93d3c1e0d373b170bc7c48 (patch)
tree81c8b351c9b9806e396f0bc44d27c6254241ed74 /lang/ocaml
parent0576206bfc8603c113022c5b43f818c8c9b2442f (diff)
downloadports-808304b3ad9615653c93d3c1e0d373b170bc7c48.tar.gz
ports-808304b3ad9615653c93d3c1e0d373b170bc7c48.zip
lang/ocaml: Remove softvfp option from ARMv6 build (no longer required)
PR: 200102 Submitted by: Mikael Urankar Approved by: maintainer (assumed good, not able to test)
Notes
Notes: svn path=/head/; revision=388125
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 300d66297c40..2af0663aae90 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -66,7 +66,7 @@ PLIST_SUB+= DOC="@comment "
.endif
.if ${ARCH} == armv6
-CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS} -mfpu=softvfp -meabi=5"
+CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS} -meabi=5"
.else
CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS}"
.endif
@@ -97,7 +97,8 @@ CONFIGURE_ARGS+=-no-graph
OCAML_ARCH= ${ARCH:S/x86_64/amd64/:S/powerpc/power/:S/armv6/arm/}
-.if defined(NO_PROFILE) || ${OCAML_ARCH:Mpower} || ${OCAML_ARCH:Mamd64}
+.if defined(NO_PROFILE) || ${OCAML_ARCH:Mpower} || ${OCAML_ARCH:Mamd64} \
+ || ${OCAML_ARCH:Marm}
PLIST_SUB+= PROF="@comment "
.else
PLIST_SUB+= PROF=""