aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-08-23 10:12:19 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-08-23 10:12:19 +0000
commitc1f9825d443005b2c8c48720bf3f9335f65983c5 (patch)
tree8d2991f1e1e086591347c7c4217552c6086bd244 /lang/ocaml
parent03eafd06f455087baac17dfa006aa84003a23efd (diff)
downloadports-c1f9825d443005b2c8c48720bf3f9335f65983c5.tar.gz
ports-c1f9825d443005b2c8c48720bf3f9335f65983c5.zip
lang/ocaml: pet portlint, change pkg-plist as suggested by ohauer
PR: 195736 Submitted by: ohauer
Notes
Notes: svn path=/head/; revision=395081
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile8
-rw-r--r--lang/ocaml/pkg-plist6
2 files changed, 6 insertions, 8 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 2af0663aae90..33dbd8b53bec 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -38,7 +38,7 @@ CONFIGURE_ARGS= -verbose -prefix "${PREFIX}" \
-aspp "${CC} -c" \
-partialld "${LD} -r"
-OPTIONS_DEFINE= X11 THREADS DOCS EXAMPLES
+OPTIONS_DEFINE= X11 THREADS DOCS EXAMPLES
OPTIONS_DEFAULT=X11 THREADS
CMP_LIB_DESC= Install compiler libraries
PORTDOCS= htmlman ${DOCSDISTNAME}-refman.ps.gz \
@@ -66,9 +66,9 @@ PLIST_SUB+= DOC="@comment "
.endif
.if ${ARCH} == armv6
-CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS} -meabi=5"
+CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS} -meabi=5"
.else
-CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS}"
+CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS}"
.endif
.if ${PORT_OPTIONS:MTHREADS}
@@ -95,7 +95,7 @@ CONFIGURE_ARGS+=-no-graph
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manfiles"
-OCAML_ARCH= ${ARCH:S/x86_64/amd64/:S/powerpc/power/:S/armv6/arm/}
+OCAML_ARCH= ${ARCH:S/x86_64/amd64/:S/powerpc/power/:S/armv6/arm/}
.if defined(NO_PROFILE) || ${OCAML_ARCH:Mpower} || ${OCAML_ARCH:Mamd64} \
|| ${OCAML_ARCH:Marm}
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index de0953002092..8f6780fc4b5a 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -288,10 +288,8 @@ lib/ocaml/dynlink.cmx
lib/ocaml/dynlink.cmxa
lib/ocaml/dynlink.mli
%%THREADS%%lib/ocaml/event.mli
-@mode 0555
-lib/ocaml/expunge
-lib/ocaml/extract_crc
-@mode
+@(,,0555) lib/ocaml/expunge
+@(,,0555) lib/ocaml/extract_crc
lib/ocaml/filename.cmi
lib/ocaml/filename.cmx
%%PROF%%lib/ocaml/filename.p.cmx