aboutsummaryrefslogtreecommitdiff
path: root/lang/ofc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-10-02 00:56:45 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-10-02 00:56:45 +0000
commit08b56ed3285b968b3bfe79f4c8aeef23383128f7 (patch)
tree6492ab8774266fbd5c1de218603bd371be71a59e /lang/ofc
parent0951425ccbaed831970ab7584ed683da369ee597 (diff)
downloadports-08b56ed3285b968b3bfe79f4c8aeef23383128f7.tar.gz
ports-08b56ed3285b968b3bfe79f4c8aeef23383128f7.zip
Notes
Diffstat (limited to 'lang/ofc')
-rw-r--r--lang/ofc/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
index 8cf8197c6245..c8825a352c6e 100644
--- a/lang/ofc/Makefile
+++ b/lang/ofc/Makefile
@@ -18,13 +18,19 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
OPTIONS= GDBM "Add gdbm support" off \
GMP "Add gmp support" off
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
.if defined (WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
.endif
@@ -33,4 +39,4 @@ LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
LIB_DEPENDS+= gmp.4:${PORTSDIR}/math/libgmp4
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>