aboutsummaryrefslogtreecommitdiff
path: root/lang/opencoarrays
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-05-26 13:08:03 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-05-26 13:08:03 +0000
commit75256077f73ca911c812f210915b634da6b18c69 (patch)
treeb56b700d9f4aeb21292047643a7213b1b10e89b3 /lang/opencoarrays
parentabea919efc3e8d63157e8201a53fd3bab5a201c9 (diff)
downloadports-75256077f73ca911c812f210915b634da6b18c69.tar.gz
ports-75256077f73ca911c812f210915b634da6b18c69.zip
Update to 1.8.12.
PR: 219456 Submitted by: mexas@bris.ac.uk (maintainer)
Notes
Notes: svn path=/head/; revision=441781
Diffstat (limited to 'lang/opencoarrays')
-rw-r--r--lang/opencoarrays/Makefile6
-rw-r--r--lang/opencoarrays/distinfo6
-rw-r--r--lang/opencoarrays/files/patch-CMakeLists.txt51
-rw-r--r--lang/opencoarrays/files/patch-src_mpi_CMakeLists.txt39
-rw-r--r--lang/opencoarrays/files/patch-src_mpi_mpi__caf.c10
5 files changed, 5 insertions, 107 deletions
diff --git a/lang/opencoarrays/Makefile b/lang/opencoarrays/Makefile
index 9b0617c0fca8..f19dcc92ad3e 100644
--- a/lang/opencoarrays/Makefile
+++ b/lang/opencoarrays/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= opencoarrays
-PORTVERSION= 1.8.4
-PORTREVISION= 1
+PORTVERSION= 1.8.12
CATEGORIES= lang parallel
MAINTAINER= mexas@bris.ac.uk
@@ -44,8 +43,7 @@ OPENMPI2_CONFIGURE_ENV= MPI_HOME=${LOCALBASE}/mpi/openmpi2
.include <bsd.port.options.mk>
.if ${GCC_DEFAULT:R} < 5
-IGNORE= This port requires GCC 5 or higher. Add\
- DEFAULT_VERSIONS+=gcc=5 to /etc/make.conf
+IGNORE= requires GCC 5 or higher. Add DEFAULT_VERSIONS+=gcc=5 to /etc/make.conf
.endif
post-patch:
diff --git a/lang/opencoarrays/distinfo b/lang/opencoarrays/distinfo
index 8ddc009edd5f..28eeb97e7312 100644
--- a/lang/opencoarrays/distinfo
+++ b/lang/opencoarrays/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1489406657
-SHA256 (sourceryinstitute-OpenCoarrays-1.8.4_GH0.tar.gz) = c40b504a65ea2933a3b68979c4e08dc9522f22b7a8d560d734d1a8bc6bcc1ee7
-SIZE (sourceryinstitute-OpenCoarrays-1.8.4_GH0.tar.gz) = 243759
+TIMESTAMP = 1495791116
+SHA256 (sourceryinstitute-OpenCoarrays-1.8.12_GH0.tar.gz) = c1d96ed78b99c4f57b4355384b0e02b2448d86430094be118034e811133e7648
+SIZE (sourceryinstitute-OpenCoarrays-1.8.12_GH0.tar.gz) = 252181
diff --git a/lang/opencoarrays/files/patch-CMakeLists.txt b/lang/opencoarrays/files/patch-CMakeLists.txt
deleted file mode 100644
index 8ad128f37217..000000000000
--- a/lang/opencoarrays/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
---- CMakeLists.txt.orig 2017-02-07 05:19:01 UTC
-+++ CMakeLists.txt
-@@ -164,48 +164,6 @@ if ( (NOT MPI_C_FOUND) OR (NOT MPI_Fortr
- find_package( MPI REQUIRED )
- endif()
-
--#--------------------------------------------------------
--# Make sure a simple "hello world" C mpi program compiles
--#--------------------------------------------------------
--set(OLD_REQUIRED_FLAGS ${CMAKE_REQUIRED_FLAGS})
--set(CMAKE_REQUIRED_FLAGS ${MPI_C_COMPILE_FLAGS} ${MPI_C_LINK_FLAGS})
--set(OLD_INCLUDES ${CMAKE_REQUIRED_INCLUDES})
--set(CMAKE_REQUIRED_INCLUDES ${MPI_C_INCLUDE_PATH})
--set(OLD_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES})
--set(CMAKE_REQUIRED_LIBRARIES ${MPI_C_LIBRARIES})
--include (CheckCSourceCompiles)
--CHECK_C_SOURCE_COMPILES("
--#include <mpi.h>
--#include <stdio.h>
--int main(int argc, char** argv) {
-- MPI_Init(NULL, NULL);
-- int world_size;
-- MPI_Comm_size(MPI_COMM_WORLD, &world_size);
-- int world_rank;
-- MPI_Comm_rank(MPI_COMM_WORLD, &world_rank);
-- char processor_name[MPI_MAX_PROCESSOR_NAME];
-- int name_len;
-- MPI_Get_processor_name(processor_name, &name_len);
-- printf('Hello world from processor %s, rank %d out of %d processors',
-- processor_name, world_rank, world_size);
-- MPI_Finalize();
--}"
--MPI_C_COMPILES)
--set(CMAKE_REQUIRED_FLAGS ${OLD_REQUIRED_FLAGS})
--set(CMAKE_REQUIRED_INCLUDES ${OLD_INCLUDES})
--set(CMAKE_REQUIRED_LIBRARIES ${OLD_LIBRARIES})
--unset(OLD_REQUIRED_FLAGS)
--unset(OLD_INCLUDES)
--unset(OLD_LIBRARIES)
--
--if (NOT MPI_C_COMPILES)
-- message(FATAL_ERROR "MPI_C is missing! "
-- "Try setting MPI_C_COMPILER to the appropriate C compiler wrapper script and reconfigure. "
-- "i.e., `cmake -DMPI_C_COMPILER=/path/to/mpicc ..` or set it by editing the cache using "
-- "cmake-gui or ccmake."
-- )
--endif()
--
- #--------------------------------------------------------------
- # Make sure a simple "hello world" Fortran mpi program compiles
- # Try using mpi.mod first then fall back on includ 'mpif.h'
diff --git a/lang/opencoarrays/files/patch-src_mpi_CMakeLists.txt b/lang/opencoarrays/files/patch-src_mpi_CMakeLists.txt
deleted file mode 100644
index 7c17d4782208..000000000000
--- a/lang/opencoarrays/files/patch-src_mpi_CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/mpi/CMakeLists.txt.orig 2017-02-07 05:19:01 UTC
-+++ src/mpi/CMakeLists.txt
-@@ -58,15 +58,15 @@ install(TARGETS caf_mpi EXPORT OpenCoarr
- )
-
- # Install modules to standard include dir, but namespace them with compiler/version
--set (mod_install "${CMAKE_INSTALL_FULL_INCLUDEDIR}/OpenCoarrays/${CMAKE_Fortran_COMPILER_ID}/${CMAKE_Fortran_COMPILER_VERSION}")
-+set (mod_install "OpenCoarrays/${CMAKE_Fortran_COMPILER_ID}/${CMAKE_Fortran_COMPILER_VERSION}")
- install(DIRECTORY "${CMAKE_BINARY_DIR}/mod/"
-- DESTINATION "${mod_install}"
-+ DESTINATION "${CMAKE_INSTALL_FULL_INCLUDEDIR}/${mod_install}"
- FILES_MATCHING PATTERN "*.mod"
- )
-
- # Now add a link in standard include dir so that compilers will find by default... this may or may not actually be a good idea...
- if ( "${CMAKE_Fortran_COMPILER_ID}" MATCHES "GNU" )
-- INSTALL(CODE "execute_process( COMMAND ${CMAKE_COMMAND} -E create_symlink ${mod_install}/opencoarrays.mod ${CMAKE_INSTALL_FULL_INCLUDEDIR}/opencoarrays.mod )"
-+ INSTALL(CODE "execute_process( COMMAND ${CMAKE_COMMAND} -E create_symlink ${mod_install}/opencoarrays.mod \$ENV{DESTDIR}${CMAKE_INSTALL_FULL_INCLUDEDIR}/opencoarrays.mod )"
- )
- endif ()
-
-@@ -76,7 +76,7 @@ set(exe_dir ${CMAKE_BINARY_DIR}/bin_stag
- set(compiler_wrapper ${exe_dir}/caf)
- install(
- FILES "${compiler_wrapper}"
-- PERMISSIONS WORLD_EXECUTE WORLD_READ WORLD_WRITE OWNER_EXECUTE OWNER_READ OWNER_WRITE GROUP_EXECUTE GROUP_READ GROUP_WRITE
-+ PERMISSIONS WORLD_EXECUTE WORLD_READ OWNER_EXECUTE OWNER_READ GROUP_EXECUTE GROUP_READ
- DESTINATION "${CMAKE_INSTALL_BINDIR}"
- )
- file(READ ${CMAKE_CURRENT_SOURCE_DIR}/../extensions/caf-head CAF_HEADER)
-@@ -109,7 +109,7 @@ file(APPEND "${compiler_wrapper}" "${FOO
- set(caf_launcher ${exe_dir}/cafrun)
- install(
- FILES "${caf_launcher}"
-- PERMISSIONS WORLD_EXECUTE WORLD_READ WORLD_WRITE OWNER_EXECUTE OWNER_READ OWNER_WRITE GROUP_EXECUTE GROUP_READ GROUP_WRITE
-+ PERMISSIONS WORLD_EXECUTE WORLD_READ OWNER_EXECUTE OWNER_READ GROUP_EXECUTE GROUP_READ
- DESTINATION "${CMAKE_INSTALL_BINDIR}"
- )
- file(READ ${CMAKE_CURRENT_SOURCE_DIR}/../extensions/cafrun-head CAFRUN_HEADER)
diff --git a/lang/opencoarrays/files/patch-src_mpi_mpi__caf.c b/lang/opencoarrays/files/patch-src_mpi_mpi__caf.c
deleted file mode 100644
index d9b77ecbf050..000000000000
--- a/lang/opencoarrays/files/patch-src_mpi_mpi__caf.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mpi/mpi_caf.c.orig 2017-02-07 05:19:01 UTC
-+++ src/mpi/mpi_caf.c
-@@ -37,7 +37,6 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBI
- #include <stdlib.h>
- #include <string.h> /* For memcpy. */
- #include <stdarg.h> /* For variadic arguments. */
--#include <alloca.h>
- #include <unistd.h>
- #include <mpi.h>
- #include <pthread.h>