aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Data-JavaScript
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-09 18:55:53 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-09 18:55:53 +0000
commite02bab0889913f9b41d973aab74d6aa223d87632 (patch)
treedc8a71ab70e507da553b93757b680ca686d040a3 /lang/p5-Data-JavaScript
parent4ebd898c771a780828b00f53c84afe75ddad4665 (diff)
downloadports-e02bab0889913f9b41d973aab74d6aa223d87632.tar.gz
ports-e02bab0889913f9b41d973aab74d6aa223d87632.zip
Add p5-Data-JavaScript, a perl module to dump perl structures to
JavaScript code.
Notes
Notes: svn path=/head/; revision=48613
Diffstat (limited to 'lang/p5-Data-JavaScript')
-rw-r--r--lang/p5-Data-JavaScript/Makefile22
-rw-r--r--lang/p5-Data-JavaScript/distinfo1
-rw-r--r--lang/p5-Data-JavaScript/pkg-comment1
-rw-r--r--lang/p5-Data-JavaScript/pkg-descr12
-rw-r--r--lang/p5-Data-JavaScript/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/lang/p5-Data-JavaScript/Makefile b/lang/p5-Data-JavaScript/Makefile
new file mode 100644
index 000000000000..6c3dd31a22cd
--- /dev/null
+++ b/lang/p5-Data-JavaScript/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Data-JavaScript
+# Date created: 09 October 2001
+# Whom: tobez
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-JavaScript
+PORTVERSION= 1.05
+CATEGORIES= lang www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Data::JavaScript.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Data-JavaScript/distinfo b/lang/p5-Data-JavaScript/distinfo
new file mode 100644
index 000000000000..5a8307f50310
--- /dev/null
+++ b/lang/p5-Data-JavaScript/distinfo
@@ -0,0 +1 @@
+MD5 (Data-JavaScript-1.05.tar.gz) = 6bd5965cade8dacd9cc250f19243207c
diff --git a/lang/p5-Data-JavaScript/pkg-comment b/lang/p5-Data-JavaScript/pkg-comment
new file mode 100644
index 000000000000..626438a0671e
--- /dev/null
+++ b/lang/p5-Data-JavaScript/pkg-comment
@@ -0,0 +1 @@
+Data::JavaScript - Dump perl structures to JavaScript code
diff --git a/lang/p5-Data-JavaScript/pkg-descr b/lang/p5-Data-JavaScript/pkg-descr
new file mode 100644
index 000000000000..d75ac9ff6f78
--- /dev/null
+++ b/lang/p5-Data-JavaScript/pkg-descr
@@ -0,0 +1,12 @@
+This module is aimed mainly for CGI programming, when a perl script
+generates a page with client side JavaScript code that needs access to
+structures created on the server.
+
+It works by creating one line of JavaScript code per datum. Therefore,
+structures cannot be created anonymously and needed to be assigned to
+variables. This enables dumping big structures.
+
+Author: Ariel Brosh <schop@cpan.org>
+WWW: http://search.cpan.org/search?dist=Data-JavaScript
+
+-- Anton
diff --git a/lang/p5-Data-JavaScript/pkg-plist b/lang/p5-Data-JavaScript/pkg-plist
new file mode 100644
index 000000000000..42fbc5d757ff
--- /dev/null
+++ b/lang/p5-Data-JavaScript/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/JavaScript/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Data/JavaScript.pm
+lib/perl5/site_perl/%%PERL_VER%%/Data/example.pl
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data/JavaScript
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Data 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Data 2>/dev/null || true