aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Error
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-06-22 11:07:21 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-06-22 11:07:21 +0000
commitda3e946d3a21a6d8be7b028eab8ea8e4cceecb7e (patch)
tree44cea466826d82f485d42a2144bb4e54fea2085b /lang/p5-Error
parent336281b59af593c06bd6864bcb8662fdeee9d365 (diff)
downloadports-da3e946d3a21a6d8be7b028eab8ea8e4cceecb7e.tar.gz
ports-da3e946d3a21a6d8be7b028eab8ea8e4cceecb7e.zip
Import of p5-Error, which provides support for exceptions under Perl 5.
PR: ports/18826 Submitted by: Peter van Heusden <pvh@egenetics.com>
Notes
Notes: svn path=/head/; revision=29774
Diffstat (limited to 'lang/p5-Error')
-rw-r--r--lang/p5-Error/Makefile25
-rw-r--r--lang/p5-Error/distinfo1
-rw-r--r--lang/p5-Error/pkg-comment1
-rw-r--r--lang/p5-Error/pkg-descr4
-rw-r--r--lang/p5-Error/pkg-plist3
5 files changed, 34 insertions, 0 deletions
diff --git a/lang/p5-Error/Makefile b/lang/p5-Error/Makefile
new file mode 100644
index 000000000000..54d9fe7bd5d8
--- /dev/null
+++ b/lang/p5-Error/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Error
+# Date created: 24-May-2000
+# Whom: Peter van Heusden <pvh@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Error
+PORTVERSION= 0.13
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=Error
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pvh@egenetics.com
+
+USE_PERL5= YES
+
+MAN3= Error.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Error/distinfo b/lang/p5-Error/distinfo
new file mode 100644
index 000000000000..f8428c2f9c06
--- /dev/null
+++ b/lang/p5-Error/distinfo
@@ -0,0 +1 @@
+MD5 (Error-0.13.tar.gz) = 11c5b631aa7b4ce8f16f08d12b4e3be4
diff --git a/lang/p5-Error/pkg-comment b/lang/p5-Error/pkg-comment
new file mode 100644
index 000000000000..478863f87f43
--- /dev/null
+++ b/lang/p5-Error/pkg-comment
@@ -0,0 +1 @@
+Perl module to provide Error/exception support for perl: Error
diff --git a/lang/p5-Error/pkg-descr b/lang/p5-Error/pkg-descr
new file mode 100644
index 000000000000..74780697f88a
--- /dev/null
+++ b/lang/p5-Error/pkg-descr
@@ -0,0 +1,4 @@
+Error - Error/exception handling in an OO-ish way
+
+This is Graham Barr's Error module, which provides support for throwing
+and catching Error (i.e. exception) objects.
diff --git a/lang/p5-Error/pkg-plist b/lang/p5-Error/pkg-plist
new file mode 100644
index 000000000000..71a183710826
--- /dev/null
+++ b/lang/p5-Error/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Error.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Error/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Error 2>/dev/null || true