aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-JSAN/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-12-25 03:28:36 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-12-25 03:28:36 +0000
commita24be62cb935eb9e5864c48a3bf26df485871578 (patch)
treecee6b8e9f7a0672425586d2e630ecb2c39d7b37c /lang/p5-JSAN/Makefile
parent5948bc61a36850a32f4a305b0bca791070dd026b (diff)
downloadports-a24be62cb935eb9e5864c48a3bf26df485871578.tar.gz
ports-a24be62cb935eb9e5864c48a3bf26df485871578.zip
Notes
Diffstat (limited to 'lang/p5-JSAN/Makefile')
-rw-r--r--lang/p5-JSAN/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/lang/p5-JSAN/Makefile b/lang/p5-JSAN/Makefile
new file mode 100644
index 000000000000..69e6a45052d7
--- /dev/null
+++ b/lang/p5-JSAN/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-JSAN
+# Date created: 2006/12/23
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= JSAN
+PORTVERSION= 0.07
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CW/CWEST
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= JavaScript Archive Network (JSAN) Shell
+
+BUILD_DEPENDS= p5-Class-DBI-SQLite>=0:${PORTSDIR}/databases/p5-Class-DBI-SQLite \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-Class-DBI-DATA-Schema>=0:${PORTSDIR}/databases/p5-Class-DBI-DATA-Schema \
+ p5-Class-DBI-Loader>=0:${PORTSDIR}/databases/p5-Class-DBI-Loader \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-SQL-Translator>=0:${PORTSDIR}/databases/p5-SQL-Translator \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
+ p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
+ p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
+ p5-ExtUtils-AutoInstall>=0:${PORTSDIR}/devel/p5-ExtUtils-AutoInstall
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= JSAN::Shell.3 JSAN.3 JSAN::Indexer::Creator.3 JSAN::Indexer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>