aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-JavaScript-Squish
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-11 12:36:48 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-11 12:36:48 +0000
commit2393165f346d329b392638dde0f66718216b7e38 (patch)
tree36615180ecbd0deddb790a1945191834407c61cf /lang/p5-JavaScript-Squish
parent5ec0630fa3709b9eafa986cbb13eebc183c512c3 (diff)
downloadports-2393165f346d329b392638dde0f66718216b7e38.tar.gz
ports-2393165f346d329b392638dde0f66718216b7e38.zip
Add lang/p5-JavaScript-Squish 0.04, a perl module to reduce/compact
JavaScript code to as few characters as possible.
Notes
Notes: svn path=/head/; revision=144931
Diffstat (limited to 'lang/p5-JavaScript-Squish')
-rw-r--r--lang/p5-JavaScript-Squish/Makefile22
-rw-r--r--lang/p5-JavaScript-Squish/distinfo2
-rw-r--r--lang/p5-JavaScript-Squish/pkg-descr5
-rw-r--r--lang/p5-JavaScript-Squish/pkg-plist6
4 files changed, 35 insertions, 0 deletions
diff --git a/lang/p5-JavaScript-Squish/Makefile b/lang/p5-JavaScript-Squish/Makefile
new file mode 100644
index 000000000000..e323bd28bb47
--- /dev/null
+++ b/lang/p5-JavaScript-Squish/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: lang/p5-JavaScript-Squish
+# Date created: 11 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JavaScript-Squish
+PORTVERSION= 0.04
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= JavaScript
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Reduce/Compact JavaScript code to as few characters as possible
+
+PERL_CONFIGURE= yes
+
+MAN3= JavaScript::Squish.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-JavaScript-Squish/distinfo b/lang/p5-JavaScript-Squish/distinfo
new file mode 100644
index 000000000000..4ba22c99a8a6
--- /dev/null
+++ b/lang/p5-JavaScript-Squish/distinfo
@@ -0,0 +1,2 @@
+MD5 (JavaScript-Squish-0.04.tar.gz) = ee9a35368c101de2d21170c2ed36facd
+SIZE (JavaScript-Squish-0.04.tar.gz) = 10144
diff --git a/lang/p5-JavaScript-Squish/pkg-descr b/lang/p5-JavaScript-Squish/pkg-descr
new file mode 100644
index 000000000000..b6df813d0220
--- /dev/null
+++ b/lang/p5-JavaScript-Squish/pkg-descr
@@ -0,0 +1,5 @@
+This module provides methods to compact javascript source down to just
+what is needed. It can remove all comments, put everything on one line
+(semi-)safely, and remove extra whitespace.
+
+WWW: http://search.cpan.org/dist/JavaScript-Squish/
diff --git a/lang/p5-JavaScript-Squish/pkg-plist b/lang/p5-JavaScript-Squish/pkg-plist
new file mode 100644
index 000000000000..2d8cbf278c77
--- /dev/null
+++ b/lang/p5-JavaScript-Squish/pkg-plist
@@ -0,0 +1,6 @@
+bin/js_compactor
+%%SITE_PERL%%/JavaScript/Squish.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/Squish/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/Squish 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/JavaScript 2>/dev/null || true