aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Marpa-PP
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /lang/p5-Marpa-PP
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
downloadports-b59621d3ae883bef429a8fae6073bfa293a55222.tar.gz
ports-b59621d3ae883bef429a8fae6073bfa293a55222.zip
Notes
Diffstat (limited to 'lang/p5-Marpa-PP')
-rw-r--r--lang/p5-Marpa-PP/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/lang/p5-Marpa-PP/Makefile b/lang/p5-Marpa-PP/Makefile
index 45465a64c437..384b1826f3d6 100644
--- a/lang/p5-Marpa-PP/Makefile
+++ b/lang/p5-Marpa-PP/Makefile
@@ -18,12 +18,13 @@ COMMENT= Pure Perl version of Marpa
BUILD_DEPENDS= p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-PPI>=1.206:${PORTSDIR}/textproc/p5-PPI \
+ p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken
TEST_DEPENDS= p5-Test-Weaken>=3.004000:${PORTSDIR}/devel/p5-Test-Weaken
# PERL_CONFIGURE failed on Perl 5.12.4
-PERL_MODBUILD= yes
+PERL_MODBUILD= 5.10.0+
MAN3= Marpa::PP.3 \
Marpa::PP::Advanced::Bibliography.3 \
@@ -40,4 +41,19 @@ MAN3= Marpa::PP.3 \
Marpa::PP::Tracing.3 \
Marpa::PP::Vocabulary.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.21:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.21:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Storable>=2.21:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= p5-Data-Dumper>=2.125:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Storable>=2.21:${PORTSDIR}/devel/p5-Storable
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>