aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Switch
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2014-08-01 12:51:23 +0000
committerAnton Berezin <tobez@FreeBSD.org>2014-08-01 12:51:23 +0000
commit209c394d9a9fc770bbcababfee208169b0de4b93 (patch)
treece94feba4f280e5e97bae50bb1863cab108bcdf2 /lang/p5-Switch
parent35f367ed9f3a06bc4ba02393075ded5bda917548 (diff)
downloadports-209c394d9a9fc770bbcababfee208169b0de4b93.tar.gz
ports-209c394d9a9fc770bbcababfee208169b0de4b93.zip
Update to 2.17 and
apply a patch to fix interaction with modern Filter.pm. PR: 191730 Submitted by: Ting-Wei Lan
Notes
Notes: svn path=/head/; revision=363704
Diffstat (limited to 'lang/p5-Switch')
-rw-r--r--lang/p5-Switch/Makefile4
-rw-r--r--lang/p5-Switch/distinfo4
-rw-r--r--lang/p5-Switch/files/patch-Switch.pm15
3 files changed, 19 insertions, 4 deletions
diff --git a/lang/p5-Switch/Makefile b/lang/p5-Switch/Makefile
index 55dbfdd97200..1a99efaf75f0 100644
--- a/lang/p5-Switch/Makefile
+++ b/lang/p5-Switch/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= Switch
-PORTVERSION= 2.16
+PORTVERSION= 2.17
CATEGORIES= lang perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:RGARCIA
+MASTER_SITE_SUBDIR= CPAN:CHORNY
PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
diff --git a/lang/p5-Switch/distinfo b/lang/p5-Switch/distinfo
index 143410266fbb..e2806c2e3da2 100644
--- a/lang/p5-Switch/distinfo
+++ b/lang/p5-Switch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Switch-2.16.tar.gz) = 308c8f27f295906778186f14c6291923905730b46ba879c3a68fff81c37df9d8
-SIZE (Switch-2.16.tar.gz) = 13185
+SHA256 (Switch-2.17.tar.gz) = 31354975140fe6235ac130a109496491ad33dd42f9c62189e23f49f75f936d75
+SIZE (Switch-2.17.tar.gz) = 14490
diff --git a/lang/p5-Switch/files/patch-Switch.pm b/lang/p5-Switch/files/patch-Switch.pm
new file mode 100644
index 000000000000..532e6ec9ef29
--- /dev/null
+++ b/lang/p5-Switch/files/patch-Switch.pm
@@ -0,0 +1,15 @@
+--- Switch.pm 2014-08-01 14:47:54.000000000 +0200
++++ Switch.pm 2014-08-01 14:47:57.000000000 +0200
+@@ -25,9 +25,11 @@ my ($Perl5, $Perl6) = (0,0);
+
+ sub import
+ {
++ my ($class) = @_;
++ my $self = bless {}, $class;
+ $fallthrough = grep /\bfallthrough\b/, @_;
+ $offset = (caller)[2]+1;
+- filter_add({}) unless @_>1 && $_[1] eq 'noimport';
++ filter_add($self) unless @_>1 && $_[1] eq 'noimport';
+ my $pkg = caller;
+ no strict 'refs';
+ for ( qw( on_defined on_exists ) )