aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-ePerl
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /lang/p5-ePerl
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Notes
Notes: svn path=/head/; revision=29658
Diffstat (limited to 'lang/p5-ePerl')
-rw-r--r--lang/p5-ePerl/Makefile9
-rw-r--r--lang/p5-ePerl/files/patch-aa53
2 files changed, 58 insertions, 4 deletions
diff --git a/lang/p5-ePerl/Makefile b/lang/p5-ePerl/Makefile
index e9274b1f0371..352cf79a855f 100644
--- a/lang/p5-ePerl/Makefile
+++ b/lang/p5-ePerl/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= p5-ePerl
+PORTNAME= eperl
PORTVERSION= 2.2.14
CATEGORIES= lang www perl5
MASTER_SITES= http://www.engelschall.com/sw/eperl/distrib/ \
@@ -13,16 +13,17 @@ MASTER_SITES= http://www.engelschall.com/sw/eperl/distrib/ \
ftp://ftp.hyperreal.org/software/engelschall/eperl/ \
${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=Parse
-DISTNAME= eperl-2.2.14
+PKGNAMEPREFIX= p5-
MAINTAINER= rse@engelschall.com
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= Parse::ePerl.3 Apache::ePerl.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/lang/p5-ePerl/files/patch-aa b/lang/p5-ePerl/files/patch-aa
new file mode 100644
index 000000000000..1fb2377c53d9
--- /dev/null
+++ b/lang/p5-ePerl/files/patch-aa
@@ -0,0 +1,53 @@
+--- configure Sun Aug 2 09:48:40 1998
++++ configure.new Fri Jun 16 19:59:15 2000
+@@ -901,7 +901,6 @@
+ GCC=yes
+ ac_test_CFLAGS="${CFLAGS+set}"
+ ac_save_CFLAGS="$CFLAGS"
+- CFLAGS=
+ echo $ac_n "checking whether ${CC-cc} accepts -g""... $ac_c" 1>&6
+ echo "configure:907: checking whether ${CC-cc} accepts -g" >&5
+ if eval "test \"`echo '$''{'ac_cv_prog_cc_g'+set}'`\" = set"; then
+@@ -918,16 +917,17 @@
+ fi
+
+ echo "$ac_t""$ac_cv_prog_cc_g" 1>&6
++ if false; then
+ if test "$ac_test_CFLAGS" = set; then
+ CFLAGS="$ac_save_CFLAGS"
+ elif test $ac_cv_prog_cc_g = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="$CFLAGS -g -O2"
+ else
+- CFLAGS="-O2"
++ CFLAGS="$CFLAGS -O2"
+ fi
++ fi
+ else
+ GCC=
+- test "${CFLAGS+set}" = set || CFLAGS="-g"
+ fi
+
+ # Extract the first word of "ranlib", so it can be a program name with args.
+@@ -1025,11 +1025,8 @@
+ if test "${enable_debug+set}" = set; then
+ enableval="$enable_debug"
+ if test ".$ac_cv_prog_gcc" = ".yes"; then
+- CFLAGS="-Wall -g -ggdb3"
++ CFLAGS="$CFLAGS -Wall -g -ggdb3"
+ LDFLAGS="-g -ggdb3"
+-else
+- CFLAGS="-g"
+- LDFLAGS="-g"
+ fi
+ x="enabled"
+ debug=on
+@@ -1039,8 +1036,6 @@
+
+
+ else
+- CFLAGS=""
+-LDFLAGS=""
+ x=disabled
+ debug=off
+