aboutsummaryrefslogtreecommitdiff
path: root/lang/pbasic
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-24 16:05:13 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-24 16:05:13 +0000
commit71327572d4ddb65846fbfe309a4c6e8409008092 (patch)
tree0cd29170b1d8fa1ff079d33bcaa186dc273f28c8 /lang/pbasic
parentb0c2e70551e33372d1c9b42107f63f74449422b2 (diff)
downloadports-71327572d4ddb65846fbfe309a4c6e8409008092.tar.gz
ports-71327572d4ddb65846fbfe309a4c6e8409008092.zip
- respect CC/CFLAGS
PR: 162539 Submitted by: Jan Beich <jbeich@tormail.net> Approved by: maintainer Feature safe: yes
Notes
Notes: svn path=/head/; revision=286376
Diffstat (limited to 'lang/pbasic')
-rw-r--r--lang/pbasic/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/pbasic/Makefile b/lang/pbasic/Makefile
index 9d7cc43b7a51..90c4332608ac 100644
--- a/lang/pbasic/Makefile
+++ b/lang/pbasic/Makefile
@@ -22,6 +22,12 @@ MAKEFILE= makefile
MAN1= pbasic.1
PLIST_FILES= bin/pbasic
+post-patch: .SILENT
+ ${REINPLACE_CMD} -e '/^CC/s/=/?=/' \
+ -e '/^CFLAGS/{s/=/+=/;s/-O//;}' \
+ ${WRKSRC}/freebsd/makefile
+ ${ECHO_CMD} '.PHONY: $$(SYSTEMS)' >>${WRKSRC}/makefile
+
do-configure:
-cd ${WRKSRC} ; ${RM} -rf termio m68000 msdos vax pyramid ns32000 \
pdp11 cursor/cursor.dos cursor/cursor.ukc