aboutsummaryrefslogtreecommitdiff
path: root/lang/pdss
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-09-19 11:16:58 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-09-19 11:16:58 +0000
commitf5dba9dba079ac004aa2ef326f49cc780b167904 (patch)
tree448062e109d6b85abb7e43a7cf45e11eb3a3964e /lang/pdss
parent88cf70450578885b63dfea8117592a14eb9533b4 (diff)
downloadports-f5dba9dba079ac004aa2ef326f49cc780b167904.tar.gz
ports-f5dba9dba079ac004aa2ef326f49cc780b167904.zip
Notes
Diffstat (limited to 'lang/pdss')
-rw-r--r--lang/pdss/Makefile47
-rw-r--r--lang/pdss/distinfo1
-rw-r--r--lang/pdss/files/Makefile.bsd75
-rw-r--r--lang/pdss/files/patch-compiler:Makefile23
-rw-r--r--lang/pdss/files/patch-debug_utl:Makefile27
-rw-r--r--lang/pdss/files/patch-emacs:pdss-init.el49
-rw-r--r--lang/pdss/files/patch-emulator:Makefile65
-rw-r--r--lang/pdss/files/patch-emulator:config.h60
-rw-r--r--lang/pdss/files/patch-mpimos:Makefile26
-rw-r--r--lang/pdss/files/patch-pdsscmp33
-rw-r--r--lang/pdss/files/patch-pimos_utl:Makefile26
-rw-r--r--lang/pdss/files/patch-runtime:Makefile26
-rw-r--r--lang/pdss/pkg-comment1
-rw-r--r--lang/pdss/pkg-descr14
-rw-r--r--lang/pdss/pkg-plist285
15 files changed, 758 insertions, 0 deletions
diff --git a/lang/pdss/Makefile b/lang/pdss/Makefile
new file mode 100644
index 000000000000..d5c3b9e4d25a
--- /dev/null
+++ b/lang/pdss/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: PDSS-KL1
+# Date created: 07 Sep 2002
+# Whom: NINOMIYA Hideyuki <nin@Jp.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdss
+PORTVERSION= 2.52.21
+#PORTREVISION= 1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.icot.or.jp/ifs/symbolic-proc/unix/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= nin@Jp.FreeBSD.org
+
+USE_REINPLACE= YES
+
+EMACS_FILES= kl1-mode.el pdss-init.e.el pdss-init.j.el \
+ pdss-kl1cmp.el pdss-manual.el pdss.el
+
+INSTALL_DIR= ${INSTALL} -d ${_SHROWNGRP} -m 0755
+
+WRKSRC= ${WRKDIR}
+MAKE_ENV+= BSD_INSTALL_DIR="${INSTALL_DIR}"
+SCRIPTS_ENV+= BSD_INSTALL_DIR="${INSTALL_DIR}"
+
+do-configure:
+ @${CP} ${FILESDIR}/Makefile.bsd ${WRKSRC}/Makefile
+.for f in pdsscmp emulator/config.h emacs/pdss-init.el
+ @${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:" ${WRKSRC}/${f}
+.endfor
+
+post-build:
+ @${CP} ${WRKSRC}/emacs/pdss-init.el ${WRKSRC}/emacs/pdss-init.e.el
+ @${CP} ${WRKSRC}/emacs/pdss-init.el ${WRKSRC}/emacs/pdss-init.j.el
+ @${REINPLACE_CMD} -e "s:%%DOCDIR%%:doc.e:" ${WRKSRC}/emacs/pdss-init.e.el
+ @${REINPLACE_CMD} -e "s:%%DOCDIR%%:doc.j:" ${WRKSRC}/emacs/pdss-init.j.el
+
+post-install:
+ @${INSTALL_DIR} ${DATADIR}/emacs
+.for f in ${EMACS_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/emacs/${f} ${DATADIR}/emacs
+.endfor
+
+.include <bsd.port.mk>
diff --git a/lang/pdss/distinfo b/lang/pdss/distinfo
new file mode 100644
index 000000000000..f8f47a128dbc
--- /dev/null
+++ b/lang/pdss/distinfo
@@ -0,0 +1 @@
+MD5 (pdss.tar.Z) = c385081378910bb452e5f38e910572a0
diff --git a/lang/pdss/files/Makefile.bsd b/lang/pdss/files/Makefile.bsd
new file mode 100644
index 000000000000..3ba947f452ea
--- /dev/null
+++ b/lang/pdss/files/Makefile.bsd
@@ -0,0 +1,75 @@
+#
+# ports/lang/pdss/Makefile
+#
+
+BINDIR?= ${PREFIX}/bin
+PDSSROOT?= ${PREFIX}/libexec/pdss
+PDSSSHARE?= ${PREFIX}/share/pdss
+
+MAKE_SUB= ${MAKE} PDSSROOT=${PDSSROOT} PDSSSHARE=${PDSSSHARE}
+
+SUBDIRS= emulator runtime mpimos compiler \
+ debug_utl pimos_utl
+
+SUBDIRS_SHARE= macro compiler_pl doc.e doc.j \
+ sample test
+
+FILES= CONTENTS COPYRIGHT COPYRIGHT.J INSTALL \
+ INSTALL.J README README.J
+
+MACRO_FILES= pdss pimos
+
+COMPILER_PL_FILES= \
+ Makefile aux2.pl code_opt2.pl comp2.pl \
+ convert.pl gen_kl1cmp.pl index2.pl libdir.pl \
+ macro2.pl mrb4.pl norm3.pl pdss_blt.pl \
+ pdss_sys.pl pdsstrans.pl read.pl reg.pl \
+ top2.pl write2.pl
+
+DOC.E_FILES= pdss.dvi pdss.sty pdss.tex
+
+DOC.J_FILES= jmakeindex.c pdss.dvi pdss.sty pdss.tex
+
+SAMPLE_FILES= append.kl1 bestpath.kl1 bup.kl1 check.kl1 \
+ dead.kl1 espascal.kl1 etsmall.kl1 kl1cmp1.kl1 \
+ kl1cmp2.kl1 prime.kl1 prime_dd.kl1 qlay.kl1 \
+ queen.kl1 semi.kl1 tri.kl1
+
+TEST_FILES= b_arith.kl1 b_arith_e.kl1 b_arith_s.kl1 b_atom.kl1 \
+ b_atom_e.kl1 b_atom_s.kl1 b_code.kl1 b_code_e.kl1 \
+ b_code_s.kl1 b_f_arith.kl1 b_f_arith_e.kl1 b_f_arith_s.kl1 \
+ b_f_func1.kl1 b_f_func1_e.kl1 b_f_func1_s.kl1 b_f_func2.kl1 \
+ b_f_func2_e.kl1 b_f_func2_s.kl1 b_f_tfunc.kl1 b_f_tfunc_e.kl1 \
+ b_f_tfunc_s.kl1 b_func.kl1 b_func_e.kl1 b_func_s.kl1 \
+ b_logic.kl1 b_logic_e.kl1 b_logic_s.kl1 b_merge.kl1 \
+ b_pri_e.kl1 b_pri_pro.kl1 b_pri_s.kl1 b_raise_e.kl1 \
+ b_raise_s.kl1 b_string.kl1 b_string_e.kl1 b_string_s.kl1 \
+ b_type.kl1 b_type_s.kl1 b_vector.kl1 b_vector_e.kl1 \
+ b_vector_s.kl1 br_cnst.kl1 check_cnst.kl1 g_arith.kl1 \
+ g_comp.kl1 g_diff.kl1 g_f_arith.kl1 g_f_comp.kl1 \
+ g_f_func1.kl1 g_f_func2.kl1 g_f_tfunc.kl1 g_func.kl1 \
+ g_logic.kl1 g_vec_str.kl1 get_cnst.kl1 get_cnst_e.kl1 \
+ get_val.kl1 get_val_e.kl1 is_type.kl1 jnon_type.kl1 \
+ jnon_type_s.kl1 put_cnst.kl1 put_val.kl1 put_var.kl1 \
+ read_var.kl1 reuse.kl1 set_cnst.kl1 set_val.kl1 \
+ set_var.kl1 sw_type.kl1 test_cnst.kl1 type.kl1 \
+ type_s.kl1 wait_cnst.kl1 wait_cnst_s.kl1 wait_val.kl1 \
+ wait_val_s.kl1 write_cnst.kl1 write_val.kl1 write_var.kl1
+
+all:
+.for dir in ${SUBDIRS}
+ cd ${dir}; ${MAKE_SUB} all
+.endfor
+
+install:
+ ${BSD_INSTALL_DIR} ${PDSSROOT}
+.for dir in ${SUBDIRS}
+ cd ${dir}; ${MAKE_SUB} install
+.endfor
+ ${BSD_INSTALL_SCRIPT} pdsscmp ${BINDIR}
+ ${BSD_INSTALL_DIR} ${PDSSSHARE}
+ ${BSD_INSTALL_DATA} ${FILES} ${PDSSSHARE}
+.for dir in ${SUBDIRS_SHARE}
+ ${BSD_INSTALL_DIR} ${PDSSSHARE}/${dir}
+ cd ${dir} ; ${BSD_INSTALL_DATA} ${${dir:U:C/(.*)/\1_FILES/}} ${PDSSSHARE}/${dir}/
+.endfor
diff --git a/lang/pdss/files/patch-compiler:Makefile b/lang/pdss/files/patch-compiler:Makefile
new file mode 100644
index 000000000000..8cb88b533877
--- /dev/null
+++ b/lang/pdss/files/patch-compiler:Makefile
@@ -0,0 +1,23 @@
+Index: compiler/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/compiler/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- compiler/Makefile 11 Jun 2002 16:11:13 -0000 1.1.1.1
++++ compiler/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,5 @@
++COMPILERDIR = ${PDSSROOT}/compiler
++
+ PDSSCMP = ../pdsscmp +s
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -8,6 +10,8 @@
+ all: $(PARA) $(COMPILER)
+
+ install:
++ ${BSD_INSTALL_DIR} ${COMPILERDIR}
++ ${BSD_INSTALL_SCRIPT} ${COMPILER} ${COMPILERDIR}
+
+ clean:
+
diff --git a/lang/pdss/files/patch-debug_utl:Makefile b/lang/pdss/files/patch-debug_utl:Makefile
new file mode 100644
index 000000000000..3cff4ac010be
--- /dev/null
+++ b/lang/pdss/files/patch-debug_utl:Makefile
@@ -0,0 +1,27 @@
+Index: debug_utl/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/debug_utl/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- debug_utl/Makefile 11 Jun 2002 16:11:12 -0000 1.1.1.1
++++ debug_utl/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++DUTLDIR = ${PDSSROOT}/debug_utl
++DUTLSRCDIR = ${PDSSSHARE}/debug_utl
++
+ PDSSCMP = ../pdsscmp
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -8,7 +11,10 @@
+ all: $(PARA) $(DUTIL)
+
+ install:
+-
++ ${BSD_INSTALL_DIR} ${DUTLDIR}
++ ${BSD_INSTALL_SCRIPT} ${DUTIL} ${DUTLDIR}
++ ${BSD_INSTALL_DIR} ${DUTLSRCDIR}
++ ${BSD_INSTALL_DATA} *.kl1 ${DUTLSRCDIR}
+ clean:
+
+ reassm:
diff --git a/lang/pdss/files/patch-emacs:pdss-init.el b/lang/pdss/files/patch-emacs:pdss-init.el
new file mode 100644
index 000000000000..54759cef9abf
--- /dev/null
+++ b/lang/pdss/files/patch-emacs:pdss-init.el
@@ -0,0 +1,49 @@
+Index: emacs/pdss-init.el
+===================================================================
+RCS file: /ext/cvs/PDSS/emacs/pdss-init.el,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- emacs/pdss-init.el 11 Jun 2002 16:11:14 -0000 1.1.1.1
++++ emacs/pdss-init.el 1 Aug 2002 12:54:23 -0000 1.1.1.1.2.2
+@@ -1,21 +1,21 @@
+ ;; GNU Emacs initiation file for PDSS V2.5 (89.09.13)
+ ;; Copy this file to emacs/lisp directory (see Makefile),
+ ;; and insert following command into user's .emacs file.
+-;; (load "pdss-init")
++;; (require "pdss-init")
+
+ ;;-----------------------------------------------------------------------------
+ ;; Path Names.
+
+ (defconst pdss-directory-name
+- "/usr/local/src/pdss/"
++ "%%PREFIX%%/libexec/pdss/"
+ "Directory path name of PDSS.")
+
+ (defconst pdss-emacs-directory-name
+- "/usr/local/src/pdss/emacs/"
++ "%%PREFIX%%/libexec/pdss/emacs/"
+ "Directory path name of PDSS.")
+
+ (defconst pdss-command-name
+- (concat pdss-directory-name "emulator/pdss")
++ "pdss"
+ "Command path name of PDSS emulator.")
+
+ (defconst pdss-kl1cmp-compiler
+@@ -39,7 +39,7 @@
+ "Command path name of PDSS assembler.")
+
+ (defconst pdss-manual-file-name
+- (concat pdss-directory-name "doc.j/pdss.tex")
++ "%%PREFIX%%/share/pdss/%%DOCDIR%%/pdss.tex"
+ "Path name of PDSS manual file.")
+
+ ;;-----------------------------------------------------------------------------
+@@ -60,3 +60,5 @@
+
+ (setq auto-mode-alist
+ (cons '("\\.kl1$" . kl1-mode) auto-mode-alist))
++
++(provide 'pdss-init)
diff --git a/lang/pdss/files/patch-emulator:Makefile b/lang/pdss/files/patch-emulator:Makefile
new file mode 100644
index 000000000000..80e7e5059f5f
--- /dev/null
+++ b/lang/pdss/files/patch-emulator:Makefile
@@ -0,0 +1,65 @@
+Index: emulator/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/emulator/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- emulator/Makefile 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ emulator/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -5,11 +5,12 @@
+ # ALL RIGHTS RESERVED. #
+ ##########################################################################
+
+-BINDIR = /usr/local/bin
++BINDIR ?= ${PREFIX}/bin
++EMULATORDIR = ${PDSSROOT}/emulator
+
+ #CFLAGS = -g -DDEBUG
+ #CFLAGS = -g -DDEBUG -J
+-CFLAGS = -O
++CFLAGS ?= -O
+ #CFLAGS = -p
+
+ PARA =
+@@ -29,21 +30,23 @@
+ INV = pdssinv.o memory.o atom.o module.o instr.o\
+ invassm.o saveload.o float.o ctype.o
+ MERGE = pdssmerge.o
++PROG = pdssasm pdssmerge
++DATA = KL1CMP RUNTIME STARTUP
+
+-all: pdss pdssasm pdssmerge
++all: pdss ${PROG}
+
+ pdss: $(PARA) $(KL1)
+- $(CC) $(CFLAGS) -o pdss.x -D"MAKEDATE=\"`date`\"" version.c $(KL1) -lm
++ ${SETENV} LC_ALL=C $(CC) $(CFLAGS) -o pdss.x -D"MAKEDATE=\"`date`\"" version.c $(KL1) -lcompat -lm
+ mv -f pdss.x pdss
+ rm -f version.o
+
+ pdssasm: $(PARA) $(ASM)
+- $(CC) $(CFLAGS) -o pdssasm.x -D"MAKEDATE=\"`date`\"" version.c $(ASM) -lm
++ ${SETENV} LC_ALL=C $(CC) $(CFLAGS) -o pdssasm.x -D"MAKEDATE=\"`date`\"" version.c $(ASM) -lm
+ mv -f pdssasm.x pdssasm
+ rm -f version.o
+
+ pdssinv: $(PARA) $(INV)
+- $(CC) $(CFLAGS) -o pdssinv.x -D"MAKEDATE=\"`date`\"" version.c $(INV) -lm
++ ${SETENV} LC_ALL=C $(CC) $(CFLAGS) -o pdssinv.x -D"MAKEDATE=\"`date`\"" version.c $(INV) -lm
+ mv -f pdssinv.x pdssinv
+ rm -f version.o
+
+@@ -52,9 +55,10 @@
+ mv -f pdssmerge.x pdssmerge
+
+ install:
+- cp pdss $(BINDIR)/pdss.x
+- strip $(BINDIR)/pdss.x
+- mv -f $(BINDIR)/pdss.x $(BINDIR)/pdss
++ ${BSD_INSTALL_PROGRAM} pdss ${BINDIR}
++ ${BSD_INSTALL_DIR} ${EMULATORDIR}
++ ${BSD_INSTALL_PROGRAM} ${PROG} ${EMULATORDIR}
++ ${BSD_INSTALL_DATA} ${DATA} ${EMULATORDIR}
+
+ clean:
+ rm -f $(KL1) $(ASM) $(INV) $(MERGE)
diff --git a/lang/pdss/files/patch-emulator:config.h b/lang/pdss/files/patch-emulator:config.h
new file mode 100644
index 000000000000..d3e6ed58c199
--- /dev/null
+++ b/lang/pdss/files/patch-emulator:config.h
@@ -0,0 +1,60 @@
+Index: emulator/config.h
+===================================================================
+RCS file: /ext/cvs/PDSS/emulator/config.h,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.1
+diff -u -r1.1.1.1 -r1.1.1.1.2.1
+--- emulator/config.h 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ emulator/config.h 20 Jul 2002 08:30:53 -0000 1.1.1.1.2.1
+@@ -28,9 +28,12 @@
+ object. It is uesd by dynamic native code module linker.
+ (But, native code generator is not supported yet.)
+ *************************************************************************/
+-#define PDSS_LIBDIR "/usr/local/src/pdss"
+-#define PDSS_SUPDIR "/usr/local/src/pdss/emulator"
+-#define PDSS_OBJECT_FILE "/usr/local/src/pdss/emulator/pdss"
++/* #define PDSS_LIBDIR "/usr/local/src/pdss" */
++#define PDSS_LIBDIR "%%PREFIX%%/libexec/pdss"
++/* #define PDSS_SUPDIR "/usr/local/src/pdss/emulator" */
++#define PDSS_SUPDIR "%%PREFIX%%/libexec/pdss/emulator"
++/* #define PDSS_OBJECT_FILE "/usr/local/src/pdss/emulator/pdss" */
++#define PDSS_OBJECT_FILE "%%PREFIX%%/libexec/pdss/emulator/pdss"
+
+
+ /*************************************************************************
+@@ -69,8 +72,10 @@
+ area at initial startup time, then PDSS divide code area into 2
+ parts and use divided one for user codes.
+ *************************************************************************/
+-#define HEAP_SIZE 200000
+-#define CODE_SIZE 1000000
++/* #define HEAP_SIZE 200000 */
++#define HEAP_SIZE 625000
++/* #define CODE_SIZE 1000000 */
++#define CODE_SIZE 5000000
+
+
+ /*************************************************************************
+@@ -169,7 +174,8 @@
+ Configuration for atom table.
+ >> MAX_ATOMS: Maximum number of atoms.
+ *************************************************************************/
+-#define MAX_ATOMS 20000
++/* #define MAX_ATOMS 20000 */
++#define MAX_ATOMS 50000
+
+
+ /*************************************************************************
+@@ -251,6 +257,9 @@
+ INSTRUCTION_COUNT's value are `YES', PDSS counts the number of
+ branches in each KL1-B instuction.
+ *************************************************************************/
+-#define INSTRUCTION_TRACE NO
+-#define INSTRUCTION_COUNT NO
+-#define INSTRUCTION_BRANCH_COUNT NO
++/* #define INSTRUCTION_TRACE NO */
++#define INSTRUCTION_TRACE YES
++/* #define INSTRUCTION_COUNT NO */
++#define INSTRUCTION_COUNT YES
++/* #define INSTRUCTION_BRANCH_COUNT NO */
++#define INSTRUCTION_BRANCH_COUNT YES
diff --git a/lang/pdss/files/patch-mpimos:Makefile b/lang/pdss/files/patch-mpimos:Makefile
new file mode 100644
index 000000000000..2301fffbb7ba
--- /dev/null
+++ b/lang/pdss/files/patch-mpimos:Makefile
@@ -0,0 +1,26 @@
+Index: mpimos/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/mpimos/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- mpimos/Makefile 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ mpimos/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++MPIMOSDIR = ${PDSSROOT}/mpimos
++MPIMOSSRCDIR= ${PDSSSHARE}/mpimos
++
+ PDSSCMP = ../pdsscmp +s
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -17,6 +20,10 @@
+ all: $(PARA) $(MPIMOS)
+
+ install:
++ ${BSD_INSTALL_DIR} ${MPIMOSDIR}
++ ${BSD_INSTALL_SCRIPT} ${MPIMOS} ${MPIMOSDIR}
++ ${BSD_INSTALL_DIR} ${MPIMOSSRCDIR}
++ ${BSD_INSTALL_DATA} *.kl1 ${MPIMOSSRCDIR}
+
+ clean:
+
diff --git a/lang/pdss/files/patch-pdsscmp b/lang/pdss/files/patch-pdsscmp
new file mode 100644
index 000000000000..2ee2d48ad3e2
--- /dev/null
+++ b/lang/pdss/files/patch-pdsscmp
@@ -0,0 +1,33 @@
+Index: pdsscmp
+===================================================================
+RCS file: /ext/cvs/PDSS/pdsscmp,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.1
+diff -u -r1.1.1.1 -r1.1.1.1.2.1
+--- pdsscmp 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ pdsscmp 20 Jul 2002 08:30:53 -0000 1.1.1.1.2.1
+@@ -1,8 +1,19 @@
+-comp=/usr/local/src/pdss/compiler_pl/kl1cmp
+-tran=/usr/local/src/pdss/compiler_pl/pdsstrans
+-save=/usr/local/src/pdss/emulator/pdssasm
+-pdss=/usr/local/src/pdss/emulator/pdss
+-stup=/usr/local/src/pdss/emulator/KL1CMP
++#!/bin/sh
++# pdsscmp
++#
++# $Id: patch-pdsscmp,v 1.1 2002/09/07 16:33:39 nin Exp $
++
++pdssroot=%%PREFIX%%/libexec/pdss
++#comp=/usr/local/src/pdss/compiler_pl/kl1cmp
++comp=${pdssroot}/compiler_pl/kl1cmp
++#tran=/usr/local/src/pdss/compiler_pl/pdsstrans
++tran=${pdssroot}/compiler_pl/pdsstrans
++#save=/usr/local/src/pdss/emulator/pdssasm
++save=${pdssroot}/emulator/pdssasm
++#pdss=/usr/local/src/pdss/emulator/pdss
++pdss=%%PREFIX%%/bin/pdss
++#stup=/usr/local/src/pdss/emulator/KL1CMP
++stup=${pdssroot}/emulator/KL1CMP
+
+ mode=user
+ indx=1
diff --git a/lang/pdss/files/patch-pimos_utl:Makefile b/lang/pdss/files/patch-pimos_utl:Makefile
new file mode 100644
index 000000000000..79bcf0966ee1
--- /dev/null
+++ b/lang/pdss/files/patch-pimos_utl:Makefile
@@ -0,0 +1,26 @@
+Index: pimos_utl/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/pimos_utl/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- pimos_utl/Makefile 11 Jun 2002 16:11:13 -0000 1.1.1.1
++++ pimos_utl/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++PUTILDIR = ${PDSSROOT}/pimos_utl
++PUTILSRCDIR = ${PDSSSHARE}/pimos_utl
++
+ PDSSCMP = ../pdsscmp
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -9,6 +12,10 @@
+ all: $(PARA) $(PUTIL)
+
+ install:
++ ${BSD_INSTALL_DIR} ${PUTILDIR}
++ ${BSD_INSTALL_SCRIPT} ${PUTIL} ${PUTILDIR}
++ ${BSD_INSTALL_DIR} ${PUTILSRCDIR}
++ ${BSD_INSTALL_DATA} *.kl1 ${PUTILSRCDIR}
+
+ clean:
+
diff --git a/lang/pdss/files/patch-runtime:Makefile b/lang/pdss/files/patch-runtime:Makefile
new file mode 100644
index 000000000000..611418ea7ca8
--- /dev/null
+++ b/lang/pdss/files/patch-runtime:Makefile
@@ -0,0 +1,26 @@
+Index: runtime/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/runtime/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- runtime/Makefile 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ runtime/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++RUNTIMEDIR = ${PDSSROOT}/runtime
++RUNTIMESRCDIR = ${PDSSSHARE}/runtime
++
+ PDSSCMP = ../pdsscmp +s
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -7,6 +10,10 @@
+ all: $(PARA) $(RUNTIME)
+
+ install:
++ ${BSD_INSTALL_DIR} ${RUNTIMEDIR}
++ ${BSD_INSTALL_SCRIPT} ${RUNTIME} ${RUNTIMEDIR}
++ ${BSD_INSTALL_DIR} ${RUNTIMESRCDIR}
++ ${BSD_INSTALL_SCRIPT} *.kl1 ${RUNTIMESRCDIR}
+
+ clean:
+
diff --git a/lang/pdss/pkg-comment b/lang/pdss/pkg-comment
new file mode 100644
index 000000000000..b98463a12a99
--- /dev/null
+++ b/lang/pdss/pkg-comment
@@ -0,0 +1 @@
+The KL1 programming environment on an ordinary UNIX system
diff --git a/lang/pdss/pkg-descr b/lang/pdss/pkg-descr
new file mode 100644
index 000000000000..2a8d8ac14510
--- /dev/null
+++ b/lang/pdss/pkg-descr
@@ -0,0 +1,14 @@
+PDSS-KL1 System
+
+Overview:
+ The KL1 programming environment on an ordinary UNIX system.
+
+Configuration:
+ * KL1-B (byte code) interpreter written in C.
+ * KL1 to KL1-B compilers written in KL1
+ (and SICStus Prolog. [MAINTAINER comment: What is this ?])
+ * Runtime support routines (command interpreter and I/O) written in KL1.
+ * GNU Emacs Libraries - KL1-mode to edit KL1 source programs and
+ PDSS-mode to run PDSS interactively through multiple emacs buffers.
+
+WWW: http://www.icot.or.jp/ARCHIVE/Museum/IFS/HomePage-E.html
diff --git a/lang/pdss/pkg-plist b/lang/pdss/pkg-plist
new file mode 100644
index 000000000000..3e25b1b21161
--- /dev/null
+++ b/lang/pdss/pkg-plist
@@ -0,0 +1,285 @@
+bin/pdss
+bin/pdsscmp
+libexec/pdss/compiler/blt.sav
+libexec/pdss/compiler/com.sav
+libexec/pdss/compiler/comp.sav
+libexec/pdss/compiler/macarg.sav
+libexec/pdss/compiler/macro.sav
+libexec/pdss/compiler/mactbl.sav
+libexec/pdss/compiler/mrb.sav
+libexec/pdss/compiler/norm.sav
+libexec/pdss/compiler/outp.sav
+libexec/pdss/compiler/reader.sav
+libexec/pdss/compiler/reg.sav
+libexec/pdss/compiler/struct.sav
+libexec/pdss/debug_utl/mpimos_pretty_printer.sav
+libexec/pdss/debug_utl/mpimos_varchk.sav
+libexec/pdss/debug_utl/mpimos_xref.sav
+libexec/pdss/debug_utl/mpimos_xref_table.sav
+libexec/pdss/emulator/KL1CMP
+libexec/pdss/emulator/RUNTIME
+libexec/pdss/emulator/STARTUP
+libexec/pdss/emulator/pdssasm
+libexec/pdss/emulator/pdssmerge
+libexec/pdss/mpimos/boot.sav
+libexec/pdss/mpimos/builtin.sav
+libexec/pdss/mpimos/cmd_basic.sav
+libexec/pdss/mpimos/cmd_code.sav
+libexec/pdss/mpimos/cmd_debug.sav
+libexec/pdss/mpimos/cmd_dir.sav
+libexec/pdss/mpimos/cmd_env.sav
+libexec/pdss/mpimos/cmd_utl.sav
+libexec/pdss/mpimos/code_man.sav
+libexec/pdss/mpimos/dir.sav
+libexec/pdss/mpimos/dir_drv.sav
+libexec/pdss/mpimos/dummy_dir.sav
+libexec/pdss/mpimos/dummy_file.sav
+libexec/pdss/mpimos/dummy_window.sav
+libexec/pdss/mpimos/file.sav
+libexec/pdss/mpimos/file_drv.sav
+libexec/pdss/mpimos/file_man.sav
+libexec/pdss/mpimos/macro_ex.sav
+libexec/pdss/mpimos/module_pool.sav
+libexec/pdss/mpimos/mpimos_fildev.sav
+libexec/pdss/mpimos/mpimos_iodev.sav
+libexec/pdss/mpimos/mpimos_timdev.sav
+libexec/pdss/mpimos/mpimos_windev.sav
+libexec/pdss/mpimos/op.sav
+libexec/pdss/mpimos/optbl.sav
+libexec/pdss/mpimos/parser.sav
+libexec/pdss/mpimos/pool_mli.sav
+libexec/pdss/mpimos/shell.sav
+libexec/pdss/mpimos/task_monitor.sav
+libexec/pdss/mpimos/timer_man.sav
+libexec/pdss/mpimos/unparser.sav
+libexec/pdss/mpimos/utl.sav
+libexec/pdss/mpimos/window.sav
+libexec/pdss/mpimos/window_drv.sav
+libexec/pdss/mpimos/window_man.sav
+libexec/pdss/pimos_utl/comparator.sav
+libexec/pdss/pimos_utl/hasher.sav
+libexec/pdss/pimos_utl/keyed_bag.sav
+libexec/pdss/pimos_utl/keyed_sorted_bag.sav
+libexec/pdss/pimos_utl/merger.sav
+libexec/pdss/pimos_utl/multiply_keyed_bag.sav
+libexec/pdss/pimos_utl/pimos_utility_error.sav
+libexec/pdss/pimos_utl/pool.sav
+libexec/pdss/pimos_utl/queue.sav
+libexec/pdss/pimos_utl/quick_sort.sav
+libexec/pdss/pimos_utl/sorter.sav
+libexec/pdss/pimos_utl/stack.sav
+libexec/pdss/runtime/coddev.sav
+libexec/pdss/runtime/fildev.sav
+libexec/pdss/runtime/shoen.sav
+libexec/pdss/runtime/timdev.sav
+libexec/pdss/runtime/windev.sav
+share/pdss/CONTENTS
+share/pdss/COPYRIGHT
+share/pdss/COPYRIGHT.J
+share/pdss/INSTALL
+share/pdss/INSTALL.J
+share/pdss/README
+share/pdss/README.J
+share/pdss/compiler_pl/Makefile
+share/pdss/compiler_pl/aux2.pl
+share/pdss/compiler_pl/code_opt2.pl
+share/pdss/compiler_pl/comp2.pl
+share/pdss/compiler_pl/convert.pl
+share/pdss/compiler_pl/gen_kl1cmp.pl
+share/pdss/compiler_pl/index2.pl
+share/pdss/compiler_pl/libdir.pl
+share/pdss/compiler_pl/macro2.pl
+share/pdss/compiler_pl/mrb4.pl
+share/pdss/compiler_pl/norm3.pl
+share/pdss/compiler_pl/pdss_blt.pl
+share/pdss/compiler_pl/pdss_sys.pl
+share/pdss/compiler_pl/pdsstrans.pl
+share/pdss/compiler_pl/read.pl
+share/pdss/compiler_pl/reg.pl
+share/pdss/compiler_pl/top2.pl
+share/pdss/compiler_pl/write2.pl
+share/pdss/debug_utl/mpimos_pretty_printer.kl1
+share/pdss/debug_utl/mpimos_varchk.kl1
+share/pdss/debug_utl/mpimos_xref.kl1
+share/pdss/debug_utl/mpimos_xref_table.kl1
+share/pdss/doc.e/pdss.dvi
+share/pdss/doc.e/pdss.sty
+share/pdss/doc.e/pdss.tex
+share/pdss/doc.j/jmakeindex.c
+share/pdss/doc.j/pdss.dvi
+share/pdss/doc.j/pdss.sty
+share/pdss/doc.j/pdss.tex
+share/pdss/emacs/kl1-mode.el
+share/pdss/emacs/pdss-init.e.el
+share/pdss/emacs/pdss-init.j.el
+share/pdss/emacs/pdss-kl1cmp.el
+share/pdss/emacs/pdss-manual.el
+share/pdss/emacs/pdss.el
+share/pdss/macro/pdss
+share/pdss/macro/pimos
+share/pdss/mpimos/boot.kl1
+share/pdss/mpimos/builtin.kl1
+share/pdss/mpimos/cmd_basic.kl1
+share/pdss/mpimos/cmd_code.kl1
+share/pdss/mpimos/cmd_debug.kl1
+share/pdss/mpimos/cmd_dir.kl1
+share/pdss/mpimos/cmd_env.kl1
+share/pdss/mpimos/cmd_utl.kl1
+share/pdss/mpimos/code_man.kl1
+share/pdss/mpimos/dir.kl1
+share/pdss/mpimos/dir_drv.kl1
+share/pdss/mpimos/dummy_dir.kl1
+share/pdss/mpimos/dummy_file.kl1
+share/pdss/mpimos/dummy_window.kl1
+share/pdss/mpimos/file.kl1
+share/pdss/mpimos/file_drv.kl1
+share/pdss/mpimos/file_man.kl1
+share/pdss/mpimos/macro_ex.kl1
+share/pdss/mpimos/module_pool.kl1
+share/pdss/mpimos/mpimos_fildev.kl1
+share/pdss/mpimos/mpimos_iodev.kl1
+share/pdss/mpimos/mpimos_timdev.kl1
+share/pdss/mpimos/mpimos_windev.kl1
+share/pdss/mpimos/op.kl1
+share/pdss/mpimos/optbl.kl1
+share/pdss/mpimos/parser.kl1
+share/pdss/mpimos/pool_mli.kl1
+share/pdss/mpimos/shell.kl1
+share/pdss/mpimos/task_monitor.kl1
+share/pdss/mpimos/timer_man.kl1
+share/pdss/mpimos/unparser.kl1
+share/pdss/mpimos/utl.kl1
+share/pdss/mpimos/window.kl1
+share/pdss/mpimos/window_drv.kl1
+share/pdss/mpimos/window_man.kl1
+share/pdss/pimos_utl/comparator.kl1
+share/pdss/pimos_utl/hasher.kl1
+share/pdss/pimos_utl/keyed_bag.kl1
+share/pdss/pimos_utl/keyed_sorted_bag.kl1
+share/pdss/pimos_utl/merger.kl1
+share/pdss/pimos_utl/multiply_keyed_bag.kl1
+share/pdss/pimos_utl/pimos_utility_error.kl1
+share/pdss/pimos_utl/pool.kl1
+share/pdss/pimos_utl/queue.kl1
+share/pdss/pimos_utl/quick_sort.kl1
+share/pdss/pimos_utl/sorter.kl1
+share/pdss/pimos_utl/stack.kl1
+share/pdss/runtime/coddev.kl1
+share/pdss/runtime/fildev.kl1
+share/pdss/runtime/shoen.kl1
+share/pdss/runtime/timdev.kl1
+share/pdss/runtime/windev.kl1
+share/pdss/sample/append.kl1
+share/pdss/sample/bestpath.kl1
+share/pdss/sample/bup.kl1
+share/pdss/sample/check.kl1
+share/pdss/sample/dead.kl1
+share/pdss/sample/espascal.kl1
+share/pdss/sample/etsmall.kl1
+share/pdss/sample/kl1cmp1.kl1
+share/pdss/sample/kl1cmp2.kl1
+share/pdss/sample/prime.kl1
+share/pdss/sample/prime_dd.kl1
+share/pdss/sample/qlay.kl1
+share/pdss/sample/queen.kl1
+share/pdss/sample/semi.kl1
+share/pdss/sample/tri.kl1
+share/pdss/test/b_arith.kl1
+share/pdss/test/b_arith_e.kl1
+share/pdss/test/b_arith_s.kl1
+share/pdss/test/b_atom.kl1
+share/pdss/test/b_atom_e.kl1
+share/pdss/test/b_atom_s.kl1
+share/pdss/test/b_code.kl1
+share/pdss/test/b_code_e.kl1
+share/pdss/test/b_code_s.kl1
+share/pdss/test/b_f_arith.kl1
+share/pdss/test/b_f_arith_e.kl1
+share/pdss/test/b_f_arith_s.kl1
+share/pdss/test/b_f_func1.kl1
+share/pdss/test/b_f_func1_e.kl1
+share/pdss/test/b_f_func1_s.kl1
+share/pdss/test/b_f_func2.kl1
+share/pdss/test/b_f_func2_e.kl1
+share/pdss/test/b_f_func2_s.kl1
+share/pdss/test/b_f_tfunc.kl1
+share/pdss/test/b_f_tfunc_e.kl1
+share/pdss/test/b_f_tfunc_s.kl1
+share/pdss/test/b_func.kl1
+share/pdss/test/b_func_e.kl1
+share/pdss/test/b_func_s.kl1
+share/pdss/test/b_logic.kl1
+share/pdss/test/b_logic_e.kl1
+share/pdss/test/b_logic_s.kl1
+share/pdss/test/b_merge.kl1
+share/pdss/test/b_pri_e.kl1
+share/pdss/test/b_pri_pro.kl1
+share/pdss/test/b_pri_s.kl1
+share/pdss/test/b_raise_e.kl1
+share/pdss/test/b_raise_s.kl1
+share/pdss/test/b_string.kl1
+share/pdss/test/b_string_e.kl1
+share/pdss/test/b_string_s.kl1
+share/pdss/test/b_type.kl1
+share/pdss/test/b_type_s.kl1
+share/pdss/test/b_vector.kl1
+share/pdss/test/b_vector_e.kl1
+share/pdss/test/b_vector_s.kl1
+share/pdss/test/br_cnst.kl1
+share/pdss/test/check_cnst.kl1
+share/pdss/test/g_arith.kl1
+share/pdss/test/g_comp.kl1
+share/pdss/test/g_diff.kl1
+share/pdss/test/g_f_arith.kl1
+share/pdss/test/g_f_comp.kl1
+share/pdss/test/g_f_func1.kl1
+share/pdss/test/g_f_func2.kl1
+share/pdss/test/g_f_tfunc.kl1
+share/pdss/test/g_func.kl1
+share/pdss/test/g_logic.kl1
+share/pdss/test/g_vec_str.kl1
+share/pdss/test/get_cnst.kl1
+share/pdss/test/get_cnst_e.kl1
+share/pdss/test/get_val.kl1
+share/pdss/test/get_val_e.kl1
+share/pdss/test/is_type.kl1
+share/pdss/test/jnon_type.kl1
+share/pdss/test/jnon_type_s.kl1
+share/pdss/test/put_cnst.kl1
+share/pdss/test/put_val.kl1
+share/pdss/test/put_var.kl1
+share/pdss/test/read_var.kl1
+share/pdss/test/reuse.kl1
+share/pdss/test/set_cnst.kl1
+share/pdss/test/set_val.kl1
+share/pdss/test/set_var.kl1
+share/pdss/test/sw_type.kl1
+share/pdss/test/test_cnst.kl1
+share/pdss/test/type.kl1
+share/pdss/test/type_s.kl1
+share/pdss/test/wait_cnst.kl1
+share/pdss/test/wait_cnst_s.kl1
+share/pdss/test/wait_val.kl1
+share/pdss/test/wait_val_s.kl1
+share/pdss/test/write_cnst.kl1
+share/pdss/test/write_val.kl1
+share/pdss/test/write_var.kl1
+@dirrm share/pdss/test
+@dirrm share/pdss/sample
+@dirrm share/pdss/runtime
+@dirrm share/pdss/pimos_utl
+@dirrm share/pdss/mpimos
+@dirrm share/pdss/macro
+@dirrm share/pdss/emacs
+@dirrm share/pdss/doc.j
+@dirrm share/pdss/doc.e
+@dirrm share/pdss/debug_utl
+@dirrm share/pdss/compiler_pl
+@dirrm share/pdss
+@dirrm libexec/pdss/runtime
+@dirrm libexec/pdss/pimos_utl
+@dirrm libexec/pdss/mpimos
+@dirrm libexec/pdss/emulator
+@dirrm libexec/pdss/debug_utl
+@dirrm libexec/pdss/compiler
+@dirrm libexec/pdss