aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.12
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-03-05 17:56:24 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-03-05 17:56:24 +0000
commit0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd (patch)
treebceb2742d39fdcf46634bb4aa705a8a439a58bfe /lang/perl5.12
parentcf30e6a4d302b5a5be5e545ba263d39c2fc5a567 (diff)
downloadports-0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd.tar.gz
ports-0f24c25f5a0f3e0fc1eba0df35f8fe4234aa23bd.zip
Notes
Diffstat (limited to 'lang/perl5.12')
-rw-r--r--lang/perl5.12/Makefile28
-rw-r--r--lang/perl5.12/files/use.perl108
2 files changed, 19 insertions, 117 deletions
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index a7e77d1658ef..aef552feba13 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -20,7 +20,7 @@ DIST_SUBDIR= perl
PATCH_SITES= ${MASTER_SITE_LOCAL:S!$!skv/!} \
http://protey.ru/freebsd/distfiles/
-PATCHFILES= defined-or-${PERL_VER}.bz2
+PATCHFILES= defined-or-${PERL_VERSION}.bz2
MAINTAINER= skv@FreeBSD.org
COMMENT= Practical Extraction and Report Language
@@ -36,23 +36,22 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
-PERL_VER= 5.8.9
+PERL_VERSION= 5.8.9
PERL_ARCH= mach
-PERL_VERSION= ${PERL_VER}
-SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
+SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
USE_BZIP2= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
- -Darchlib=${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH} \
- -Dprivlib=${PREFIX}/lib/perl5/${PERL_VER} \
- -Dman3dir=${PREFIX}/lib/perl5/${PERL_VER}/perl/man/man3 \
+ -Darchlib=${PREFIX}/lib/perl5/${PERL_VERSION}/${PERL_ARCH} \
+ -Dprivlib=${PREFIX}/lib/perl5/${PERL_VERSION} \
+ -Dman3dir=${PREFIX}/lib/perl5/${PERL_VERSION}/perl/man/man3 \
-Dman1dir=${PREFIX}/man/man1 \
-Dsitearch=${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH} \
-Dsitelib=${PREFIX}/${SITE_PERL_REL} -Dscriptdir=${PREFIX}/bin \
- -Dsiteman3dir=${PREFIX}/lib/perl5/${PERL_VER}/man/man3 \
+ -Dsiteman3dir=${PREFIX}/lib/perl5/${PERL_VERSION}/man/man3 \
-Dsiteman1dir=${PREFIX}/man/man1 \
-Ui_malloc -Ui_iconv -Uinstallusrbinperl \
-Dcc="${CC}" -Duseshrplib -Dinc_version_list=none \
@@ -67,7 +66,7 @@ MAKE_ENV+= ${LOCALE_CLEANUP}
.include <bsd.port.pre.mk>
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
+ PERL_VER=${PERL_VERSION} \
PERL_ARCH=${PERL_ARCH} \
SITE_PERL=${SITE_PERL:S|^${LOCALBASE}/||}
@@ -135,9 +134,9 @@ PLIST_SUB+= NEED_USE_PERL="@comment "
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
.endif
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}/perl
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}/perl
-BSDPAN_DEST= ${PREFIX}/lib/perl5/${PERL_VER}/BSDPAN
+BSDPAN_DEST= ${PREFIX}/lib/perl5/${PERL_VERSION}/BSDPAN
BSDPAN_FILES= BSDPAN.pm BSDPAN/Override.pm Config.pm \
ExtUtils/MM_Unix.pm \
ExtUtils/MakeMaker.pm \
@@ -150,7 +149,6 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
post-patch:
${SED} -e 's|%%PREFIX%%|${PREFIX}|g;' \
- -e 's|%%PERL_VER%%|${PERL_VER}|g;' \
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
@@ -174,16 +172,16 @@ post-patch:
.endif
pre-su-install:
- @${RM} -f ${PREFIX}/bin/perl${PERL_VER}
+ @${RM} -f ${PREFIX}/bin/perl${PERL_VERSION}
@${RM} -f ${PREFIX}/bin/perl
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/perl${PERL_VER}
+ @${STRIP_CMD} ${PREFIX}/bin/perl${PERL_VERSION}
@${STRIP_CMD} ${PREFIX}/bin/perl
@${PREFIX}/bin/pod2man ${WRKDIR}/perl-after-upgrade >${WRKDIR}/perl-after-upgrade.1
@${INSTALL_SCRIPT} ${WRKDIR}/perl-after-upgrade ${PREFIX}/bin/perl-after-upgrade
@${INSTALL_MAN} ${WRKDIR}/perl-after-upgrade.1 ${MAN1PREFIX}/man/man1/perl-after-upgrade.1
- @${LN} -sf ${PREFIX}/bin/perl${PERL_VER} ${PREFIX}/bin/perl5
+ @${LN} -sf ${PREFIX}/bin/perl${PERL_VERSION} ${PREFIX}/bin/perl5
.for files in ${BSDPAN_FILES}
${MKDIR} ${BSDPAN_DEST}/${files:H}
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
diff --git a/lang/perl5.12/files/use.perl b/lang/perl5.12/files/use.perl
index eca7811f3a85..55b7f51ed148 100644
--- a/lang/perl5.12/files/use.perl
+++ b/lang/perl5.12/files/use.perl
@@ -28,9 +28,6 @@ if [ "x$this" = "xuse.perl" ]; then
need_spam_manpath=yes
elif [ "$1" = "system" ] ; then
need_remove_links=yes
- if [ $osreldate -lt 500036 ] ; then
- need_base_system_perl=yes
- fi
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else
@@ -42,19 +39,14 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 500036 ] ; then
- need_create_links=yes
- need_cleanup_make_conf=yes
- need_cleanup_manpath=yes
- need_spam_make_conf=yes
- need_spam_manpath=yes
- fi
+ need_create_links=yes
+ need_cleanup_make_conf=yes
+ need_cleanup_manpath=yes
+ need_spam_make_conf=yes
+ need_spam_manpath=yes
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -lt 500036 ] ; then
- need_base_system_perl=yes
- fi
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else
@@ -62,26 +54,6 @@ else
fi
fi
-link_list="
- a2p
- c2ph
- find2perl
- h2ph
- h2xs
- perlbug
- perlcc
- perldoc
- pl2pm
- pod2html
- pod2latex
- pod2man
- pod2text
- s2p
- splain
- suidperl"
-if [ $osreldate -ge 500036 ] ; then
- link_list=""
-fi
special_link_list="
perl
perl5"
@@ -89,7 +61,7 @@ special_link_list="
do_remove_links()
{
echo "Removing stale symlinks from /usr/bin..."
- for binary in $link_list $special_link_list
+ for binary in $special_link_list
do
if [ -L "/usr/bin/$binary" ] ; then
echo " Removing /usr/bin/$binary"
@@ -112,21 +84,6 @@ do_remove_links()
do_create_links()
{
echo "Creating various symlinks in /usr/bin..."
- for binary in $link_list
- do
- if [ -f "/usr/bin/$binary" ] ; then
- echo " Backing up /usr/bin/$binary as /usr/bin/$binary.freebsd"
- /bin/mv -f "/usr/bin/$binary" "/usr/bin/$binary.freebsd"
- fi
- if [ -e "/usr/bin/$binary" ] ; then
- echo " *** /usr/bin/$binary is still there, which should not happen"
- elif [ -e "$PKG_PREFIX/bin/$binary" ] ; then
- echo " Symlinking $PKG_PREFIX/bin/$binary to /usr/bin/$binary"
- /bin/ln -sf "$PKG_PREFIX/bin/$binary" "/usr/bin/$binary"
- else
- echo " *** $PKG_PREFIX/bin/$binary is not there, a symlink won't do any good"
- fi
- done
for binary in $special_link_list
do
if [ -f "/usr/bin/$binary" ] ; then
@@ -146,54 +103,6 @@ do_create_links()
echo "Done."
}
-do_base_system_perl()
-{
- echo "Restoring base system perl binaries..."
- for binary in $link_list
- do
- if [ -e "/usr/bin/$binary" ] ; then
- echo " *** /usr/bin/$binary is there, which should not happen"
- else
- if [ -f "/usr/bin/$binary.freebsd" ] ; then
- echo " Moving /usr/bin/$binary.freebsd to /usr/bin/$binary"
- /bin/mv -f "/usr/bin/$binary.freebsd" "/usr/bin/$binary"
- else
- echo " *** /usr/bin/$binary.freebsd is NOT there, nothing to restore"
- fi
- fi
- done
- for binary in $special_link_list
- do
- if [ -e "/usr/bin/$binary" ] ; then
- echo " *** /usr/bin/$binary is there, which should not happen"
- else
- bin=`echo $binary | /usr/bin/sed -e 's!perl5!perl!'`
- bin=`echo $bin | /usr/bin/sed -e 's!suidperl!sperl!'`
- bins=`/bin/ls /usr/bin/${bin}5.* 2>/dev/null | /usr/bin/sort`
- bin=""
- for b in $bins
- do
- if [ -f $b -a ! -L $b ] ; then
- bin=$b
- fi
- done
- if [ -z $bin ] ; then
- echo " *** cannot find what /usr/bin/$binary shall be restored FROM"
- elif [ -f $bin ] ; then
- echo " Hardlinking $bin to /usr/bin/$binary"
- ln -f "$bin" "/usr/bin/$binary"
- else
- echo " *** $bin is NOT there, nothing to restore"
- fi
- if [ -f "/usr/bin/$binary.freebsd" ] ; then
- echo " Removing backup copy /usr/bin/$binary.freebsd"
- rm -f "/usr/bin/$binary.freebsd"
- fi
- fi
- done
- echo "Done."
-}
-
do_post_install()
{
INCLUDEDIR=/usr/include
@@ -239,11 +148,7 @@ do_spam_make_conf()
{
echo -n "Spamming ${MAKE_CONF}..."
echo "$banner" >>${MAKE_CONF}
- echo "PERL_VER=%%PERL_VER%%" >>${MAKE_CONF}
echo "PERL_VERSION=%%PERL_VERSION%%" >>${MAKE_CONF}
- if [ $osreldate -lt 500036 ] ; then
- echo "NOPERL=yes" >>${MAKE_CONF}
- fi
echo " Done."
}
@@ -258,7 +163,6 @@ do_spam_manpath()
[ $need_remove_links ] && do_remove_links
[ $need_create_links ] && do_create_links
-[ $need_base_system_perl ] && do_base_system_perl
[ $need_post_install ] && do_post_install
[ $need_cleanup_make_conf ] && do_cleanup_make_conf
[ $need_spam_make_conf ] && do_spam_make_conf