aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.34/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-09-11 14:57:58 +0000
committerRene Ladan <rene@FreeBSD.org>2021-09-30 21:23:30 +0000
commit620968a43a5f9bb3fa98ab20f257a4c0d864caa7 (patch)
tree09bef799707f4b6e715b912429bd3b73c1addf4c /lang/perl5.34/Makefile
parentb9a93c0bf4778b9ec327c1be6f819eb1ff90ec19 (diff)
downloadports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.tar.gz
ports-620968a43a5f9bb3fa98ab20f257a4c0d864caa7.zip
Diffstat (limited to 'lang/perl5.34/Makefile')
-rw-r--r--lang/perl5.34/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/lang/perl5.34/Makefile b/lang/perl5.34/Makefile
index ed38db918ce0..044eabcd635b 100644
--- a/lang/perl5.34/Makefile
+++ b/lang/perl5.34/Makefile
@@ -52,7 +52,8 @@ CONFIGURE_ARGS= -Darchlib=${PREFIX}/${_ARCH_LIB} \
-sde \
-Ui_iconv \
-Ui_malloc \
- -Uinstallusrbinperl
+ -Uinstallusrbinperl \
+ -Accflags='-DUSE_THREAD_SAFE_LOCALE'
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.
@@ -172,10 +173,6 @@ _PERL5_DEFAULT_FILE= /tmp/PERL5_DEFAULT
.include <bsd.port.options.mk>
.sinclude "${_PERL5_DEFAULT_FILE}"
-.if ${OSVERSION} >= 1200004
-CONFIGURE_ARGS+= -Accflags='-DUSE_THREAD_SAFE_LOCALE'
-.endif
-
# if this port is default due PERL5_DEFAULT
# change PKGNAME to reflect this
.if ${PERL_VER} == ${PERL5_DEFAULT}